Airtime 2.3 - Instalacija Mint14-u ! Da li je moguća uopšte instalacija na Mintu14 ?

Posto sam na neki nacin zapoceo pricu oko zvuka i ovog programa - otvaram tamu iskljucivo za instalaciu ovog programa.

Naime zahvaljujuci @[member=‘drinx’] -u i njegovim detaljnijim angazovanjem moguće je rješiti po koji problem ovde, obzirom da čovjek to objani ipak detaljnije.

Nemama namjeru da mnimiziram niciji znacaj ovde al klasicna copy/paste upute za instalacije nekog programa NISU NEKA POMOC u nekim momentima, al doista. Pogotovo ako se radi o različitm platformam na koji se taj program treba instalirati.

I ja sam pratio upute, međutim instalacija ne prolazi na Mintu 14 ?

Zar je moguce da je linux u ovom segmentu problama, nema nekakvu alternativnu mogućnost instalacije pojedinih paketa koje Terminal jednostavno nemože da pronđa - i uporno to izbacuje !

Ili je rešenje da apsurd bude veći za svaki program koji ne prihvati recimo Mint moram instalirati PCLinux ili Ubuntu …ili lil … da bi uopšte vidio kako taj neki program radi i da li mi odgovara uopšte - i dokle tako ??

Zamolicu jos jednom svakog člana ovog foruma pocev od @Tукса, @ZDroid … (koji ima iskustva sa ovim) da detaljno postavi upute za istalaciju.

pozz svima

P.S … nadam se da ne trazim mnogo

Predložio sam kompajliranje jer deluje kao da ne radi ovo sa apt instalacijom.

Jednostavno je. :wink: Pisao sam već o tome i na blogu (http://zdroidblog.info/kompajliranje/), ali dobro, nije za sve programe isto. :wink:

Video sam da ovde ima uputstvo za kompajliranje.

http://en.flossmanua…l-installation/ - probaj ovo, ako nešto ne budeš razumeo, tu sam :slight_smile:

Ima ovde mnogo korisnika gde je moje poznavanje linuxa na 0,1% njihovog znanja, a angažovanje pri rešavanju problema je individualnog karaktera. Problem treba razumeti, reprodukovati, treba vremena i volje !

Koji je sadržaj text fajlova kod tebe u

etc/apt/sources.list.d/sourcefabric.list
etc/apt/sources.list.d/sourcefabric.list.save

Slazem se sa recenim, pogotovo vrijeme je kljucni faktor u svemu. Međutim sta ce mo sa znanjem onih cije je poznavanje linuxa mozda ispod 0,1 % - trebalo bi i njima bar malo pomoci / ili ja griješim?? Postovi, odgovori svakom onom korisniku koji se ovde prijavio zbog nekog razloga - bolje reci problema govore sve… al dobro necemo vise o tome moja intencija je bila da prije svega zamolim svakog onoga korisnika koji nesto više zna da to samo bolje pojasni. Shodno tome bolje da se uhvatimo u kostac sa ovim te da donesemo kakav pametan zakljucak da li se Airtime moze ili ne instalirati na Mint 14-u, možda ovo bude od koristi jos nekome.

Da situacija nije ružičasta po ovom pitanju (cim dobijem vremena postavicu novi posta za jos nekoliko programa ); dakle ovo se ponavlja u dosta slucajeva gdje kod program moramo naknadno instalirati tj. cim se NE nalazi u Synapticu sanse da necemo instalirati zeljeni program su velike - a ako ga kojim slucajem i instaliram desava se da nece da se starta ili ga uopšte nema na startnom meniju - tacnije nigdje ga nema ?!

ovako je stanje :

  1. etc/apt/sources.list.d/sourcefabric.list

Sourcefabric package repository

deb http://apt.sourcefabric.org/ nadia main

Debian squeeze backports repository, not needed for Ubuntu or Debian wheezy

deb http://backports.debian.org/debian-backports squeeze-backports main

2.etc/apt/sources.list.d/sourcefabric.list.save

Sourcefabric package repository

deb http://apt.sourcefabric.org/ nadia main

Debian squeeze backports repository, not needed for Ubuntu or Debian wheezy

#deb http://backports.debian.org/debian-backports squeeze-backports main

pokusam pa javim…

Otvori kao root,

gksu pluma etc/apt/sources.list.d/sourcefabric.list

i

gksu pluma etc/apt/sources.list.d/sourcefabric.list.save

zameni nadia sa quantal, snimi izmene, pokreni Synaptic i klikni na Reload ( sačekaj koliko treba ). Kucaj u pretrazi Airtime i jel ima ?

Pojavio se u Synaptic-u (u stvari ja sam u Synapticu do ovog pokusaja vec imao airtime-easy-setup valjda od svih dosadasnjih instalacija) iako sam imao nekakvih gresaka prilikom ove instalacije (sto se moze vidjeti dole)… znaci djeluje mi da radi za sad, međutim ovako brzinski sto sam mogao pogledati ovaj program radi preko browsera ??? ? jel to jedini nacin njegovog rada, ako si ga ti sebi instalirao ? Nesto mi to ne uliva povjerenje ako ce za njegov rad trebati brow.

i kako ti nalazis ove alternativne mogućnosti za resavanje ovakvih problema - posto imam jos programa koje bi pogledao kako rade al jednostavno ne mogu ih instalirati tj. dovesti ih u Synaptic

Prekonfigurišem pakete …
Izabiram prethodno neizabrani paket liquidsoap.
(Čitam bazu podataka … 253418 datoteka ili direktorija trenutno instalirano)
Raspakujem liquidsoap (iz datoteke …/liquidsoap_1.0.1+repack1-1_i386.deb) …
Izabiram prethodno neizabrani paket silan.
Raspakujem silan (iz datoteke …/silan_0.3.0~quantal~sfo-1_i386.deb) …
Izabiram prethodno neizabrani paket airtime.
Raspakujem airtime (iz datoteke …/airtime_2.3.0-1_all.deb) …
Izabiram prethodno neizabrani paket airtime-audio-samples.
Raspakujem airtime-audio-samples (iz datoteke …/airtime-audio-samples_1.9.3-2_all.deb) …
Izabiram prethodno neizabrani paket liquidsoap-plugin-faad.
Raspakujem liquidsoap-plugin-faad (iz datoteke …/liquidsoap-plugin-faad_1.0.1+repack1-1_i386.deb) …
Izabiram prethodno neizabrani paket liquidsoap-plugin-ogg.
Raspakujem liquidsoap-plugin-ogg (iz datoteke …/liquidsoap-plugin-ogg_1.0.1+repack1-1_i386.deb) …
Izabiram prethodno neizabrani paket liquidsoap-plugin-flac.
Raspakujem liquidsoap-plugin-flac (iz datoteke …/liquidsoap-plugin-flac_1.0.1+repack1-1_i386.deb) …
Izabiram prethodno neizabrani paket liquidsoap-plugin-icecast.
Raspakujem liquidsoap-plugin-icecast (iz datoteke …/liquidsoap-plugin-icecast_1.0.1+repack1-1_i386.deb) …
Izabiram prethodno neizabrani paket liquidsoap-plugin-lame.
Raspakujem liquidsoap-plugin-lame (iz datoteke …/liquidsoap-plugin-lame_1.0.1+repack1-1_i386.deb) …
Izabiram prethodno neizabrani paket liquidsoap-plugin-mad.
Raspakujem liquidsoap-plugin-mad (iz datoteke …/liquidsoap-plugin-mad_1.0.1+repack1-1_i386.deb) …
Izabiram prethodno neizabrani paket liquidsoap-plugin-pulseaudio.
Raspakujem liquidsoap-plugin-pulseaudio (iz datoteke …/liquidsoap-plugin-pulseaudio_1.0.1+repack1-1_i386.deb) …
Izabiram prethodno neizabrani paket liquidsoap-plugin-taglib.
Raspakujem liquidsoap-plugin-taglib (iz datoteke …/liquidsoap-plugin-taglib_1.0.1+repack1-1_i386.deb) …
Izabiram prethodno neizabrani paket liquidsoap-plugin-voaacenc.
Raspakujem liquidsoap-plugin-voaacenc (iz datoteke …/liquidsoap-plugin-voaacenc_1.0.1+repack1-1_i386.deb) …
Izabiram prethodno neizabrani paket liquidsoap-plugin-vorbis.
Raspakujem liquidsoap-plugin-vorbis (iz datoteke …/liquidsoap-plugin-vorbis_1.0.1+repack1-1_i386.deb) …
Izabiram prethodno neizabrani paket mp3gain.
Raspakujem mp3gain (iz datoteke …/mp3gain_1.5.2-r2-2_i386.deb) …
Izabiram prethodno neizabrani paket vorbisgain.
Raspakujem vorbisgain (iz datoteke …/vorbisgain_0.37-2_i386.deb) …
Obrađujem okidače za doc-base …
Procesiranje 1 dodana doc-base datoteka…
Registriranje dokumenata sa scrollkeeper…
Obrađujem okidače za man-db …
Obrađujem okidače za ureadahead …
ureadahead will be reprofiled on next reboot
Obrađujem okidače za bamfdaemon …
Rebuilding /usr/share/applications/bamf.index…
Obrađujem okidače za desktop-file-utils …
Obrađujem okidače za menu …
Podešavam paket airtime-easy-setup (2.2.1-1)…
Installing Sourcefabric package signing key…
OK
Setting up Airtime for Etc/UTC timezone…
Setting Icecast and Airtime domain names to KANCELARIJA…
Setting defaults for non-interactive installation…
dpkg: error processing airtime-easy-setup (–configure):
podproces installirana post-installation skripta je prijavio grešku sa statusom 1
Podešavam paket liquidsoap (1.0.1+repack1-1)…Nije napravljen apport izvještaj jer je dosegnut maksimalni broj izvještaja

Dodavanje grupe liquidsoap' (GID 130) ... Gotovo. Dodavanje sistemskog korisnika liquidsoap’ (UID 118) …
Dodavanje novog korisnika liquidsoap' (UID 118) sa grupom liquidsoap’ …
Kreiranje početnog direktorijuma `/usr/share/liquidsoap’ …
Starting liquidsoap channels: no script found in /etc/liquidsoap
Podešavam paket silan (0.3.0~quantal~sfo-1)…
Podešavam paket airtime-audio-samples (1.9.3-2)…
/var/lib/dpkg/info/airtime-audio-samples.postinst: linija 13: airtime-import: nisam pronašao komandu
dpkg: error processing airtime-audio-samples (–configure):
podproces installirana post-installation skripta je prijavio grešku sa statusom 127
Nije napravljen apport izvještaj jer je dosegnut maksimalni broj izvještaja
Podešavam paket mp3gain (1.5.2-r2-2)…
Podešavam paket vorbisgain (0.37-2)…
Obrađujem okidače za ureadahead …
Podešavam paket liquidsoap-plugin-ogg (1.0.1+repack1-1)…
Podešavam paket liquidsoap-plugin-flac (1.0.1+repack1-1)…
Podešavam paket liquidsoap-plugin-icecast (1.0.1+repack1-1)…
Podešavam paket liquidsoap-plugin-lame (1.0.1+repack1-1)…
Podešavam paket liquidsoap-plugin-mad (1.0.1+repack1-1)…
Podešavam paket liquidsoap-plugin-pulseaudio (1.0.1+repack1-1)…
Podešavam paket liquidsoap-plugin-taglib (1.0.1+repack1-1)…
Podešavam paket liquidsoap-plugin-voaacenc (1.0.1+repack1-1)…
Podešavam paket liquidsoap-plugin-vorbis (1.0.1+repack1-1)…
Podešavam paket airtime (2.3.0-1)…
Setting up apache2…
Enabling site airtime-vhost.
To activate the new configuration, you need to run:
service apache2 reload
Enabling module rewrite.
To activate the new configuration, you need to run:
service apache2 restart
Site default disabled.
To activate the new configuration, you need to run:
service apache2 reload
Configuring php5…
Setting up icecast2…
Restarting icecast2: Starting icecast2
Detaching from the console
icecast2.
Setting up monit configuration…

  • Stopping daemon monitor monit [ OK ]
  • Starting daemon monitor monit [ OK ]
  • Restarting web server apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
    … waiting .apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
    [ OK ]
    Creating symlink for Liquidsoap…
  • Making sure /etc/default/locale is set properly
    LANG=“bs_BA.UTF-8”
  • None found.
  • Temporarily stopping any previous running services

******************************** Install Begin *********************************
Ensuring python-virtualenv version > 1.4.8…Success!

*** Creating Virtualenv for Airtime ***
Already using interpreter /usr/bin/python
The --no-site-packages flag is deprecated; it is now the default behavior.
New python executable in /usr/lib/airtime/airtime_virtualenv/bin/python
Installing distribute…done.
Installing pip…done.

*** Installing Python Libraries ***
Unpacking /var/lib/airtime/tmp/python_apps/python-virtualenv/airtime_virtual_env.pybundle
Downloading/unpacking pytz
Running setup.py egg_info for package pytz

warning: no files found matching ‘*.pot’ under directory ‘pytz’
warning: no previously-included files found matching ‘test_zdump.py’
Requirement already satisfied (use --upgrade to upgrade): wsgiref in /usr/lib/python2.7
Downloading/unpacking configobj
Running setup.py egg_info for package configobj

Downloading/unpacking mutagen
Running setup.py egg_info for package mutagen

Requirement already satisfied (use --upgrade to upgrade): argparse in /usr/lib/python2.7
Downloading/unpacking amqplib
Running setup.py egg_info for package amqplib

Downloading/unpacking pyinotify
Running setup.py egg_info for package pyinotify

Downloading/unpacking poster
Running setup.py egg_info for package poster

Downloading/unpacking PyDispatcher
Running setup.py egg_info for package PyDispatcher

warning: no previously-included files matching ‘*.bat’ found anywhere in distribution
warning: no previously-included files matching ‘./CVS’ found anywhere in distribution
warning: no previously-included files matching ‘.cvsignore’ found anywhere in distribution
Downloading/unpacking docopt
Running setup.py egg_info for package docopt

Downloading/unpacking kombu
Running setup.py egg_info for package kombu

Downloading/unpacking anyjson
Running setup.py egg_info for package anyjson

Installing collected packages: pytz, configobj, mutagen, amqplib, pyinotify, poster, PyDispatcher, docopt, kombu, anyjson
Running setup.py install for pytz

warning: no files found matching ‘*.pot’ under directory ‘pytz’
warning: no previously-included files found matching ‘test_zdump.py’
Running setup.py install for configobj

Running setup.py install for mutagen
changing mode of build/scripts-2.7/mutagen-inspect from 644 to 755
changing mode of build/scripts-2.7/mid3v2 from 644 to 755
changing mode of build/scripts-2.7/moggsplit from 644 to 755
changing mode of build/scripts-2.7/mid3iconv from 644 to 755
changing mode of build/scripts-2.7/mutagen-pony from 644 to 755

changing mode of /usr/lib/airtime/airtime_virtualenv/bin/mutagen-inspect to 755
changing mode of /usr/lib/airtime/airtime_virtualenv/bin/mid3v2 to 755
changing mode of /usr/lib/airtime/airtime_virtualenv/bin/moggsplit to 755
changing mode of /usr/lib/airtime/airtime_virtualenv/bin/mid3iconv to 755
changing mode of /usr/lib/airtime/airtime_virtualenv/bin/mutagen-pony to 755
Running setup.py install for amqplib

Running setup.py install for pyinotify

Running setup.py install for poster

Running setup.py install for PyDispatcher

warning: no previously-included files matching ‘*.bat’ found anywhere in distribution
warning: no previously-included files matching ‘./CVS’ found anywhere in distribution
warning: no previously-included files matching ‘.cvsignore’ found anywhere in distribution
Running setup.py install for docopt

Running setup.py install for kombu

Running setup.py install for anyjson

Successfully installed pytz configobj mutagen amqplib pyinotify poster PyDispatcher docopt kombu anyjson
Cleaning up…

*** Patching Python Libraries ***

  • Patching virtualenv libraries in /usr/lib/airtime/airtime_virtualenv/lib/python2.7

—Applying Patches for mutagen—
patching file site-packages/mutagen/mp3.py
Hunk #1 succeeded at 205 (offset -4 lines).
patching file site-packages/mutagen/mp3.py
Hunk #2 succeeded at 169 (offset -4 lines).

  • Checking for user pypo

  • Creating user pypo

  • Creating INI files

  • Initializing INI files

  • Airtime Version: 2.3.0

  • Storage directory setup

  • Directory /srv/airtime/stor created

  • Giving Apache permission to access /srv/airtime/stor

  • Directory /srv/airtime/stor/organize created

  • Giving Apache permission to access /srv/airtime/stor/organize

  • Checking database for correct encoding

  • Database Installation

  • Creating Airtime database user

  • Database user ‘airtime’ created.

  • Creating Airtime database

  • Database ‘airtime’ created.

  • Postgres scripting language already installed

  • Creating database tables

  • Setting Airtime version

  • Inserting stor directory location /srv/airtime/stor/ into music_dirs table

  • Creating /etc/airtime

  • Creating /etc/monit/conf.d/monit-airtime-generic.cfg

  • Creating /etc/cron.d/airtime-crons

  • Creating /usr/lib/airtime

  • Creating symbolic links in /usr/bin

  • Creating /var/log/airtime

  • Creating /usr/share/airtime

  • Creating /var/log/airtime

  • Creating /var/tmp/airtime
    Generating locales
    Generating locales…
    cs_CZ.UTF-8… done
    Generation complete.
    Generating locales…
    de_DE.UTF-8… done
    Generation complete.
    Generating locales…
    el_GR.UTF-8… done
    Generation complete.
    Generating locales…
    en_CA.UTF-8… done
    Generation complete.
    Generating locales…
    en_GB.UTF-8… done
    Generation complete.
    Generating locales…
    en_US.UTF-8… up-to-date
    Generation complete.
    Generating locales…
    es_ES.UTF-8… done
    Generation complete.
    Generating locales…
    fr_FR.UTF-8… done
    Generation complete.
    Generating locales…
    it_IT.UTF-8… done
    Generation complete.
    Generating locales…
    ko_KR.UTF-8… done
    Generation complete.
    Generating locales…
    pl_PL.UTF-8… done
    Generation complete.
    Generating locales…
    pt_BR.UTF-8… done
    Generation complete.
    Generating locales…
    ru_RU.UTF-8… done
    Generation complete.
    Generating locales…
    zh_CN.UTF-8… done
    Generation complete.

  • Waiting for media-monitor processes to start…
    Starting Airtime Media Monitor: Done.

  • Detecting OS: … Found Linux Mint 14 Nadia (nadia) on i386 architecture

  • Creating symlink to Liquidsoap binary

  • Clearing previous pypo cache

  • Waiting for pypo processes to start…

  • Stopping daemon monitor monit [ OK ]

  • Starting daemon monitor monit [ OK ]

*** Verifying your system environment, running airtime-check-system ***
AIRTIME_STATUS_URL = http://KANCELARIJA:8…key/%%api_key%%
AIRTIME_SERVER_RESPONDING = OK
KERNEL_VERSION = 3.5.0-17-generic
MACHINE_ARCHITECTURE = i686
TOTAL_MEMORY_MBYTES = 1018480
TOTAL_SWAP_MBYTES = 1038332
AIRTIME_VERSION = 2.3.0
OS = Linux Mint 14 Nadia i686
CPU = Intel® Celeron® CPU 2.66GHz
WEB_SERVER = Apache/2.2.22 (Ubuntu)
PLAYOUT_ENGINE_PROCESS_ID = 6341
PLAYOUT_ENGINE_RUNNING_SECONDS = 18
PLAYOUT_ENGINE_MEM_PERC = 1.0%
PLAYOUT_ENGINE_CPU_PERC = 0.9%
LIQUIDSOAP_PROCESS_ID = 6372
LIQUIDSOAP_RUNNING_SECONDS = 18
LIQUIDSOAP_MEM_PERC = 1.3%
LIQUIDSOAP_CPU_PERC = 0.0%
MEDIA_MONITOR_PROCESS_ID = 6274
MEDIA_MONITOR_RUNNING_SECONDS = 20
MEDIA_MONITOR_MEM_PERC = 0.9%
MEDIA_MONITOR_CPU_PERC = 0.0%
RABBITMQ_PROCESS_ID = 1581
RABBITMQ_RUNNING_SECONDS = 2850
RABBITMQ_MEM_PERC = 0.5%
RABBITMQ_CPU_PERC = 0.0%
– Your installation of Airtime looks OK!

******************************* Install Complete *******************************
Podešavam paket liquidsoap-plugin-faad (1.0.1+repack1-1)…
Obrađujem okidače za menu …
Ustanovljene su greške prilikom obrade:
airtime-easy-setup
airtime-audio-samples
E: Sub-process /usr/bin/dpkg returned an error code (1)
Nisam uspeo da instaliram paket. Pokušavam da oporavim:
Podešavam paket airtime-audio-samples (1.9.3-2)…
Cannot find file or path: /usr/share/airtime/audio-samples
Podešavam paket airtime-easy-setup (2.2.1-1)…
Installing Sourcefabric package signing key…
OK
Setting up Airtime for Etc/UTC timezone…
sed: ne može čitati /usr/share/airtime/debconf-selections: Ne postoji takva datoteka ili direktorijum
dpkg: error processing airtime-easy-setup (–configure):
podproces installirana post-installation skripta je prijavio grešku sa statusom 2
Ustanovljene su greške prilikom obrade:
airtime-easy-setup