AMD drajveri

Posto se ovaj Ubuntu vucara pomislih da je do drajvere za graficku pa sam skinuo AMD-ov draver verzije 13.4 i otvorio ga medjutim dobijam prilozeni dokument. Posto nisam toliko cackao po netu o drajverima za Linux molio bih za neki savet u vezi njih kao i za neku preporuku istih. Grafa je Sapphire Radeon 7870.

Corruption OK :). Ubuntu verzija? XFCE je DE pretpostavljam?

Za opensource radeon drajver, a za tu karticu treba ti sve potpuno novo, ceo graphics stack. Baš, baš, po krilatici - novo je bolje :chiffa:.

A što se fglrxa tiče, to je potpuno drugačije - starije je bolje, recimo LTS , ali noviji drajver pošto je novija kartica :slight_smile: .

I ako možeš logove da daš /var/log/Xorg.0.log i izlaz komande

lspci -knn

Inače taj fglrx instaler se ne otvara tako, niti se instalira na klik :). E sad ne znam interne verzije po kojima Ubuntu obeležava ove drajvere, što mi baš i ne pomaže, možda ima i ovaj gotov paket iz repoa.

http://packages.ubun…om/raring/fglrx
http://packages.ubun…g/fglrx-updates

Evo vodiča, tu bar pominju 13.4 i ovaj instaler, a ne kao u paketima što obeležavaju :connie_pumpkinsmile:

http://wiki.cchtml.com/index.php/Ubuntu_Precise_Installation_Guide#Installing_Catalyst_Manually_.28from_AMD.2FATI.27s_site.29

[email protected]:~$ /var/log/Xorg.0.log
bash: /var/log/Xorg.0.log: Permission denied
[email protected]:~$ lspci -knn
00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] nee ATI RD890 PCI to PCI bridge (external gfx0 port B) [1002:5a14] (rev 02)
Subsystem: Micro-Star International Co., Ltd. Device [1462:7693]
00:02.0 PCI bridge [0604]: Advanced Micro Devices [AMD] nee ATI RD890 PCI to PCI bridge (PCI express gpp port B) [1002:5a16]
Kernel driver in use: pcieport
Kernel modules: shpchp
00:04.0 PCI bridge [0604]: Advanced Micro Devices [AMD] nee ATI RD890 PCI to PCI bridge (PCI express gpp port D) [1002:5a18]
Kernel driver in use: pcieport
Kernel modules: shpchp
00:11.0 SATA controller [0106]: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] [1002:4391] (rev 40)
Subsystem: Micro-Star International Co., Ltd. Device [1462:7693]
Kernel driver in use: ahci
Kernel modules: ahci
00:12.0 USB controller [0c03]: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397]
Subsystem: Micro-Star International Co., Ltd. Device [1462:7693]
Kernel driver in use: ohci_hcd
00:12.2 USB controller [0c03]: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396]
Subsystem: Micro-Star International Co., Ltd. Device [1462:7693]
Kernel driver in use: ehci_hcd
00:13.0 USB controller [0c03]: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397]
Subsystem: Micro-Star International Co., Ltd. Device [1462:7693]
Kernel driver in use: ohci_hcd
00:13.2 USB controller [0c03]: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396]
Subsystem: Micro-Star International Co., Ltd. Device [1462:7693]
Kernel driver in use: ehci_hcd
00:14.0 SMBus [0c05]: Advanced Micro Devices [AMD] nee ATI SBx00 SMBus Controller [1002:4385] (rev 42)
Subsystem: Micro-Star International Co., Ltd. Device [1462:7693]
Kernel driver in use: piix4_smbus
Kernel modules: sp5100_tco, i2c-piix4
00:14.2 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) [1002:4383] (rev 40)
Subsystem: Micro-Star International Co., Ltd. Device [1462:d693]
Kernel driver in use: snd_hda_intel
Kernel modules: snd-hda-intel
00:14.3 ISA bridge [0601]: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 LPC host controller [1002:439d] (rev 40)
Subsystem: Micro-Star International Co., Ltd. Device [1462:7693]
00:14.4 PCI bridge [0604]: Advanced Micro Devices [AMD] nee ATI SBx00 PCI to PCI Bridge [1002:4384] (rev 40)
00:14.5 USB controller [0c03]: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI2 Controller [1002:4399]
Subsystem: Micro-Star International Co., Ltd. Device [1462:7693]
Kernel driver in use: ohci_hcd
00:15.0 PCI bridge [0604]: Advanced Micro Devices [AMD] nee ATI SB700/SB800/SB900 PCI to PCI bridge (PCIE port 0) [1002:43a0]
Kernel driver in use: pcieport
Kernel modules: shpchp
00:16.0 USB controller [0c03]: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397]
Subsystem: Micro-Star International Co., Ltd. Device [1462:7693]
Kernel driver in use: ohci_hcd
00:16.2 USB controller [0c03]: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396]
Subsystem: Micro-Star International Co., Ltd. Device [1462:7693]
Kernel driver in use: ehci_hcd
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] Family 15h Processor Function 0 [1022:1600]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] Family 15h Processor Function 1 [1022:1601]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] Family 15h Processor Function 2 [1022:1602]
Kernel modules: amd64_edac_mod
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] Family 15h Processor Function 3 [1022:1603]
Kernel driver in use: k10temp
Kernel modules: k10temp
00:18.4 Host bridge [0600]: Advanced Micro Devices [AMD] Family 15h Processor Function 4 [1022:1604]
Kernel driver in use: fam15h_power
Kernel modules: fam15h_power
00:18.5 Host bridge [0600]: Advanced Micro Devices [AMD] Family 15h Processor Function 5 [1022:1605]
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI PITCAIRN [Radeon HD 7800] [1002:6818]
Subsystem: PC Partner Limited Device [174b:e217]
Kernel driver in use: radeon
Kernel modules: radeon
01:00.1 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI Device [1002:aab0]
Subsystem: PC Partner Limited Device [174b:aab0]
Kernel driver in use: snd_hda_intel
Kernel modules: snd-hda-intel
02:00.0 USB controller [0c03]: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller [1b21:1042]
Subsystem: Micro-Star International Co., Ltd. Device [1462:7693]
Kernel driver in use: xhci_hcd
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)
Subsystem: Micro-Star International Co., Ltd. Device [1462:7693]
Kernel driver in use: r8169
Kernel modules: r8169

[CODE]
[email protected]:~$ wget http://www2.ati.com/drivers/linux/amd-catalyst-13.4-linux-x86.x86_64.zip
–2013-05-28 19:55:04-- http://www2.ati.com/drivers/linux/amd-catalyst-13.4-linux-x86.x86_64.zip
Resolving www2.ati.com (www2.ati.com)… 12.120.136.146
Connecting to www2.ati.com (www2.ati.com)|12.120.136.146|:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 122588023 (117M) [application/zip]
Saving to: amd-catalyst-13.4-linux-x86.x86_64.zip' 100%[======================================>] 122,588,023 617K/s in 3m 17s 2013-05-28 19:58:22 (607 KB/s) - amd-catalyst-13.4-linux-x86.x86_64.zip’ saved [122588023/122588023]
[email protected]:~$ unzip amd-catalyst-13.4-linux-x86.x86_64.zip
Archive: amd-catalyst-13.4-linux-x86.x86_64.zip
inflating: amd-catalyst-13.4-linux-x86.x86_64.run
[email protected]:~$ chmod +x amd-catalyst-13.4-linux-x86.x86_64.run
[email protected]:~$ chmod +x amd-catalyst-13.4-linux-x86.x86_64.run
[email protected]:~$ sudo sh ./amd-catalyst-13.4-linux-x86.x86_64.run --buildpkg Ubuntu/precise
[sudo] password for jablanovic:
Created directory fglrx-install.ba1MyU
Verifying archive integrity… All good.
Uncompressing AMD Catalyst™ Proprietary Driver-12.104…

AMD Catalyst™ Proprietary Driver Installer/Packager

Generating package: Ubuntu/precise
apt 0.9.7.5ubuntu5.1 for amd64 compiled on Mar 13 2013 21:25:25
Usage: apt-get [options] command
apt-get [options] install|remove pkg1 [pkg2 …]
apt-get [options] source pkg1 [pkg2 …]
apt-get is a simple command line interface for downloading and
installing packages. The most frequently used commands are update
and install.
Commands:
update - Retrieve new lists of packages
upgrade - Perform an upgrade
install - Install new packages (pkg is libc6 not libc6.deb)
remove - Remove packages
autoremove - Remove automatically all unused packages
purge - Remove packages and config files
source - Download source archives
build-dep - Configure build-dependencies for source packages
dist-upgrade - Distribution upgrade, see apt-get(8)
dselect-upgrade - Follow dselect selections
clean - Erase downloaded archive files
autoclean - Erase old downloaded archive files
check - Verify that there are no broken dependencies
changelog - Download and display the changelog for the given package
download - Download the binary package into the current directory
Options:
-h This help text.
-q Loggable output - no progress indicator
-qq No output except for errors
-d Download only - do NOT install or unpack archives
-s No-act. Perform ordering simulation
-y Assume Yes to all queries and do not prompt
-f Attempt to correct a system with broken dependencies in place
-m Attempt to continue if archives are unlocatable
-u Show a list of upgraded packages as well
-b Build the source package after fetching it
-V Show verbose version numbers
-c=? Read this configuration file
-o=? Set an arbitrary configuration option, eg -o dir::cache=/tmp
See the apt-get(8), sources.list(5) and apt.conf(5) manual
pages for more information and options.
This APT has Super Cow Powers.
Unable to install dpkg-dev. Please manually install and try again.
Package build failed!
Package build utility output:
./packages/Ubuntu/ati-packager.sh: 294: ./packages/Ubuntu/ati-packager.sh: debclean: not found
./packages/Ubuntu/ati-packager.sh: 295: ./packages/Ubuntu/ati-packager.sh: dpkg-buildpackage: not found
Removing temporary directory: fglrx-install.ba1MyU
[email protected]:~$ sudo sh ./amd-catalyst-13.4-linux-x86.x86_64.run --buildpkg Ubuntu/precise
Created directory fglrx-install.XfFDy6
Verifying archive integrity… All good.
Uncompressing AMD Catalyst™ Proprietary Driver-12.104…

AMD Catalyst™ Proprietary Driver Installer/Packager

Generating package: Ubuntu/precise
apt 0.9.7.5ubuntu5.1 for amd64 compiled on Mar 13 2013 21:25:25
Usage: apt-get [options] command
apt-get [options] install|remove pkg1 [pkg2 …]
apt-get [options] source pkg1 [pkg2 …]
apt-get is a simple command line interface for downloading and
installing packages. The most frequently used commands are update
and install.
Commands:
update - Retrieve new lists of packages
upgrade - Perform an upgrade
install - Install new packages (pkg is libc6 not libc6.deb)
remove - Remove packages
autoremove - Remove automatically all unused packages
purge - Remove packages and config files
source - Download source archives
build-dep - Configure build-dependencies for source packages
dist-upgrade - Distribution upgrade, see apt-get(8)
dselect-upgrade - Follow dselect selections
clean - Erase downloaded archive files
autoclean - Erase old downloaded archive files
check - Verify that there are no broken dependencies
changelog - Download and display the changelog for the given package
download - Download the binary package into the current directory
Options:
-h This help text.
-q Loggable output - no progress indicator
-qq No output except for errors
-d Download only - do NOT install or unpack archives
-s No-act. Perform ordering simulation
-y Assume Yes to all queries and do not prompt
-f Attempt to correct a system with broken dependencies in place
-m Attempt to continue if archives are unlocatable
-u Show a list of upgraded packages as well
-b Build the source package after fetching it
-V Show verbose version numbers
-c=? Read this configuration file
-o=? Set an arbitrary configuration option, eg -o dir::cache=/tmp
See the apt-get(8), sources.list(5) and apt.conf(5) manual
pages for more information and options.
This APT has Super Cow Powers.
Unable to install dpkg-dev. Please manually install and try again.
Package build failed!
Package build utility output:
./packages/Ubuntu/ati-packager.sh: 294: ./packages/Ubuntu/ati-packager.sh: debclean: not found
./packages/Ubuntu/ati-packager.sh: 295: ./packages/Ubuntu/ati-packager.sh: dpkg-buildpackage: not found
./packages/Ubuntu/ati-packager.sh: 294: ./packages/Ubuntu/ati-packager.sh: debclean: not found
./packages/Ubuntu/ati-packager.sh: 295: ./packages/Ubuntu/ati-packager.sh: dpkg-buildpackage: not found
Removing temporary directory: fglrx-install.XfFDy6
[email protected]:~$ sudo dpkg -i fglrx*.deb
dpkg: error processing fglrx*.deb (–install):
cannot access archive: No such file or directory
Errors were encountered while processing:
fglrx*.deb
[/CODE]Ubuntu je sa Unity-em. A po uptstvu nastaju problemi. U svakom slucaju hvala na korisnim savetima mada ne bi bilo lose za neka malo objasnjenja oko ovih pojmovo ili link ka nekoj temi na ovom ili nekom stranom forumu radi lakse komunikacije jer nisam tolki znalac .

Unable to install dpkg-dev. Please manually install and try again.

Nadam se da si instalirao sve korak po korak od:

Before you start

http://wiki.cchtml.c…ATI.27s_site.29

Izvinjavam se na malom kasnjenju. Proces sam ponovio i dobio ovaj rezultat. Sigurno su malo zamorni ali po mom citanju izmedju redova nista se nije promenilo.

[email protected]:~$ sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases fakeroot libqtgui4
[sudo] password for jablanovic:
Reading package lists... Done
Building dependency tree	
Reading state information... Done
libqtgui4 is already the newest version.
The following package was automatically installed and is no longer required:
linux-headers-3.5.0-17
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
autoconf automake autotools-dev debhelper dh-apparmor dh-translations
dpkg-dev g++ g++-4.7 html2text intltool libalgorithm-diff-perl
libalgorithm-diff-xs-perl libalgorithm-merge-perl libelfg0
libencode-locale-perl libfile-listing-perl libfont-afm-perl
libhtml-form-perl libhtml-format-perl libhtml-parser-perl
libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl
libhttp-daemon-perl libhttp-date-perl libhttp-message-perl
libhttp-negotiate-perl libio-socket-ssl-perl liblwp-mediatypes-perl
liblwp-protocol-https-perl libmail-sendmail-perl libnet-http-perl
libnet-ssleay-perl libstdc++6-4.7-dev libsys-hostname-long-perl libwww-perl
libwww-robotrules-perl libxml-parser-perl m4 po-debconf python-scour
Suggested packages:
autoconf2.13 autoconf-archive gnu-standards autoconf-doc libtool devscripts
debian-keyring g++-multilib g++-4.7-multilib gcc-4.7-doc libstdc++6-4.7-dbg
libdata-dump-perl libcrypt-ssleay-perl libstdc++6-4.7-doc
libauthen-ntlm-perl libmail-box-perl python-rsvg
The following NEW packages will be installed:
autoconf automake autotools-dev build-essential cdbs debhelper dh-apparmor
dh-make dh-modaliases dh-translations dkms dpkg-dev execstack fakeroot g++
g++-4.7 html2text intltool libalgorithm-diff-perl libalgorithm-diff-xs-perl
libalgorithm-merge-perl libelfg0 libencode-locale-perl libfile-listing-perl
libfont-afm-perl libhtml-form-perl libhtml-format-perl libhtml-parser-perl
libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl
libhttp-daemon-perl libhttp-date-perl libhttp-message-perl
libhttp-negotiate-perl libio-socket-ssl-perl liblwp-mediatypes-perl
liblwp-protocol-https-perl libmail-sendmail-perl libnet-http-perl
libnet-ssleay-perl libstdc++6-4.7-dev libsys-hostname-long-perl libwww-perl
libwww-robotrules-perl libxml-parser-perl m4 po-debconf python-scour
0 upgraded, 49 newly installed, 0 to remove and 0 not upgraded.
Need to get 14.7 MB of archives.
After this operation, 42.0 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://rs.archive.ubuntu.com/ubuntu/ quantal/main m4 amd64 1.4.16-3 [203 kB]
Get:2 http://rs.archive.ubuntu.com/ubuntu/ quantal/main autoconf all 2.69-1ubuntu1 [568 kB]
Get:3 http://rs.archive.ubuntu.com/ubuntu/ quantal/main autotools-dev all 20120608.1 [42.9 kB]
Get:4 http://rs.archive.ubuntu.com/ubuntu/ quantal/main automake all 1:1.11.6-1ubuntu1 [578 kB]
Get:5 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libstdc++6-4.7-dev amd64 4.7.2-2ubuntu1 [1,716 kB]
Get:6 http://rs.archive.ubuntu.com/ubuntu/ quantal/main g++-4.7 amd64 4.7.2-2ubuntu1 [7,966 kB]
Get:7 http://rs.archive.ubuntu.com/ubuntu/ quantal/main g++ amd64 4:4.7.2-1ubuntu2 [1,448 B]
Get:8 http://rs.archive.ubuntu.com/ubuntu/ quantal/main dpkg-dev all 1.16.7ubuntu6 [595 kB]
Get:9 http://rs.archive.ubuntu.com/ubuntu/ quantal/main build-essential amd64 11.5ubuntu3 [5,814 B]
Get:10 http://rs.archive.ubuntu.com/ubuntu/ quantal/main html2text amd64 1.3.2a-15build1 [93.3 kB]
Get:11 http://rs.archive.ubuntu.com/ubuntu/ quantal/main po-debconf all 1.0.16+nmu2ubuntu1 [210 kB]
Get:12 http://rs.archive.ubuntu.com/ubuntu/ quantal/main dh-apparmor all 2.8.0-0ubuntu5 [9,846 B]
Get:13 http://rs.archive.ubuntu.com/ubuntu/ quantal/main debhelper all 9.20120608ubuntu1 [623 kB]
Get:14 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libencode-locale-perl all 1.03-1 [12.4 kB]
Get:15 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libhttp-date-perl all 6.02-1 [10.4 kB]
Get:16 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libfile-listing-perl all 6.04-1 [9,774 B]
Get:17 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libhtml-tagset-perl all 3.20-2 [13.5 kB]
Get:18 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libhtml-parser-perl amd64 3.69-2 [99.5 kB]
Get:19 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libhtml-tree-perl all 5.02-1 [213 kB]
Get:20 http://rs.archive.ubuntu.com/ubuntu/ quantal/main liblwp-mediatypes-perl all 6.02-1 [21.7 kB]
Get:21 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libhttp-message-perl all 6.03-1 [77.6 kB]
Get:22 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libhttp-cookies-perl all 6.00-2 [23.3 kB]
Get:23 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libhttp-negotiate-perl all 6.00-2 [13.4 kB]
Get:24 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libnet-ssleay-perl amd64 1.48-1 [316 kB]
Get:25 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libio-socket-ssl-perl all 1.76-1ubuntu1 [51.2 kB]
Get:26 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libnet-http-perl all 6.03-2 [24.0 kB]
Get:27 http://rs.archive.ubuntu.com/ubuntu/ quantal/main liblwp-protocol-https-perl all 6.03-1 [7,178 B]
Get:28 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libwww-robotrules-perl all 6.01-1 [14.1 kB]
Get:29 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libwww-perl all 6.04-1 [156 kB]
Get:30 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libxml-parser-perl amd64 2.41-1build2 [294 kB]
Get:31 http://rs.archive.ubuntu.com/ubuntu/ quantal/main intltool all 0.50.2-2 [52.0 kB]
Get:32 http://rs.archive.ubuntu.com/ubuntu/ quantal/main dh-translations all 117 [21.7 kB]
Get:33 http://rs.archive.ubuntu.com/ubuntu/ quantal/main python-scour all 0.26-3 [46.5 kB]
Get:34 http://rs.archive.ubuntu.com/ubuntu/ quantal/main cdbs all 0.4.111ubuntu1 [48.3 kB]
Get:35 http://rs.archive.ubuntu.com/ubuntu/ quantal/main dh-make all 0.61ubuntu1 [36.7 kB]
Get:36 http://rs.archive.ubuntu.com/ubuntu/ quantal-updates/main dh-modaliases all 1:0.2.71.1 [8,510 B]
Get:37 http://rs.archive.ubuntu.com/ubuntu/ quantal-updates/main dkms all 2.2.0.3-1.1ubuntu1.1 [71.4 kB]
Get:38 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libelfg0 amd64 0.8.13-3build1 [45.5 kB]
Get:39 http://rs.archive.ubuntu.com/ubuntu/ quantal/main execstack amd64 0.0.20090925-6ubuntu1 [71.8 kB]
Get:40 http://rs.archive.ubuntu.com/ubuntu/ quantal/main fakeroot amd64 1.18.4-2 [88.2 kB]
Get:41 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libalgorithm-diff-perl all 1.19.02-2 [50.7 kB]
Get:42 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libalgorithm-diff-xs-perl amd64 0.04-2build3 [12.5 kB]
Get:43 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libalgorithm-merge-perl all 0.08-2 [12.7 kB]
Get:44 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libfont-afm-perl all 1.20-1 [14.3 kB]
Get:45 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libhtml-form-perl all 6.03-1 [23.5 kB]
Get:46 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libhtml-format-perl all 2.10-1 [40.6 kB]
Get:47 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libhttp-daemon-perl all 6.01-1 [17.0 kB]
Get:48 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libsys-hostname-long-perl all 1.4-2 [11.4 kB]
Get:49 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libmail-sendmail-perl all 0.79.16-1 [26.5 kB]
Fetched 14.7 MB in 26s (547 kB/s)											
Extracting templates from packages: 100%
Selecting previously unselected package m4.
(Reading database ... 158380 files and directories currently installed.)
Unpacking m4 (from .../archives/m4_1.4.16-3_amd64.deb) ...
Selecting previously unselected package autoconf.
Unpacking autoconf (from .../autoconf_2.69-1ubuntu1_all.deb) ...
Selecting previously unselected package autotools-dev.
Unpacking autotools-dev (from .../autotools-dev_20120608.1_all.deb) ...
Selecting previously unselected package automake.
Unpacking automake (from .../automake_1%3a1.11.6-1ubuntu1_all.deb) ...
Selecting previously unselected package libstdc++6-4.7-dev.
Unpacking libstdc++6-4.7-dev (from .../libstdc++6-4.7-dev_4.7.2-2ubuntu1_amd64.deb) ...
Selecting previously unselected package g++-4.7.
Unpacking g++-4.7 (from .../g++-4.7_4.7.2-2ubuntu1_amd64.deb) ...
Selecting previously unselected package g++.
Unpacking g++ (from .../g++_4%3a4.7.2-1ubuntu2_amd64.deb) ...
Selecting previously unselected package dpkg-dev.
Unpacking dpkg-dev (from .../dpkg-dev_1.16.7ubuntu6_all.deb) ...
Selecting previously unselected package build-essential.
Unpacking build-essential (from .../build-essential_11.5ubuntu3_amd64.deb) ...
Selecting previously unselected package html2text.
Unpacking html2text (from .../html2text_1.3.2a-15build1_amd64.deb) ...
Selecting previously unselected package po-debconf.
Unpacking po-debconf (from .../po-debconf_1.0.16+nmu2ubuntu1_all.deb) ...
Selecting previously unselected package dh-apparmor.
Unpacking dh-apparmor (from .../dh-apparmor_2.8.0-0ubuntu5_all.deb) ...
Selecting previously unselected package debhelper.
Unpacking debhelper (from .../debhelper_9.20120608ubuntu1_all.deb) ...
Selecting previously unselected package libencode-locale-perl.
Unpacking libencode-locale-perl (from .../libencode-locale-perl_1.03-1_all.deb) ...
Selecting previously unselected package libhttp-date-perl.
Unpacking libhttp-date-perl (from .../libhttp-date-perl_6.02-1_all.deb) ...
Selecting previously unselected package libfile-listing-perl.
Unpacking libfile-listing-perl (from .../libfile-listing-perl_6.04-1_all.deb) ...
Selecting previously unselected package libhtml-tagset-perl.
Unpacking libhtml-tagset-perl (from .../libhtml-tagset-perl_3.20-2_all.deb) ...
Selecting previously unselected package libhtml-parser-perl.
Unpacking libhtml-parser-perl (from .../libhtml-parser-perl_3.69-2_amd64.deb) ...
Selecting previously unselected package libhtml-tree-perl.
Unpacking libhtml-tree-perl (from .../libhtml-tree-perl_5.02-1_all.deb) ...
Selecting previously unselected package liblwp-mediatypes-perl.
Unpacking liblwp-mediatypes-perl (from .../liblwp-mediatypes-perl_6.02-1_all.deb) ...
Selecting previously unselected package libhttp-message-perl.
Unpacking libhttp-message-perl (from .../libhttp-message-perl_6.03-1_all.deb) ...
Selecting previously unselected package libhttp-cookies-perl.
Unpacking libhttp-cookies-perl (from .../libhttp-cookies-perl_6.00-2_all.deb) ...
Selecting previously unselected package libhttp-negotiate-perl.
Unpacking libhttp-negotiate-perl (from .../libhttp-negotiate-perl_6.00-2_all.deb) ...
Selecting previously unselected package libnet-ssleay-perl.
Unpacking libnet-ssleay-perl (from .../libnet-ssleay-perl_1.48-1_amd64.deb) ...
Selecting previously unselected package libio-socket-ssl-perl.
Unpacking libio-socket-ssl-perl (from .../libio-socket-ssl-perl_1.76-1ubuntu1_all.deb) ...
Selecting previously unselected package libnet-http-perl.
Unpacking libnet-http-perl (from .../libnet-http-perl_6.03-2_all.deb) ...
Selecting previously unselected package liblwp-protocol-https-perl.
Unpacking liblwp-protocol-https-perl (from .../liblwp-protocol-https-perl_6.03-1_all.deb) ...
Selecting previously unselected package libwww-robotrules-perl.
Unpacking libwww-robotrules-perl (from .../libwww-robotrules-perl_6.01-1_all.deb) ...
Selecting previously unselected package libwww-perl.
Unpacking libwww-perl (from .../libwww-perl_6.04-1_all.deb) ...
Selecting previously unselected package libxml-parser-perl.
Unpacking libxml-parser-perl (from .../libxml-parser-perl_2.41-1build2_amd64.deb) ...
Selecting previously unselected package intltool.
Unpacking intltool (from .../intltool_0.50.2-2_all.deb) ...
Selecting previously unselected package dh-translations.
Unpacking dh-translations (from .../dh-translations_117_all.deb) ...
Selecting previously unselected package python-scour.
Unpacking python-scour (from .../python-scour_0.26-3_all.deb) ...
Selecting previously unselected package cdbs.
Unpacking cdbs (from .../cdbs_0.4.111ubuntu1_all.deb) ...
Selecting previously unselected package dh-make.
Unpacking dh-make (from .../dh-make_0.61ubuntu1_all.deb) ...
Selecting previously unselected package dh-modaliases.
Unpacking dh-modaliases (from .../dh-modaliases_1%3a0.2.71.1_all.deb) ...
Selecting previously unselected package dkms.
Unpacking dkms (from .../dkms_2.2.0.3-1.1ubuntu1.1_all.deb) ...
Selecting previously unselected package libelfg0.
Unpacking libelfg0 (from .../libelfg0_0.8.13-3build1_amd64.deb) ...
Selecting previously unselected package execstack.
Unpacking execstack (from .../execstack_0.0.20090925-6ubuntu1_amd64.deb) ...
Selecting previously unselected package fakeroot.
Unpacking fakeroot (from .../fakeroot_1.18.4-2_amd64.deb) ...
Selecting previously unselected package libalgorithm-diff-perl.
Unpacking libalgorithm-diff-perl (from .../libalgorithm-diff-perl_1.19.02-2_all.deb) ...
Selecting previously unselected package libalgorithm-diff-xs-perl.
Unpacking libalgorithm-diff-xs-perl (from .../libalgorithm-diff-xs-perl_0.04-2build3_amd64.deb) ...
Selecting previously unselected package libalgorithm-merge-perl.
Unpacking libalgorithm-merge-perl (from .../libalgorithm-merge-perl_0.08-2_all.deb) ...
Selecting previously unselected package libfont-afm-perl.
Unpacking libfont-afm-perl (from .../libfont-afm-perl_1.20-1_all.deb) ...
Selecting previously unselected package libhtml-form-perl.
Unpacking libhtml-form-perl (from .../libhtml-form-perl_6.03-1_all.deb) ...
Selecting previously unselected package libhtml-format-perl.
Unpacking libhtml-format-perl (from .../libhtml-format-perl_2.10-1_all.deb) ...
Selecting previously unselected package libhttp-daemon-perl.
Unpacking libhttp-daemon-perl (from .../libhttp-daemon-perl_6.01-1_all.deb) ...
Selecting previously unselected package libsys-hostname-long-perl.
Unpacking libsys-hostname-long-perl (from .../libsys-hostname-long-perl_1.4-2_all.deb) ...
Selecting previously unselected package libmail-sendmail-perl.
Unpacking libmail-sendmail-perl (from .../libmail-sendmail-perl_0.79.16-1_all.deb) ...
Processing triggers for install-info ...
Processing triggers for man-db ...
Processing triggers for doc-base ...
Processing 3 added doc-base files...
Processing triggers for mime-support ...
Setting up m4 (1.4.16-3) ...
Setting up autoconf (2.69-1ubuntu1) ...
Setting up autotools-dev (20120608.1) ...
Setting up automake (1:1.11.6-1ubuntu1) ...
update-alternatives: using /usr/bin/automake-1.11 to provide /usr/bin/automake (automake) in auto mode
Setting up dpkg-dev (1.16.7ubuntu6) ...
Setting up html2text (1.3.2a-15build1) ...
Setting up po-debconf (1.0.16+nmu2ubuntu1) ...
Setting up dh-apparmor (2.8.0-0ubuntu5) ...
Setting up debhelper (9.20120608ubuntu1) ...
Setting up libencode-locale-perl (1.03-1) ...
Setting up libhttp-date-perl (6.02-1) ...
Setting up libfile-listing-perl (6.04-1) ...
Setting up libhtml-tagset-perl (3.20-2) ...
Setting up libhtml-parser-perl (3.69-2) ...
Setting up libhtml-tree-perl (5.02-1) ...
Setting up liblwp-mediatypes-perl (6.02-1) ...
Setting up libhttp-message-perl (6.03-1) ...
Setting up libhttp-cookies-perl (6.00-2) ...
Setting up libhttp-negotiate-perl (6.00-2) ...
Setting up libnet-ssleay-perl (1.48-1) ...
Setting up libio-socket-ssl-perl (1.76-1ubuntu1) ...
Setting up libnet-http-perl (6.03-2) ...
Setting up libwww-robotrules-perl (6.01-1) ...
Setting up python-scour (0.26-3) ...
Setting up dh-make (0.61ubuntu1) ...
Setting up dh-modaliases (1:0.2.71.1) ...
Setting up dkms (2.2.0.3-1.1ubuntu1.1) ...
Setting up libelfg0 (0.8.13-3build1) ...
Setting up execstack (0.0.20090925-6ubuntu1) ...
Setting up fakeroot (1.18.4-2) ...
update-alternatives: using /usr/bin/fakeroot-sysv to provide /usr/bin/fakeroot (fakeroot) in auto mode
Setting up libalgorithm-diff-perl (1.19.02-2) ...
Setting up libalgorithm-diff-xs-perl (0.04-2build3) ...
Setting up libalgorithm-merge-perl (0.08-2) ...
Setting up libfont-afm-perl (1.20-1) ...
Setting up libhtml-form-perl (6.03-1) ...
Setting up libhtml-format-perl (2.10-1) ...
Setting up libhttp-daemon-perl (6.01-1) ...
Setting up libsys-hostname-long-perl (1.4-2) ...
Setting up libmail-sendmail-perl (0.79.16-1) ...
Setting up g++-4.7 (4.7.2-2ubuntu1) ...
Setting up g++ (4:4.7.2-1ubuntu2) ...
update-alternatives: using /usr/bin/g++ to provide /usr/bin/c++ (c++) in auto mode
Setting up build-essential (11.5ubuntu3) ...
Setting up liblwp-protocol-https-perl (6.03-1) ...
Setting up libwww-perl (6.04-1) ...
Setting up libxml-parser-perl (2.41-1build2) ...
Setting up intltool (0.50.2-2) ...
Setting up dh-translations (117) ...
Setting up cdbs (0.4.111ubuntu1) ...
Setting up libstdc++6-4.7-dev (4.7.2-2ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
[email protected]:~$ sudo apt-get install lib32gcc1
Reading package lists... Done
Building dependency tree	
Reading state information... Done
The following package was automatically installed and is no longer required:
linux-headers-3.5.0-17
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
libc6-i386
The following NEW packages will be installed:
lib32gcc1 libc6-i386
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 4,047 kB of archives.
After this operation, 9,839 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://rs.archive.ubuntu.com/ubuntu/ quantal/main libc6-i386 amd64 2.15-0ubuntu20 [3,994 kB]
Get:2 http://rs.archive.ubuntu.com/ubuntu/ quantal/main lib32gcc1 amd64 1:4.7.2-2ubuntu1 [53.3 kB]
Fetched 4,047 kB in 5s (691 kB/s)
Selecting previously unselected package libc6-i386.
(Reading database ... 160875 files and directories currently installed.)
Unpacking libc6-i386 (from .../libc6-i386_2.15-0ubuntu20_amd64.deb) ...
Replaced by files in installed package libc6:i386 ...
Selecting previously unselected package lib32gcc1.
Unpacking lib32gcc1 (from .../lib32gcc1_1%3a4.7.2-2ubuntu1_amd64.deb) ...
Setting up libc6-i386 (2.15-0ubuntu20) ...
Setting up lib32gcc1 (1:4.7.2-2ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
[email protected]:~$ wget http://www2.ati.com/drivers/linux/amd-catalyst-13.4-linux-x86.x86_64.zip
--2013-05-29 20:22:33-- http://www2.ati.com/drivers/linux/amd-catalyst-13.4-linux-x86.x86_64.zip
Resolving www2.ati.com (www2.ati.com)... 12.120.136.146
Connecting to www2.ati.com (www2.ati.com)|12.120.136.146|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 122588023 (117M) [application/zip]
Saving to: `amd-catalyst-13.4-linux-x86.x86_64.zip.1'
100%[======================================>] 122,588,023 626K/s in 3m 9s
2013-05-29 20:25:42 (635 KB/s) - `amd-catalyst-13.4-linux-x86.x86_64.zip.1' saved [122588023/122588023]
[email protected]:~$ unzip amd-catalyst-13.4-linux-x86.x86_64.zip
Archive: amd-catalyst-13.4-linux-x86.x86_64.zip
replace amd-catalyst-13.4-linux-x86.x86_64.run? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: amd-catalyst-13.4-linux-x86.x86_64.run
[email protected]:~$ chmod +x amd-catalyst-13.4-linux-x86.x86_64.run
[email protected]:~$ sudo sh ./amd-catalyst-13.4-linux-x86.x86_64.run --buildpkg Ubuntu/precise
Created directory fglrx-install.YAo1f4
Verifying archive integrity... All good.
Uncompressing AMD Catalyst(TM) Proprietary Driver-12.104....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
=====================================================================
AMD Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================
Generating package: Ubuntu/precise
sudo sh ./amd-catalyst-13.4-linux-x86.x86_64.run --buildpkg Ubuntu/precisePackage /home/jablanovic/fglrx_12.104-0ubuntu1_amd64.deb has been successfully generated
Package /home/jablanovic/fglrx-dev_12.104-0ubuntu1_amd64.deb has been successfully generated
Package /home/jablanovic/fglrx-amdcccle_12.104-0ubuntu1_amd64.deb has been successfully generated
Removing temporary directory: fglrx-install.YAo1f4
[email protected]:~$
[email protected]:~$
[email protected]:~$
[email protected]:~$ sudo sh ./amd-catalyst-13.4-linux-x86.x86_64.run --buildpkg Ubuntu/precise
Created directory fglrx-install.EBIDvM
Verifying archive integrity... All good.
Uncompressing AMD Catalyst(TM) Proprietary Driver-12.104....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
=====================================================================
AMD Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================
Generating package: Ubuntu/precise
Package build failed!
Package build utility output:
cat: /tmp/pkg_build.out: No such file or directory
Removing temporary directory: fglrx-install.EBIDvM
[email protected]:~$ sudo sh ./amd-catalyst-13.4-linux-x86.x86_64.run --buildpkg Ubuntu/precise
[sudo] password for jablanovic:
Created directory fglrx-install.UM1Goi
Verifying archive integrity... All good.
Uncompressing AMD Catalyst(TM) Proprietary Driver-12.104....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
=====================================================================
AMD Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================
Generating package: Ubuntu/precise
Package /home/jablanovic/fglrx_12.104-0ubuntu1_amd64.deb has been successfully generated
Removing temporary directory: fglrx-install.UM1Goi
[email protected]:~$ sudo dpkg -i fglrx*.deb
[sudo] password for jablanovic:
dpkg: error processing fglrx*.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
fglrx*.deb
[email protected]:~$

Pa što lupaš triput istu komandu, napravio ti je deb pakete iz prvog puta ::slight_smile: .

[email protected]:~$ sudo sh ./amd-catalyst-13.4-linux-x86.x86_64.run --buildpkg Ubuntu/precise
Created directory fglrx-install.YAo1f4
Verifying archive integrity... All good.
Uncompressing AMD Catalyst(TM) Proprietary Driver-12.104....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
=====================================================================
AMD Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================
Generating package: Ubuntu/precise
sudo sh ./amd-catalyst-13.4-linux-x86.x86_64.run --buildpkg Ubuntu/precisePackage /home/jablanovic/fglrx_12.104-0ubuntu1_amd64.deb has been successfully generated
Package /home/jablanovic/fglrx-dev_12.104-0ubuntu1_amd64.deb has been successfully generated
Package /home/jablanovic/fglrx-amdcccle_12.104-0ubuntu1_amd64.deb has been successfully generated
Removing temporary directory: fglrx-install.YAo1f4
[email protected]:~$

Eto odmah tu si završio posao sa instalerom, vidiš tri deb paketa što ti je instaler generisao, ovaj ti je drajver:

fglrx_12.104-0ubuntu1_amd64.deb 

ovaj ti treba samo ako kompajliraš nešto:

fglrx-dev_12.104-0ubuntu1_amd64.deb

a ovaj ti je GUI, Control Center ili kako se već to zove

fglrx-amdcccle_12.104-0ubuntu1_amd64.deb

E sad samo drajver ti je neophodan, možeš sad i na klik samo instaliraš taj prvi paket, ostalo može i naknadno.

Thanks! Otvorio si mi oci. :morning2:

Mali off. U Mintu sam ponovio postupak i pravi mi jedan problem? Imali li resenja?

[email protected] ~ $ '/home/jablanovic/amd-catalyst-13.4-linux-x86.x86_64.run (2)'
bash: /home/jablanovic/amd-catalyst-13.4-linux-x86.x86_64.run (2): Permission denied