broken dependecies!?

nikako ne uspevam da resim ovo:

❯ sudo apt upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: zfs-initramfs : Depends: zfsutils-linux but it is not installed E: Unmet dependencies. Try using -f. ╭─    ~   100 ↵  820  0.38  ❯ sudoapt-get -f install zsh: command not found: sudoapt-get ╭─    ~   127 ↵  821  0.39  ❯ sudo apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following package was automatically installed and is no longer required: libavdevice57 Use 'apt-get autoremove' to remove it. The following extra packages will be installed: libnvpair1linux libuutil1linux libzfs2linux libzpool2linux zfs-zed zfsutils-linux Suggested packages: nfs-kernel-server samba-common-bin The following NEW packages will be installed: libnvpair1linux libuutil1linux libzfs2linux libzpool2linux zfs-zed zfsutils-linux 0 upgraded, 6 newly installed, 0 to remove and 8 not upgraded. 1 not fully installed or removed. Need to get 0 B/1,008 kB of archives. After this operation, 5,271 kB of additional disk space will be used. Do you want to continue? [Y/n] y (Reading database ... 288043 files and directories currently installed.) Preparing to unpack .../libuutil1linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking libuutil1linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/libuutil1linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/libuutil.so.1.0.1', which is also in package libuutil1 0.6.5.7-8-jessie Preparing to unpack .../libnvpair1linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking libnvpair1linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/libnvpair1linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/libnvpair.so.1.0.1', which is also in package libnvpair1 0.6.5.7-8-jessie Preparing to unpack .../libzpool2linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking libzpool2linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/libzpool2linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/libzpool.so.2.0.0', which is also in package libzpool2 0.6.5.7-8-jessie dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Preparing to unpack .../libzfs2linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking libzfs2linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/libzfs2linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/libzfs.so.2.0.0', which is also in package libzfs2 0.6.5.7-8-jessie dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Preparing to unpack .../zfsutils-linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking zfsutils-linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/zfsutils-linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/sbin/mount.zfs', which is also in package zfsutils 0.6.5.7-8-jessie dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Preparing to unpack .../zfs-zed_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking zfs-zed (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/zfs-zed_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/systemd/system/zfs-zed.service', which is also in package zfsutils 0.6.5.7-8-jessie Errors were encountered while processing: /var/cache/apt/archives/libuutil1linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/libnvpair1linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/libzpool2linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/libzfs2linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/zfsutils-linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/zfs-zed_0.6.5.9-5~bpo8+1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) ╭─    ~   100 ↵  822  0.54  ❯

@djeembe
Konflikt stare (TRIOS) i novije verzije zfs (Debian) i njihovih zavisnih libova.
Ako ne koristiš zfs, slobodno odradi

apt purge zfs* && apt-get autoremove

ne mogu cak ni to!

╭─    ~   ✓  822  0.69  ❯ sudo apt purge zfs* && apt-get autoremove zsh: no matches found: zfs* ╭─    ~   1 ↵  823  0.62  ❯ sudo apt purge zfs* zsh: no matches found: zfs* ╭─    ~   1 ↵  824  0.34  ❯ sudo apt purge zfs [sudo] password for utuk-xul: Reading package lists... Done Building dependency tree Reading state information... Done Package 'zfs' is not installed, so not removed You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: zfs-initramfs : Depends: zfsutils-linux but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). ╭─    ~   100 ↵  825  0.27  ❯ sudo apt-get autoremove Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: zfs-initramfs : Depends: zfsutils-linux but it is not installed E: Unmet dependencies. Try using -f. ╭─    ~   100 ↵  826  0.39  ❯ sudo apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following package was automatically installed and is no longer required: libavdevice57 Use 'apt-get autoremove' to remove it. The following extra packages will be installed: libnvpair1linux libuutil1linux libzfs2linux libzpool2linux zfs-zed zfsutils-linux Suggested packages: nfs-kernel-server samba-common-bin The following NEW packages will be installed: libnvpair1linux libuutil1linux libzfs2linux libzpool2linux zfs-zed zfsutils-linux 0 upgraded, 6 newly installed, 0 to remove and 8 not upgraded. 1 not fully installed or removed. Need to get 0 B/1,008 kB of archives. After this operation, 5,271 kB of additional disk space will be used. Do you want to continue? [Y/n] y (Reading database ... 288043 files and directories currently installed.) Preparing to unpack .../libuutil1linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking libuutil1linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/libuutil1linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/libuutil.so.1.0.1', which is also in package libuutil1 0.6.5.7-8-jessie Preparing to unpack .../libnvpair1linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking libnvpair1linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/libnvpair1linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/libnvpair.so.1.0.1', which is also in package libnvpair1 0.6.5.7-8-jessie Preparing to unpack .../libzpool2linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking libzpool2linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/libzpool2linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/libzpool.so.2.0.0', which is also in package libzpool2 0.6.5.7-8-jessie dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Preparing to unpack .../libzfs2linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking libzfs2linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/libzfs2linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/libzfs.so.2.0.0', which is also in package libzfs2 0.6.5.7-8-jessie dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Preparing to unpack .../zfsutils-linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking zfsutils-linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/zfsutils-linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/sbin/mount.zfs', which is also in package zfsutils 0.6.5.7-8-jessie dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Preparing to unpack .../zfs-zed_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking zfs-zed (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/zfs-zed_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/systemd/system/zfs-zed.service', which is also in package zfsutils 0.6.5.7-8-jessie Errors were encountered while processing: /var/cache/apt/archives/libuutil1linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/libnvpair1linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/libzpool2linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/libzfs2linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/zfsutils-linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/zfs-zed_0.6.5.9-5~bpo8+1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) ╭─    ~   100 ↵  827  0.26  ❯

Ovde je greška, treba wildcard ( *, zvezdica) posle zfs…

apt purge zfs*

pogledaj pazljivije iznad ceo ispis iz terminala…

❯ sudo apt purge zfs*
zsh: no matches found: zfs*

Hvala na upozorenju, nisam obratio pažnju na to da koristiš zsh, koji drugačije interpretira wildcard…mora da se stavi pod navodnike, dakle:

sudo apt purge 'zfs*'

Probaj da staviš zfs sa wildcardom pod navodnike (single quotes) ’ ’ .
sudo apt purge ‘zfs*’

Edit: Zakasnio sam sa postom, može na brisanje.

prokletstvo- opet greska:

❯ sudo apt purge 'zfs*' [sudo] password for utuk-xul: Reading package lists... Done Building dependency tree Reading state information... Done Note, selecting 'fonts-yozvox-yozfont-new-kana' for regex 'zfs*' Note, selecting 'fonts-yozvox-yozfont-edu' for regex 'zfs*' Note, selecting 'fonts-yozvox-yozfont-antique' for regex 'zfs*' Note, selecting 'fonts-yozvox-yozfont-standard-kana' for regex 'zfs*' Note, selecting 'zfs-initramfs' for regex 'zfs*' Note, selecting 'php5-lzf' for regex 'zfs*' Note, selecting 'otf-yozvox-yozfont-standard-kana' for regex 'zfs*' Note, selecting 'libzfs2linux' for regex 'zfs*' Note, selecting 'lzfs' for regex 'zfs*' Note, selecting 'zfs-dracut' for regex 'zfs*' Note, selecting 'zfsonlinux' for regex 'zfs*' Note, selecting 'zfs-modules-source' for regex 'zfs*' Note, selecting 'zfsnap' for regex 'zfs*' Note, selecting 'zfs-modules' for regex 'zfs*' Note, selecting 'otf-yozvox-yozfont-cute' for regex 'zfs*' Note, selecting 'golang-go-zfs-dev' for regex 'zfs*' Note, selecting 'libcompress-lzf-java' for regex 'zfs*' Note, selecting 'python-zfec' for regex 'zfs*' Note, selecting 'fonts-yozvox-yozfont' for regex 'zfs*' Note, selecting 'bzflag-server' for regex 'zfs*' Note, selecting 'zfs-zed' for regex 'zfs*' Note, selecting 'zfs-auto-snapshot' for regex 'zfs*' Note, selecting 'otf-yozvox-yozfont' for regex 'zfs*' Note, selecting 'zfsutils' for regex 'zfs*' Note, selecting 'zfsutils-linux' for regex 'zfs*' Note, selecting 'lzfs-dkms' for regex 'zfs*' Note, selecting 'libguestfs-zfs' for regex 'zfs*' Note, selecting 'otf-yozvox-yozfont-edu' for regex 'zfs*' Note, selecting 'libdatetime-timezone-tzfile-perl' for regex 'zfs*' Note, selecting 'debian-zfs' for regex 'zfs*' Note, selecting 'bzflag-data' for regex 'zfs*' Note, selecting 'otf-yozvox-yozfont-antique' for regex 'zfs*' Note, selecting 'zfs-dbg' for regex 'zfs*' Note, selecting 'bzflag-client' for regex 'zfs*' Note, selecting 'zfs-fuse' for regex 'zfs*' Note, selecting 'zftp' for regex 'zfs*' Note, selecting 'libning-compress-lzf-java-doc' for regex 'zfs*' Note, selecting 'zfs-dkms' for regex 'zfs*' Note, selecting 'bzflag' for regex 'zfs*' Note, selecting 'libzfs1' for regex 'zfs*' Note, selecting 'libzfs2' for regex 'zfs*' Note, selecting 'fonts-yozvox-yozfont-cute' for regex 'zfs*' Note, selecting 'zfs' for regex 'zfs*' Note, selecting 'libzfslinux-dev' for regex 'zfs*' Note, selecting 'otf-yozvox-yozfont-new-kana' for regex 'zfs*' Package 'libning-compress-lzf-java-doc' is not installed, so not removed Package 'otf-yozvox-yozfont' is not installed, so not removed Note, selecting 'fonts-yozvox-yozfont-antique' instead of 'otf-yozvox-yozfont-antique' Note, selecting 'fonts-yozvox-yozfont-cute' instead of 'otf-yozvox-yozfont-cute' Note, selecting 'fonts-yozvox-yozfont-edu' instead of 'otf-yozvox-yozfont-edu' Note, selecting 'fonts-yozvox-yozfont-new-kana' instead of 'otf-yozvox-yozfont-new-kana' Note, selecting 'fonts-yozvox-yozfont-standard-kana' instead of 'otf-yozvox-yozfont-standard-kana' Package 'php5-lzf' is not installed, so not removed Package 'zfs' is not installed, so not removed Note, selecting 'zfs-dkms' instead of 'zfs-modules' Package 'zfs-auto-snapshot' is not installed, so not removed Package 'libzfs1' is not installed, so not removed Package 'bzflag' is not installed, so not removed Package 'bzflag-client' is not installed, so not removed Package 'bzflag-data' is not installed, so not removed Package 'bzflag-server' is not installed, so not removed Package 'zftp' is not installed, so not removed Package 'libcompress-lzf-java' is not installed, so not removed Package 'fonts-yozvox-yozfont' is not installed, so not removed Package 'fonts-yozvox-yozfont-antique' is not installed, so not removed Package 'fonts-yozvox-yozfont-cute' is not installed, so not removed Package 'fonts-yozvox-yozfont-edu' is not installed, so not removed Package 'fonts-yozvox-yozfont-new-kana' is not installed, so not removed Package 'fonts-yozvox-yozfont-standard-kana' is not installed, so not removed Package 'libdatetime-timezone-tzfile-perl' is not installed, so not removed Package 'python-zfec' is not installed, so not removed Package 'zfs-fuse' is not installed, so not removed Package 'golang-go-zfs-dev' is not installed, so not removed Package 'libguestfs-zfs' is not installed, so not removed Package 'libzfs2linux' is not installed, so not removed Package 'libzfslinux-dev' is not installed, so not removed Package 'zfs-dbg' is not installed, so not removed Package 'zfs-dracut' is not installed, so not removed Package 'zfs-zed' is not installed, so not removed Package 'zfsutils-linux' is not installed, so not removed You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: grub-common : Depends: libzfs2 but it is not going to be installed grub-pc-bin : Depends: libzfs2 but it is not going to be installed grub2-common : Depends: libzfs2 but it is not going to be installed simplesnap : Depends: zfs-fuse but it is not going to be installed or zfsutils or zfs but it is not installable E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). ╭─    ~   100 ↵  830  0.55  ❯ sudo apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following package was automatically installed and is no longer required: libavdevice57 Use 'apt-get autoremove' to remove it. The following extra packages will be installed: libnvpair1linux libuutil1linux libzfs2linux libzpool2linux zfs-zed zfsutils-linux Suggested packages: nfs-kernel-server samba-common-bin The following NEW packages will be installed: libnvpair1linux libuutil1linux libzfs2linux libzpool2linux zfs-zed zfsutils-linux 0 upgraded, 6 newly installed, 0 to remove and 8 not upgraded. 1 not fully installed or removed. Need to get 0 B/1,008 kB of archives. After this operation, 5,271 kB of additional disk space will be used. Do you want to continue? [Y/n] y (Reading database ... 288043 files and directories currently installed.) Preparing to unpack .../libuutil1linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking libuutil1linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/libuutil1linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/libuutil.so.1.0.1', which is also in package libuutil1 0.6.5.7-8-jessie Preparing to unpack .../libnvpair1linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking libnvpair1linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/libnvpair1linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/libnvpair.so.1.0.1', which is also in package libnvpair1 0.6.5.7-8-jessie Preparing to unpack .../libzpool2linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking libzpool2linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/libzpool2linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/libzpool.so.2.0.0', which is also in package libzpool2 0.6.5.7-8-jessie dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Preparing to unpack .../libzfs2linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking libzfs2linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/libzfs2linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/libzfs.so.2.0.0', which is also in package libzfs2 0.6.5.7-8-jessie dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Preparing to unpack .../zfsutils-linux_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking zfsutils-linux (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/zfsutils-linux_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/sbin/mount.zfs', which is also in package zfsutils 0.6.5.7-8-jessie dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Preparing to unpack .../zfs-zed_0.6.5.9-5~bpo8+1_amd64.deb ... Unpacking zfs-zed (0.6.5.9-5~bpo8+1) ... dpkg: error processing archive /var/cache/apt/archives/zfs-zed_0.6.5.9-5~bpo8+1_amd64.deb (--unpack): trying to overwrite '/lib/systemd/system/zfs-zed.service', which is also in package zfsutils 0.6.5.7-8-jessie Errors were encountered while processing: /var/cache/apt/archives/libuutil1linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/libnvpair1linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/libzpool2linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/libzfs2linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/zfsutils-linux_0.6.5.9-5~bpo8+1_amd64.deb /var/cache/apt/archives/zfs-zed_0.6.5.9-5~bpo8+1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

Nisi nigde zakasnio, niti ćemo brisati :slight_smile:
Prostora imamo dovoljno, a ovakve poruke samo potvrđuju da ima više korisnika koji se trude da pomognu :slight_smile:

Moraćeš da sačekaš da napravim tačan spisak paketa za brisanje, kad budem imao vremena…

ok, nije problem…izvini zbog smaranja :slight_smile: i naravno hvala vam na trudu @Dragan[/USER] i [USER=1579]@mracni covek (svidja mi se tvoj nick)

@djeembe
Evo ga ovde spisak za brisanje…znam da je još neko imao identičan problem
TRIOS - Problemi i sugestije, uopštena tema | Page 66 | FOSS | Free and Opensource Serbia

hmmmm…nece da popusti nikako-mozda je postao svestan sebe i neda da se obrise:

❯ sudo apt purge libuutil1 libzfs2 libzpool2 zfsutils zfs-dkms zfs-fuse zfs-zed && apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done Package 'zfs-fuse' is not installed, so not removed Package 'zfs-zed' is not installed, so not removed You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: debian-zfs : Depends: zfs-dkms but it is not going to be installed Depends: zfsutils Recommends: linux-headers but it is not installable grub-common : Depends: libzfs2 but it is not going to be installed grub-pc-bin : Depends: libzfs2 but it is not going to be installed grub2-common : Depends: libzfs2 but it is not going to be installed libnvpair1 : Depends: libuutil1 but it is not going to be installed simplesnap : Depends: zfs-fuse but it is not going to be installed or zfsutils or zfs but it is not installable zfs-initramfs : Depends: zfs-modules or zfs-dkms but it is not going to be installed Depends: zfsutils-linux but it is not going to be installed zfsnap : Depends: zfs-fuse but it is not going to be installed or zfsutils or zfs but it is not installable E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Ok, dodaj i ovo što je prijavio, pa probaj opet:

sudo apt purge libuutil1 libzfs2 libzpool2 zfsutils zfs-dkms zfs-fuse zfs-zed debian-zfs libnvpair1 simplesnap zfs-initramfs zfsnap

sudo apt purge libuutil1 libzfs2 libzpool2 zfsutils zfs-dkms zfs-fuse zfs-zed debian-zfs libnvpair1 simplesnap zfs-initramfs zfsnap Reading package lists... Done Building dependency tree Reading state information... Done Package 'zfs-fuse' is not installed, so not removed Package 'zfs-zed' is not installed, so not removed You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: grub-common : Depends: libnvpair1 but it is not going to be installed Depends: libzfs2 but it is not going to be installed grub-pc-bin : Depends: libnvpair1 but it is not going to be installed Depends: libzfs2 but it is not going to be installed grub2-common : Depends: libnvpair1 but it is not going to be installed Depends: libzfs2 but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Daj mi ispis verzije gruba koja je kod tebe…to je grub sa ZFS patch, samo da proverimo verziju, da ne prenaglimo pa da ostaneš bez gruba:

apt-cache policy grub2-common

Usput, mala napomena u vezi ovih problema ^:
Kada sam ubacivao zfs pakete u TRIOS repo za inicijalno izdanje, to je bilo direktno od upstream provajdera
ZFS on Linux · GitHub

U to vreme, zfs nije bio ni u najavi za debian, ali u međuvremenu stvari su se promenile.
Dodatno, debian developeri imaju vrlo ružan običaj da nasilno menjaju imena nekih paketa i/ili libova u odnosu na upstream, pa to dovodi do dodatnih konflikata, mešanja šta se preko čega instalira, u kom se paketu koji lib nalazi itd…

❯ apt-cache policy grub2-common grub2-common: Installed: 2.02-beta2.9-ZOL11-7aa9f6 Candidate: 2.02-beta2.9-ZOL11-7aa9f6 Version table: *** 2.02-beta2.9-ZOL11-7aa9f6 0 100 /var/lib/dpkg/status 2.02~beta2-22+deb8u1 0 500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages 500 http://security.debian.org/ jessie/updates/main amd64 Packages

Da, to je originalni zfs grub koji se nalazio u starom trios repou…
Screenshot - 02092018 - 12:25:56 AM.png

@djeembe
Još jedno, nadam se poslednje, pitanje:
Da li imaš uefi računar, odnosno da li se kod tebe računar podiže preko rEFInd ili samo osnovnog gruba?
Pitam zato što u prvoj verziji grub može potpuno bezbedno da se ukloni, a u drugoj isto može, samo malo pažljivije :wink: