Bug with debian kernel

Hey guys,

I’ve just got my new laptop, and have finally got Trios installed on it (YAY!).

I’ve hit a few issues with the kernel, and was going to log a bug report with debian, but I suspect that will show that packages from Trios are installed.

This raises a bigger question:

If I have a problem with a package from the debian repos, should I raise it with debian or yourselves?

Cheers,

It depends … if we can solve problem, you can submit a bug to us :wink:
Joking aside … trios has a vanilla kernel from debian jessie repo, so it’s best for you to describe what is the problem with kernel.

@Dragan Thanks for the quick reply.

Have a new Dell XPS 13", and am getting the following

Mar 9 19:40:04 localhost kernel: [ 1121.338520] Modules linked in: zfs(PO) zunicode(PO) zavl(PO) zcommon(PO) znvpair(PO) spl(O) bnep autofs4 vmhgfs(O) vmw_vmci fuse parport_pc ppdev lp parport wl(PO) iTCO_wdt iTCO_vendor_support snd_hda_codec_hdmi cfg80211 rtsx_pci_ms memstick joydev hid_multitouch dell_wmi sparse_keymap x86_pkg_temp_thermal dell_laptop intel_powerclamp dcdbas intel_rapl coretemp kvm_intel ecb kvm evdev btusb psmouse pcspkr serio_raw uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core bluetooth v4l2_common videodev lpc_ich 6lowpan_iphc i2c_i801 rfkill media mei_me mei shpchp wmi i915 int3403_thermal snd_hda_intel snd_hda_controller drm_kms_helper snd_soc_sst_acpi video snd_hda_codec i2c_designware_platform snd_hwdep drm i2c_designware_core snd_pcm snd_timer battery i2c_algo_bit snd soundcore ac button acpi_pad processor ext4 crc16 mbcache jbd2 algif_skcipher af_alg dm_crypt dm_mod sg sd_mod crc_t10dif crct10dif_generic rtsx_pci_sdmmc crct10dif_pclmul crct10dif_common crc32_pclmul crc32c_intel ghash_clmulni_intel aesni_intel aes_x86_64 lrw gf128mul glue_helper ablk_helper ahci cryptd libahci libata scsi_mod rtsx_pci mfd_core xhci_hcd usbcore usb_common thermal fan thermal_sys i2c_hid hid sdhci_acpi i2c_core sdhci mmc_core
Mar 9 19:40:04 localhost kernel: [ 1121.338569] CPU: 2 PID: 7358 Comm: iwconfig Tainted: P W O 3.16.0-4-amd64 #1 Debian 3.16.7-ckt7-1
Mar 9 19:40:04 localhost kernel: [ 1121.338570] Hardware name: Dell Inc. XPS 13 9343/0TM99H, BIOS A00 11/04/2014
Mar 9 19:40:04 localhost kernel: [ 1121.338571] 0000000000000009 ffffffff81509e7c 0000000000000000 ffffffff81067727
Mar 9 19:40:04 localhost kernel: [ 1121.338573] ffff88003646e200 0000000000000000 ffff880213684800 ffff88021e820000
Mar 9 19:40:04 localhost kernel: [ 1121.338574] ffff880215415000 ffffffffa06b5e0a ffff880213684800 ffff88003646e200
Mar 9 19:40:04 localhost kernel: [ 1121.338576] Call Trace:
Mar 9 19:40:04 localhost kernel: [ 1121.338580] [] ? dump_stack+0x41/0x51
Mar 9 19:40:04 localhost kernel: [ 1121.338583] [] ? warn_slowpath_common+0x77/0x90
Mar 9 19:40:04 localhost kernel: [ 1121.338587] [] ? cfg80211_connect+0x4aa/0x4f0 [cfg80211]
Mar 9 19:40:04 localhost kernel: [ 1121.338592] [] ? cfg80211_mgd_wext_connect+0x140/0x190 [cfg80211]
Mar 9 19:40:04 localhost kernel: [ 1121.338596] [] ? cfg80211_mgd_wext_siwap+0xfd/0x170 [cfg80211]
Mar 9 19:40:04 localhost kernel: [ 1121.338598] [] ? ioctl_standard_call+0x51/0xd0
Mar 9 19:40:04 localhost kernel: [ 1121.338601] [] ? wext_handle_ioctl+0x65/0xc0
Mar 9 19:40:04 localhost kernel: [ 1121.338603] [] ? dev_ioctl+0x2e4/0x590
Mar 9 19:40:04 localhost kernel: [ 1121.338605] [] ? __do_page_fault+0x1d1/0x4f0
Mar 9 19:40:04 localhost kernel: [ 1121.338607] [] ? sock_ioctl+0x12a/0x2c0
Mar 9 19:40:04 localhost kernel: [ 1121.338609] [] ? get_empty_filp+0xc9/0x1c0
Mar 9 19:40:04 localhost kernel: [ 1121.338612] [] ? do_vfs_ioctl+0x2cf/0x4b0
Mar 9 19:40:04 localhost kernel: [ 1121.338613] [] ? sock_alloc_file+0x9f/0x130
Mar 9 19:40:04 localhost kernel: [ 1121.338615] [] ? SyS_ioctl+0x81/0xa0
Mar 9 19:40:04 localhost kernel: [ 1121.338617] [] ? page_fault+0x28/0x30
Mar 9 19:40:04 localhost kernel: [ 1121.338619] [] ? system_call_fast_compare_end+0x10/0x15
Mar 9 19:40:04 localhost kernel: [ 1121.338620] —[ end trace d4eefc17ae3094f6 ]—
Mar 9 19:40:04 localhost kernel: [ 1121.422074] wl0: link up (wlan0)

This causes intermittent wireless drop outs (interfaces stays up, and ip remains, but traffic drops in and out)

Also having issues with the synaptics touchpad, which “apparently” are fixed in later kernels…

@spOOn

It seems this is wifi driver bug, already submitted to debian
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=773676

Hmm, okies, Ill wait for someone from debian to catch this one.

On the synaptics issues, I see RH have patched it, and apparently is resolved in a later kernel:

https://bugzilla.redhat.com/show_bug.cgi?id=1188439

Got any recommendations on the way forward here? Being that the current debian kernel is significantly behind the kernel with the fixes included?

At trios, we decided to not touch kernel at all until jessie become stable…maybe some of the current bugs will be fixed untill then.

Hello @spOOn ,

You can always try current kernel from Debian experimental (3.19 now).
I’ve used it multiple times without any big hassle ( 3.17 currently running ), although it may cause problems here & there.
Usually some applications that have kernel modules/drivers may fail to rebuild them…
That ofc is for taking a relativelly small jump, like in this case 3.16 --> 3.19 ( going for 3.2 --> 3.19 on, eg. Wheezy would be a serious pain )

At any rate, it doesn’t cost you anything to give it a shot, except for some waiting*. If it’s more trouble than it’s wort, you still have original 3.16 to go back to. :slight_smile:

  • = “linux-kbuild-3.19” package is currently missing @experimental ( 3.19 headers depend on it ). :frowning:
    If you hate waiting, you can compile it yourself. All info & manual + needed patch is here.
    Otherwise, keep track here.

When it shows up, if you need help installing, ask here, or check this nice how-to:
http://anttdev.blogspot.com/2013/03/how-to-install-latest-upstream-kernel.html

Well, I guess it’s best to raise it with both of us.
However post here first, just in case it happens to be in one of our packages, or ones we’ve modified. :slight_smile:

@spOOn
@Filip
Just to mention regarding recommendations for kernel versions…ZFS on Linux is officially supported only up to version 3.16.

Hi guys, thanks very much for the good advise
@Dragan thanks for that, but I’m not using ZFS anyways…

@Filip yeah, I noticed the kbuild package was missing :slight_smile: so I’ve compiled and packaged myself, and the good news is my touchpad is now working correctly (YAY!).

Bad news is that this broadcom bcm4352 is no longer working…

I’ve tried the latest broadcom-sta-dkms from debian sid, as well as downloading the package directly from broadcom and compiling, and no luck so far.

I ever tried a couple of patches for this package floating around on the internet, which helped, but I seem to now be at a dead end (my limit :slight_smile:

http://paste.debian.net/160724/

Any advice appreciated.

Cheers,

Did you try the “linux-latest” patch from Arch/AUR? Judging by the comments/forum it seems to be compiling correctly on 3.18/3.19 kernels with it…
https://aur.archlinux.org/packages/broadcom-wl/
https://bbs.archlinux.org/viewtopic.php?pid=1495005#p1495005
:slight_smile:

Hi guys,

Have fixed the broadcom-sta driver so that it actually works with 3.18 and 3.19

Happy to provide the fixed source if anyone is interested…