Cli Companion

Pronašao sam zanimljivo programče upravo za ovo što @calex traži, a mislim da će i drugima koristiti…lep spoj terminala i GUI-ja, sa gotovom listom često korišćenih komandi, dodavanjem svojih komandi, lakim editovanjem, pravljenjem profila, dovlačenjem komandi sa interneta…svega 50-ak KB, a svašta ima :slight_smile:

[ATTACH]909.IPB[/ATTACH]

Instalacioni fajl se nalazi na

https://launchpad.net/clicompanion/1.0/1.1/+download/clicompanion_1.1-6__bzr109_all.deb

Делује занимљиво, пробао сам и личи. Шта да радим, ко је једном користио 4dos, тешко да може без оваквих … помагала.

Alal ti vera Dragane ovo mi je trebalo !!!

:slight_smile:

[ATTACH]910.IPB[/ATTACH]

napraviš csv history-ja sa servera, spojiš sa .clicompanion2 (običan text) iz home foldera i eto ti proširene biblioteke komandi :slight_smile:

Има овде материјала за играње, ја ионако сачувам .bash_history фајл да бих у новим инсталацијама имао већ откуцане команде па бих баш могао и да направим компилацију њега и овог из програма …

Понекад се сетим ситних помагала које сам користио и нема већег мерака него кад нађем нешто слично. Ко сад да кликће по стрелици и пази када ће да се појави жељена команда, овако се лепо потражи на списку и одради.

@calex

Mislim da ćeš sada malo manje mrzeti cli… :slight_smile:

Ништа ја не мрзим, само користим оно што је лаганије и нуди више могућности. Апдејт радим из конзоле а не апдејтером, зато ми је лакше кад има помагала да се не мучим превише. Ту и тамо откуцам још нешто па је добро што је и ово стигло на ред.

Ako si mrzovoljan da kucaš komande možeš bindovati određena slova da rade određenu radnju i to je opcija…

Pozdrav, prvi put na Mint-u, već dugo na linuxu, uglavnom Ubuntu i Kubuntu. Kako mi KDE mnogo više prija nego Unity posle katastrofe sa nadogradnjom KDE bete rešio sam malo da probam druge distribucije i mada je svaki KDE manje više isti reših da se zadržim malo ovde. E sad problem nastaje baš kod cli-companiona koji je svuda radio kako treba sem ovde gde neće da se pokrene, instalirao deb sa Launchpada.
Da li se još nekom to dešavalo?

dejan-Satellite-L40 dejan # clicompanion
Using locale in system
Traceback (most recent call last):
File “/usr/bin/clicompanion”, line 65, in
from clicompanionlib.view import run
File “/usr/lib/python2.7/dist-packages/clicompanionlib/view.py”, line 53, in
import clicompanionlib.tabs as cc_tabs
File “/usr/lib/python2.7/dist-packages/clicompanionlib/tabs.py”, line 40, in
import gconf
ImportError: No module named gconf

Gde da nađem gconf?

@cvexkeks

Probaj

sudo apt-get install python-gconf

@Dragan
dejan-Satellite-L40 dejan # clicompanion
Using locale in system
Traceback (most recent call last):
File “/usr/bin/clicompanion”, line 65, in
from clicompanionlib.view import run
File “/usr/lib/python2.7/dist-packages/clicompanionlib/view.py”, line 53, in
import clicompanionlib.tabs as cc_tabs
File “/usr/lib/python2.7/dist-packages/clicompanionlib/tabs.py”, line 44, in
import clicompanionlib.preferences as cc_pref
File “/usr/lib/python2.7/dist-packages/clicompanionlib/preferences.py”, line 46, in
import clicompanionlib.config as cc_config
File “/usr/lib/python2.7/dist-packages/clicompanionlib/config.py”, line 54, in
“font”: (cc_utils.get_system_font(), ‘font’),
File “/usr/lib/python2.7/dist-packages/clicompanionlib/utils.py”, line 221, in get_system_font
system_font = value.get_string()
AttributeError: ‘NoneType’ object has no attribute ‘get_string’

Kao mali napredak, ali i dalje ne radi

[/u]

Hm? možda je ovde problem…probaj da dodaš repoe za clicompanion. Prethodno ga deinstaliraj (potpuno) sa

sudo apt-get purge clicompanion

Sa https://launchpad.net/clicompanion/

You can add the PPA and install CLI Companion with these commands run in a Terminal:

sudo add-apt-repository ppa:clicompanion-devs/clicompanion-nightlies
sudo apt-get update
sudo apt-get install clicompanion

Probao i to, isti problem s tim što mi onda prikazuje i grešku kod “sudo apt-get update”, ne mogu sad da se setim, ali čini mi se da javlja da mu baš taj ppa pravi problem :frowning:

@cvexkeks

Identičan problem/bug postoji i zvanično, ali nažalost izgleda da još nije rešen

https://bugs.launchp…on/ bug/1072253

Onda čekam novu verziju, nije mi problem običan terminal, samo ne volim kad nešto ne radi, hvala na pomoći.

Zadnja verzija sa tog repozitorijuma je za Prcise=Mint 13, ako imas Mint 14 prepravi sources za taj ppa na precise pa pokusaj ponovo.

Ja ima ovu verziju i radi, KNada 14 distro
https://launchpad.net/clicompanion/1.0/1.1/+download/clicompanion_1.1-6__bzr109_all.deb