Dualboot problem

Pozdrav!

Odradio sam dualboot, ali imam problem (i nije toliki problem, al ajd) da kada palim laptop pri paljenju dobijam listu na kojoj izabiram da li hocu win ili linux, a kasnije kad izaberem linux dobijem grub na kojem opet izabiram linux (a u ponudi stoji i win) tako da…

Da li bi mogao nekako da koristim samo grub? (nekako mi je bolji)

Ako ne, kako da izkljucim grub screen?

Unapred hvala…

Ако си имао win па linux, онда није требало ништа да радиш. Шта уопште значи … odradio sam dualboot? Ако хоћеш само груб, стартуј линух па у конзоли куцај sudo grub-install /dev/sda ако је све то на правом харду. Онда ће да остане само груб. Ако имаш више хардове, можда иде мало другачије.

Znaci samo sudo grub-install /dev/sda i radice? Necu imati grub na 2 mesta…

Inace ja imam i /boot particiju i na nju sam stavio da ide bootloader, jer sam tako citao na netu jedno uputstvo, sad, da li to moze da zakomplikuje stvar?

Update:

Nakon toga, sada mi je po defaultu grub, ali kad pokusam da udjem u windows izbaci mi da mbr (ili tome slicno) nedostaje i nemogu dalje…

Kako to fixovati?

Unapred hvala…

Update 2:

Da li je ovo mozda resenje? http://helpdeskgeek.com/how-to/fix-mbr-xp-vista/

Ako ti se Windows zbrljao sa MBR (a on to hoće jako često da radi) onda primeni te savete sa tog linka što si okačio i trebalo bi 99% da proradi.

Ја сумњам да је проблем био у ономе … odradio sam dualboot … и тако је windows mbr поремећен … а онда је преко тога преписан груб и више не може да ради mbr. Решење јесте на оном линку па према томе да ли имаш xp или седмицу решаваш mbr али после остајеш без груба и линуха. Пре него све ово урадиш, скини supergrub и нарежи га на неки rw диск, оправи windows, покрени supergrub па стартуј линух и онда опет одради sudo grub-install /dev/sda па ће све да буде у реду. Мени се то десило пар пута када сам мењао windows па морао да враћам груб … мада је код мене предност што имам два харда па увек имам алтернативно стартовање.

Uspeo sam da povratim windows. Sada pri butovanju opet imam istu situaciju… :wink:

Update:

Fiksovao koristeci program EasyBCD gde sam uklonio linux sa liste, a za ujednos sam stavio i da preskoci mbr, tako da je sve fiksovano…

Hvala na pomoci!

P.S. Ovo je 200 poruka… jeee :connie_crazyperson:

Ajd’ da ne otvaram novu temu (ako treba otvoricu):
imao sam Win7 i Linux 15 (cinnamon), instalirao prvo Win pa Lin i sve je radilo super (mogao sam da biram sta cu da bootujem), ali je onda Windows pukao (sta bi drugo Windows radio) pa sam morao da ga reinstaliram (tacnije, opalio sam jedan klasican format i instalirao svezu kopiju Win7 Ultimate) i sad vise nemam Boot Menu gde mogu da biram Lin ili Win… ima li resenja?

Unapred hvala.

Windows ti je pregazio GRUB, tj. instalirao svoj bootloader, koji naravno ne vidi nista sem Windows-a :smiley:

The resenje:
Podignes Mint 15 u Live mode sa CD-a ili Flash-a -> upadnes u Terminal:
1.

sudo fdisk -l

iz ispisa vidis na kojoj ti je particiji Mint instaliran ( ako nisi siguran, baci ovde ispis, pa da vidimo ).

sudo -i

mount /dev/sdxX /mnt * grub-install –root-directory=/mnt/ /dev/sdX *

* sdxX zamenis sa adekvatnom particijom ( korak 1. ) i naravno komandu kucas bez “*”

  1. Restartuj, i to bi trebalo da je to. Samo prvo podigni Mint, pa:

sudo update-grub

da bi mogao pokrenes Win kasnije.

Za slucaj da ne uspe, tj da ne dobijes GRUB nakon koraka 1 i 2 ili Mint nije boot-abilan, podigni opet Mint Live, pa:

sudo -i
mount /dev/sdxX /mnt *
mount --bind /proc /mnt/proc
mount --bind /dev /mnt/dev
mount --bind /sys /mnt/sys
chroot /mnt update-grub
umount /mnt/sys
umount /mnt/dev
umount /mnt/proc
exit

I naravno restart. :slight_smile:

Thanx Cofi na odgovoru :slight_smile:
Ovako:

  1. za prvo resenje posle unesenog

grub-install --root-directory=/mnt/ /dev/sda
izbacuje

grub-probe: error: failed to get canonical path of /cow
Linux je instaliran na sda4

a druga opcija works like a charm - opet imam izbor za boot OSa! :smiley:

Veliko hvala jos jedared! :wink:

Meni je supergrub uvek jednostavnije rešenje. Jednom mi je bilo potrebno, našla sam to kao varijantu i radi samo tako. Napravi se supergrub disk (CDRW, DVDRW, USB) i startuje pa odmah na početku izlista instalirane operativne sisteme. Odatle se startuje linux a posle je lako. Samo sudo grub-install /dev/sdX (obično /dev/sda) i još sudo update-grub.

Bio sam prinudjen da u dualboot-u podignem W7 i AV linux 6.0.2. Nakon instalacije linuksa, GRUB vidi samo njega…wina nema.
Ima li kakve pomoci ili “Jovo nanovo”?

Si probao da osvezis grub? Ako nisi udri:

sudo update-grub

Trebalo bi da ga detektuje… :slight_smile:

Naravno da ga je osvezilo, kad sam zamenio tastaturu :slight_smile:

Kucao sam tu komandu, jedno pet puta “slepo” i non-stop mi izbacuje poruku da je kommanda nepoznata.

Tek kad sam pogledao, “r” je riknulo…

@Cofi, drugar si!!

Pozdrav!

pozdrav…da ne otvaram novu temu…ovako imao sam dualboot mint13 i win7 na istom hardu e sad trebao mi je xp sp2 zbog flesovanja creativ mp3 playera pa sam na nekom starom ata hardu instalirao xp i on je samoinicijativno pregazio mbr na ovom prvom hardu iako je instaliran na zasebnom i sada ne mogu da pokrenem niti mint niti 7-cu.imam supergrub disk ali ni sa njim vise nije moguce da se pokrene niti jedan od sistema">http://dscf0615.jpg
e sad digo sam mint16 live sa usb i sve je tu evo ispisa iz terminala:

[email protected] ~ $ sudo fdisk -l

Disk /dev/sda: 320.1 GB, 320071851520 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625140335 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xcd7ebbfa

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT
/dev/sda2 206848 209922047 104857600 7 HPFS/NTFS/exFAT
/dev/sda3 209926080 416782799 103428360 7 HPFS/NTFS/exFAT
/dev/sda4 416784382 625139711 104177665 5 Extended
/dev/sda5 416784384 424781823 3998720 82 Linux swap / Solaris
/dev/sda6 424783872 544782335 59999232 83 Linux
/dev/sda7 544784384 625139711 40177664 83 Linux

Disk /dev/sdb: 8103 MB, 8103395328 bytes
255 heads, 63 sectors/track, 985 cylinders, total 15826944 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00107148

Device Boot Start End Blocks Id System
/dev/sdb1 * 16128 15826943 7905408 c W95 FAT32 (LBA)
[email protected] ~ $

sada ja nisam siguran gde je instaliran mint sda6 ili sda7 i nemam pojma kako da sredim ovo jer se plasim da ne napravim jos vece s***e…

Verovatno je / (root) na prvoj particiji a /home na drugoj, obično se tako radi, ali i ako promašiš nije strašno, ponovićeš sve sa drugom particijom.

Primetih još nešto, imaš 3 primarne particije, mislim da to baš nije pametno, kad sledeći put budeš particionisao stavi max 2 primarne a sve ostalo pod extended.

evo sta izbacuje

[email protected] ~ $ sudo mount /dev/sda6 /mnt
[email protected] ~ $ grub-install –root-directory=/mnt/ /dev/sda
unshare failed: Operation not permitted
grub-probe: error: failed to get canonical path of /cow.
More than one install device?
Usage: grub-install.real [OPTION] [INSTALL_DEVICE]
Install GRUB on your drive.

  -h, --help              print this message and exit
  -v, --version           print the version information and exit
  --modules=MODULES       pre-load specified modules MODULES
  --boot-directory=DIR    install GRUB images under the directory DIR/grub
                          instead of the /boot/grub directory
  --target=TARGET         install GRUB for TARGET platform
                          [default=current]
  --directory=DIR         use GRUB images from DIR. Takes precedence
                          over target
  --grub-setup=FILE       use FILE as grub-setup
  --grub-mkimage=FILE     use FILE as grub-mkimage
  --grub-mkrelpath=FILE   use FILE as grub-mkrelpath
  --grub-probe=FILE       use FILE as grub-probe
  --allow-floppy          make the drive also bootable as floppy (default
                          for fdX devices). May break on some BIOSes.
  --recheck               delete device map if it already exists
  --force                 install even if problems are detected
  --force-file-id         use identifier file even if UUID is available
  --disk-module=MODULE    disk module to use (biosdisk or native). This
                          option is only available on BIOS target.
  --no-nvram              don't update the `boot-device' NVRAM
                          variable. This option is only available on
                          IEEE1275 targets.
  --removable             the installation device is removable. This option
                          is only available on EFI.
  --bootloader-id=ID      the ID of bootloader. This option is only
                          available on EFI.
  --efi-directory=DIR     use DIR as the EFI System Partition root.
  --uefi-secure-boot      install an image usable with UEFI Secure
                          Boot. This option is only available on EFI and if
                          the grub-efi-amd64-signed package is installed.
  --no-uefi-secure-boot   do not install an image usable with UEFI Secure
                          Boot, even if the system was currently started
                          using it. This option is only available on EFI.

INSTALL_DEVICE must be system device filename.

grub-install.real copies GRUB images into /boot/grub, and uses grub-setup
to install grub into the boot sector.


Report bugs to .
[email protected] ~ $ 

Samo da napomenem za sve:
[SIZE=18px]Kada imate dva fizicka hard diska, i instalirate Windows, on ce uvek upisati svoj bootloader u MBR prvog diska[/SIZE] (koji je prvi mozete proveriti u BIOS-u, obicno pod “Hard disc boot priority” ili tome slicno )[SIZE=18px].[/SIZE]
[SIZE=18px]Najsigurnija metoda je da jednostavno fizicki iskljucite hdd na koji ne zelite da zavrsi bootloader, instalirate Win, pa ga prikljucite ponovo[/SIZE][SIZE=18px].[/SIZE]

@djeembe:

Najsigurnije ti je da iz live-a mountujes recimo /dev/sda6, pa proveris u File Manager-u sadrzaj… :slight_smile:

sudo mount /dev/sda6 /mnt

Nakon toga odes kroz FM u /mnt pa vidis sta ima, prepoznaces vec da li je root ili ne.
Ako jeste, samo nastavi:
http://www.foss.rs/index.php/topic/1010-dualboot-problem/#entry33959

Ako nije:

sudo umount /dev/sda6

pa probas /dev/sda7 i tako u krug… :smile:

ja probao i dev sda6 i dev sda7 i uvek isto pokazuje jel postoji drugi nacin ja ovako nemogu/ne znam???
">http://screenshot.png

inace to je ovako
[/URL] [/url]">http://[url=http://www.dodaj.rs/?3D/7C/20PtzpzU/screenshot-1.png]screenshot-1.jpg na ovom od 61gb je root a manja 41 je home

Ok, ako si siguran da je ova od 61GB root (screenshot ukazuje da jeste), onda je /dev/sda6 u pitanju. :slight_smile:

Onda ovako cepaj redom iz live-a:

sudo -i
mount /dev/sda6 /mnt
mount --bind /proc /mnt/proc
mount --bind /dev /mnt/dev
mount --bind /sys /mnt/sys
grub-install –root-directory=/mnt/ /dev/sda
chroot /mnt update-grub
umount /mnt/sys
umount /mnt/dev
umount /mnt/proc
exit

Nakon toga restart, i to bi trebalo da je to. :smile:

Zdravo

@djeembe:

ako ti ovo ne uspe probaj sa boot repair
može i u live mintu to da se uradi
evo ti repo
sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair
boot-repair
sa njim možeš da namestiš i redosled podizanja OS-a
on vrši upis i u win bootloader i u grub