/etc/fstab - šta, kako

Pošto sam kupio novi hard disk, odlučio sam da pomoću Clonezilla kloniram postojeću Neptune instalaciju sa starog diska na novi i uspešno sam to uradio.

E sad stari sistem je na /dev/sda1, particija sa podacima je /dev/sda4

Izvadio sam stari disk i ostavio samo novi.
Tako da novom disku sistem je na /dev/sda6, podaci na /dev/sda5

Na novom disku stoji /etc/fstab od prethodnog, znači piše

# /etc/fstab: static file system information.
#
#      
proc /proc proc defaults 0 0
sys /sys sysfs defaults 0 0

/dev/sda1 / ext4 defaults,errors=remount-ro 0 1

/dev/sda4 /data ext4 defaults,errors=remount-ro 0 0

Ali sistem se najnormalnije pokrenuo, kad iz Dolphina kliknem sa strane na “data” particiju, odmah se najnormalnije mountuje, iako je /etc/fstab netačan. Kako to?

[hr]

Zatim drugo pitanje, pošto sam na novi disk ubacio i Windows8 (ne pitajte zašto), kapirao sam da ovo treba dodati u fstab:

/dev/sda1	   /media/win8	 ntfs defaults,errors=remount-ro 0 0

I naravno ispravio sam ceo fstab kako treba, restartovao računar ali ne mogu mountovati tu particiju

[email protected]: / # mount /dev/sda1
Windows is hibernated, refused to mount.
Failed to mount '/dev/sda1': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Moguće da sam stavio Windows na hibernaciju (ne sećam se) ali svejedno, stavio sam u fstab errors=remount-ro ali neće, tek ako ukucam mount /dev/sda1 --ro onda se mountuje. Možda to što je sistem u hibernaciji ne spada u “errors”?

Promenio sam tu liniju napisao sam samo

/dev/sda1	   /media/win8	 ntfs defaults,ro 0 0

I kad probam iz Dolphina da mountujem, piše

An error occurred while accessing ‘Home’, the system responded: The requested operation has failed.: Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/sda1 on /media/win8

A ako kao root ukucam mount /dev/sda1, onda radi ok

Očigledno ne znam toliko o mountovanju i fstab kao što sam mislio…

ubacio i Windows8 (ne pitajte zašto

Ja moram da pitam zasto ne 7-ica, od dva zla, mnogo je manje… :smiley:

Sto se hibernacije tice:

  1. on Windows 8 it’s normal. You need to shut down Windows 8 via cmd by entering shutdown /f /s /t 0 then it might work.
  1. Windows 8 adds a “fast startup” feature. It does make Windows start up faster after a shutdown, but as a side effect it ends up putting your filesystem in that hibernating state.
    To disable this feature in Win 8, search for “choose what the power buttons do” under settings, click the shield to unlock the checkboxes, and you can enable or disable the fast startup from there.

Ili najlakse, nemoj gasiti komp iz Win-a, samo restartuj, pa gasi iz lunksa, na taj nacin ces zaobici hibernaciju.
Sad samo pripali Win, pa restart, i nakon toga mount-ovanje ne bi trebao da ti pravi problem… :slight_smile:

Prva rečenica :smiley:
http://forum.opensou…nux/#entry29989

Eh, hibernacije i multibootovi… i posle se čovek buni što mu sve obaška automatski ne radi onako kako je napravljeno da radi čak i kad ne misli :wacko3: .

:sarcastic: :biggrin: :biggrin:
Al’ moram da primetim, da je uzrok i jednom i drugom sam Win… :smiley:

Sto se prvog pitanja tice, da li kada Delfin mountuje particiju, mountuje u /data ili negde drugde?
Nemam iskustva sa Delfinom, ali ako je kao Thunar, nije bitno sta imas u fstab-u vec ce mountovati sistem koji odaberes na neko predefinisano mesto (/media/$LABEL).
Ako pak mountuje u /data, onda je zaista cudno.

Sto se drugog pitanja tice, kad mountujes kao root sa:

mount /dev/sda1

Probaj da promenis vlasnika sa:

chown {korisnik}:{korisnik} /media/win8

onda probaj:

sudo umount /dev/sda1

Pa vidi jel ce moci iz file manager-a.
Ako ne, mozes i da probas sa “user” u fstab-u posle opcije “defaults” (man fstab)
Sve zavisi kako taj Delfin radi to mountovanje.

^^

MIslim da je njemu “data” label particije verovatno Ntfs, i naravno Dolphin je lepo mauntuje u /media/sdaX svaki put kada klikne na “data”. Tuks, bolje ubaci u fstab tu particiju, primera radi ako napraviš neke muzičke play-liste da ne moraš stalno da klikćeš i mauntuješ data particiju.

He kakvi ste ljudi, ja lepo reko ne pitajte a oni pitaju :slight_smile: (apsolutno mi nebitno koji je win u pitanju, a kad sam vec instalirao osmicu - bila mi pri ruci - neka je, dobro radi)

Meni nije problem da nadjem zaobilazni put kao sto neki kazu “nemoj stavljati na hibernaciju pa se nece desiti”. Zelim da dublje razumem sta kako i zasto, kakve Linux veze ima sto je Win u hibernaciji na svojoj particiji, all in all it’s all just files on ntfs

@[member=‘drinx’] Ne bre, “data” je ext4 particija i mountujem je na /data :slight_smile:

Ajde uci cu malo kasnije na Linux pa cu detaljnije da pojasnim situaciju

Ali i dalje mi nije jasno kako je neispravan fstab radio :confused:

Evo Tuksero malo za čitanje :):

http://www.h-online.com/open/features/Linux-and-Windows-8-Fast-Startup-puts-data-at-risk-1780640.html