Flash: mint-flashplugin-11 vs. adobe-flashplugin

Ne znam kako mi je ovo promaklo, ali flashplugin koji dolazi sa Mintom za koji nisam siguran da li je preinstaliran ili se instalira kroz Add Multimedia Codecs opciju iz Wellcome Screen-a, je default flash plugin. S druge strane iz Software Managera ili Synaptic-a mozete instalirati adobe-flashplugin, koji, moram priznati, ipak radi malo bolje. Pre svega jer je verzija svezija (11.2.202.228 u odnosu na 11.0.1.152), pre svega nestao je problem kada imam otvorena dva taba sa flash sadrzajem (dva youtube taba sa dva snimka) gde ako gledam jedan onaj drugi posle nekog vremena nestane, tacnije pobeli i nista mu ne mogu sem Refresh strane. CPU/GPU zahtevnost je ista, cini mi se da je novi nekako malo glatkiji u radu da se tako izrazim (mozda je gladji? :23: ). Zna li neko u cemo je fora, zasto Mint gura out-dated plugin kao default varijantu i cemu opste Mint “verzija”?

Nisam ni ja video do prošle nedelje pa sam probao adobe plugin i jeste bolje nema šta.

Čemu Mint verzija…

Pa programeri su hteli da prilagode fleš da radi dobro pod Mintom… kako je fama oko prestanka podrške Adobe za Linux, koja je počela da se prepričava još oid polovine prošle godine, tu se stalo sa razvojem Flash Plugin-in za Mint, jer se čeka finalni ishod ili neko prelazno/trajno rešenje a da to nije upravo Adobe, iz tog razloga je i dalje stari plugin.

Sad sam video da je mint-flashplugin-11 deo mint-meta-codecs paketa, znaci ne dolazi preinstaliran vec se instalira kroz Add Multimedia Codecs opciju iz Wellcome Screen-a. S obzirom da je u pitanju meta-package, njegovim uklanjanjem se ne uklanjaju kodeci koje je instalirao, tako da u slicaju da nekoga ovo buni, slobodno moze da obrise mint-meta-package i mint-flashplugin-11 ostali kodeci i plugin-ovi ostaju.

Steta sto su programeri Minta stali sa razvojem ovog paketa, jer sam siguran da bi aktuelna Mint verzija plugin-a radila bolje na Mintu od Adobe verzije.

Edit: Ako nekoga interesuje sta mint-meta-package instalira od kodeka i pluginova:

gstreamer0.10-ffmpeg gstreamer0.10-pitfdll gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly libdvdcss2 libdvdnav4 libdvdread4 cabextract gecko-mediaplayer totem-plugins-extra unrar unshield mint-flashplugin w32codecs

i to je iz ove verzije u riznicama (2011.12.2), dok je zanimljivo da je u LMDE ovaj paket up-to-date

Version: 2012.03.27-1lmde1

i osim navedenih instalira i

gstreamer0.10-esd gstreamer0.10-plugins-good

Ne bi se ja ni igrao sa tim da nisam imao istih problema kao Shankly.

Hmm, a kako mogu ocistiti mint-ove flash plugin-ove i instalirati samo adobe? Posto imam problem da mi pobele snimci, pa gledam kako to da resim.

@MrSpaz preko Synaptic Managera obrises mint-flashplugin11 paket koji ce obrisati i mint-meta-package, ali nema veze, to meta package. E sad, ja sam sa ovim adobe-flashplugin imao problema jer je poceo da brljavi i da mi ponovo ostavlja “bele” klipove, a na samom youtube su kipovi bili zelenkasto-ljubicasti-plavicasti, dok isti snimak embeded na b92 sajtu radi normalnim bojama. Na svim browserima ista prica. Ni reinstalacija adobe-flashplugin nije pomogla, na kraju sam instalirao flashplugin-installer i flashplugin-downloader pakete koji su povukli flash plugin source paket umesto prekompajliranih .deb i sad sve radi kao zmaj, sa tri taba sa flash sasdrzajem i nijedan nije pobeleo evo ih ima 20 minuta kao rade, malo ih testiram. Inace, nesto su veci paketi za download (ukupno je bilo oko 23MB, nije pisalo sta skida samo koliko je tesko 3MB + 7MB + 900KB + 12MB, mozda neko zna koje pakete je poskidao, ja znam samo da je ovaj od 12MB flash-plugin-orig.tar.gz). Sa ovim CPU ne zakiva vise i ne ide preko 75% u 720pHD, dok je za 1080pHD od 75-80% CPU na oba jezgra.

Jok. Evo ga opet. A pobrisao sam sve vezano za adobe i macromedia u Home. To je ova verzija 11.2.202.233 koja je na LSD. Kad vratim na mint-flashplugin11 sve se varti na normalu. E show. :frowning: + :slight_smile: = :frowning:

Edit: Vracanje na 280.13 nvidia drivers nije pomoglo, znaci definitivno nesto do flash-a. Vracam se na mint-flashplugin11 dok ovo ne oprave. Aaaaaa…

Probaj da isključiš hardware acceleration. Bilo je nešto pisano o tome skoro.

Jeste hardware acceleration problem. Ne znam sto mi brlja boje, kad ugasim HA boja je ok, ali mi ubiva CPU i 1080pHD video secka (nije bas da svaki dan gledam 1080p flash sadrzaje, ali ipak me nervira). Ja sam sumnjao na video drajvere, oni i omogucavaju HA, ali i sa starim drajverima je isti problem, tako da ovaj flash ima neke bubice. Valjda ce neki update popraviti ovo.

Opšte je poznato… ako oćeš da gledaš bez problema 1080p minimum je procesor sa 2 jezgra. Sve ispod toga opterečuje CPU maksimalno.

Imam ja dva jezgra i 512MB grafiku, al opet nesto tu mulja flash player. Isti taj video u 1080p u UMplayeru kad ga strimuje sa YouTube mi zauzima 40-50% CPU. Elem, nasao sam resenje problema za ovaj bug (plavicasti video), a da li ce pomoci opstoj stabilnosti flashplugin-a videcemo, mnogi se zale da im ovo crashuje flash, meni za sada ne. Resenje je sledece:

sudo mkdir /etc/adobe

pa zatim

echo -e "EnableLinuxHWVideoDecode=1\nOverrideGPUValidation=true" | sudo tee /etc/adobe/mms.cfg > /dev/null

i sad radi :slight_smile: i sa HA podesenim, pa deo procesiranja prebacuje na GPU i ne mrchi mi mahinu; na 1080p 30fps ne prelazi CPU 75-80% sto je svakako bolje od zakucavanja na 100% i seckanja snimka.

izvor

Ovo sto sam u prethodnom postu napisao je ipak fail. I to veliki. Crashovao mi je plugin na svaki minut. Tako da je

sudo rm /etc/adobe

jedino pametno sto sam mogao da uradim, i ponovo iskljucim HA. S druge strane, Adobe je ipak izbacio upate iako su rekli da nece vise biti podrske za linux sa 1.2.202.228 > 1.2.202.233 ali se ispostavilo da je to neki security update, tako da je problem sa HA ostao i dalje.