GIMP 2.8 stiže

GIMP 2.8 stiže za oko 45 dana.

[attach=1]

PPA se može očekivati već u maju. GIMP dolazi sa jednom novinom - single window mode. Novina je u tome da je to podrazumevano rešenje, ali se svakako može promeniti, u zavisnosti kako je ko od korisnika navikao.

Fala bogu da su se setili to za “sve u jednom prozoru”… alal im pihtije za ovo!

Ја се сећам да је прошле године (ваљда), после ажурирања, Гимп радио у једном прозору, али нисам био расположен за навикавање па сам у опцијама вратио на стари изглед. Сада гледам и те опције уопште нема.
Хм, могуће је и да сам се ја тада вртео развојну 2.7 верзију, а сада је Gimp 2.6.12 … Нема везе, single window је био па је био! :23:

Jeste bio, ali sada podrazumevano dolazi, što nije ranije bio slučaj, bar ne u stabilnim verzijama…

Jedva čekam da ga bacim na test i vidim kako se ponaša, nerviraju me ti programi koji furaju Mac OSX fazon menadzera i upotreba aktivnih prozora u programu.

Od pre neki dan postoji mogućnost instalacije GIMP-2.8 RC1, doduše pomoću nezvanične skripte… Instalacija traje malo duže jer skripta dovlači ceo kod aplikacije što iznosi ~400MB…
Ja sam je probao na Kubuntu-u 12.04 i radi odlično… Nisam je probao na Mint-u, neko to može umesto mene pa da javi iskustva.

[attach=1] [attach=2]

Instalacija:

Preuzmite skriptu ovde.
Raspakujte je:

tar -xzvf SKRIPTA.tar.gz

Uđite u raspakovanu fasciklu i učinite skriptu izvršnom:

chmod +x SKRIPTA.sh

A onda je pokrenite:

./SKRIPTA.sh

Kažem opet, instalacija će potrajati, imajte strpljenja (oko 45 min). Ne morate da deintalirate GIMP-2.6, ovaj novi će se instalirati pored postojećeg…

Čekam utiske :23:

I da, podrazumevano ne dolazi single-window mode :23:

ALi može da se prebaci u single mode!?

Sigurno može, nisam čačkao… Ali prvobitna informacija je bila da podrazumevano dolazi u single-window modu, pa sam zbog toga ovo napomenuo :23:

Ja slabo baratam sa gimpom tako da od mene ne očekujte da javim utiske :23:

Ma probaću ga ja sutra, nego sam mislio da će neko već večeras, pa rek’o da javi kako i šta… :23:

Može i tako ostaje kod budućih podizanja.

Bas me zanima koje su novine u odnosu na 2.6…

Ima novih četkica i unutrašnji dizajn je malo promenjen… To je ono što je vidljivo na prvi pogled. Pravo da ti kažem, nisam ga nešto ni čačkao nakon instalacije, uhvatio sam neke druge obaveze :23:

Lepa vest. Gimp u jednom prozoru. I to je lepa vest (bar za mene). Taman sutra popodne namam nekog posla pa ću da probam da instaliram.

Da ne biste pokretali ovu skriptu i instalirali čitav kod (oko 400MB), sada je dostupan i PPA koji je namenjen baš za Ubuntu 11.10, a samim tim i Mint 12 kao potpuno kompatibilan.

sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install gimp

Nesto mu tu nije ok :23:

sudo apt-get install gimp
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gimp : Depends: libgimp2.0 (>= 2.8.0~rc1-2oneiric0~ppa) but 2.6.11-2ubuntu4 is to be installed
Depends: libgtk2.0-0 (>= 2.24.10) but 2.24.6-0ubuntu5linuxmint1 is to be installed
E: Unable to correct problems, you have held broken packages.

'ajde, probaću kasnije da instaliram kod mene… Ja sam naišao na ovaj PPA i piše da je za Ubuntu 11.10. Pa sam skontao da je i za Mint 12, bar treba da bude, jer su oni kompatibilni.

Ona skripta koju sam postavio je testirana na 12.04, a ja sam je i instalirao na Kubuntu 12.04. Ovde sad je naglašeno 11.10. Videću baš, pa javljam :23:

Da, i meni izbaci ovo i još 2-3 nerešene zavisnosti. Ako neko vozi Ubuntu 11.10 neka proba, pa neka javi. U svakom slučaju - imamo i skriptu :23:

ppa:otto-kesselgulasch/gimp-libs

Pise da mu treba i ovo ali na kraju ispadne zestoko njesra, ne moze ni taj a ne mozes ni stari da vratis. :23: :23:

libgtk2.0-0 (>= 2.24.10) but 2.24.6-0ubuntu5linuxmint1 is to be installed

Ovo ne mogu nikako da shvatim, zar ne moze da se ustanovi neki standard za biblioteke, ovako svaki distro fura svoje. Zar ne mogu programi da budu nezavisni od distibucije, kernel je kernel, KDE je KDE, gnome2 je gnome2, nikako ne uspevam da uhvatim tu nit, sta je to sto ne dozvoljava da se to tako instalira nego sve mora biti komplikovano i uvezano u sto cvorova. Ako je vec bitan distro sto se sve ne svlaci iz source za svojim libovima pa nek se komajlira samo.

Ja sam na Debian instalirao preko ove riznice:
http://notesalexp.org

Iako tu piše da je Gimp 2.7, kada se instalira dolazi 2.8 rc :23: