HP 1020

Imam problem sa štampanjem .Naime, imam štampać LaserJet 1020,skinuo sam novi HPLIP ,instalirao i sve je išlo u redu do samog štampanja. Uključim štampač da štampa test stranu, ne ištampa niša i ne pokrene ga ,a linux mi napiše da je štampanje završeno. Isto mi se događalo i sa Ubuntu dok sam imao. Koji su mi sledeći koraci?

HP printers (Laserjet and Deskjet): how to install them in Linux Mint

Jesi li ovako odradio?

Piše mi Device comunication Error (5012).

Ako pokreneš HP Toolbox kao root da li ti se ista greška javlja?

Kako ?

Štampač je normalno priključen,proverio da li radi i pod win10 (radi normalno) i u HP device menager mi piše no device fuond A pod printers mi se vidi jasno da je priključen na lokalhost.

Da nemas bug sa hplip plugins? Skoro je bio jedan bug koji je onemogucavao stampanje, pa je neki ljubazni lik
napravio AUR paket sa fix-om, kasnije su popravili, al ja se slepam uz Arch Linux :wink:
Inace jel to usb stampac?

Može biti.Stalno mi vraća na instairanje plug-in_Da USB štampač ,i javlja da nema nema ga tamo. A stalno je uklujučen štampač.
Nikako da dđedo onog trećeg koraka.
https://www.dropbox.com/s/ofbezmqkeiathc1/Screenshot%20from%202018-12-14%2013-21-07.png?dl=0

Root…

how to run applications as root in linux

Bugs…

Bugs : HPLIP

Da sam na tvom mestu uradio bih sledeće…

Prvo bih uklonio hplip-gui i hplip…

[CODE]sudo apt-get remove --auto-remove hplip-gui

sudo apt-get remove --auto-remove hplip[/CODE]

Pa bih probao pažljivo da uradim sve sa onog linka koji sam postavio iznad…

Ako to ne bi upalilo, probao bih konkretnu pretragu i zaređao od rešenja do rešenja… recimo…

device communication error 5012

Pokreni se zoki, nemoj biti pasivan i samo čekati da ti ovde neko reši problem…

Srećno.

Sve uradio i opet isto. Kad pokrenem štampač stalno mi traži da skinem i instaliram plugin. I po koji puta to uradim i opet isto. Slična stvar mi se dešavala i sa Ubuntuom.

Inace da li sistem vidi stampac proveris sa lsusb, mada to verovatno znas.

Evo ovde šta je učitao!! Imam USB Hub na kojem je štampač.

Ovako je kod mene:

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 003 Device 003: ID 046d:092c Logitech, Inc. QuickCam Chat Bus 003 Device 002: ID 04a9:2220 Canon, Inc. CanoScan LIDE 25 Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 005: ID 046d:c534 Logitech, Inc. Unifying Receiver Bus 001 Device 004: ID 03f0:002a HP, Inc LaserJet P1102 Bus 001 Device 003: ID 1a2c:2d43 China Resource Semico Co., Ltd Bus 001 Device 002: ID 051d:0002 American Power Conversion Uninterruptible Power Supply Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Znači iz nekog razloga ga ne očitava. Vidim od tebe ima ,a kod mene nema.

Probaj da promenis usb port, ne znam, ako ga ne vidi sa usb-a to kao da je veza problem. Probaj usb 2, 3 mozda proradi.
Iskljuci xhci u biosu i to.