Instalacija FreeCAD na Triosu

Problem prilikom instalacije FreeCad-a na Trios, traži tonu nekakvih zavisnosti. Neka sugestija.

@banjah2002
Problem je cnc komponenta koju si dodao i (najverovatnije) ostavio u /etc/apt/sources.list.d/trios.list kada smo isprobavali TuxPlot na TRIOS-u.

TP zahteva QT3 framework koji je izbačen iz Jessie, i kolje se sa python-qt4 koji je neophodan za FreeCad.
Dakle, ukloni cnc komponentu iz trios.list, sačuvaj je, nakon toga odradi

apt update && apt install freecad

…pa prijavi ovde rezultat kada budeš imao vremena.
Screenshot_2016-08-17_21-27-11.png

@Dragan, da li će izbacivanje cnc komponenti iz liste imati reperkusije na dalje korištenje TP-a, jer sa ovom temom svakako nisam završio i spremam se da je što prije reaktiviram čim malo popusti intezitet rada na poslu a nadam se uskoro.

Nažalost da…nakon uklanjanja cnc komponente i apgrejda na python-qt4 ponovo se javlja greška kod pokretanja TuxPlot.
Ovde nema pomoći, zato što jednostavno ne mogu postojati qt3 i qt4 verzije python-a na jednom istom računaru.
Dakle, ili se jednog od ta 2 programa moraš odreći (TP ili FCad) ili da instaliraš 2 verzije TRIOS-a na jednom računaru, 1 verzija sa cnc komponentom, druga bez nje.
Treća mogućnost je dodatni računar…

Pardon, konfliktni fajl je python-sip…kopam i dalje :slight_smile:

@Dragan
Važi druže.

Da li bi pomoglo da se problematicni fajl(ovi) drze u nekoj eksternoj lokaciji i po potrebi odrade adekvatna (un)link-ovanja? Ne bi mogla oba programa da rade u isto vreme