Instalacija LAMP

Pokusavam da instaliram LAMP na Linux Mnit 17. Koristio sam ovo uputstvo:
http://www.howtoforge.com/ubuntu-lamp-server-with-apache2-php5-mysql-on-14.04-lts

sve korake sam uspeo sem poslednjeg, 7-mog. Znaci instaliram phpmyadmin i kada ukucam u browseru
http://localhost/phpmyadmin/[/URL] (mada u ovom uputstvu pise na par mesta [URL=“http://192.168.0.100”]http://192.168.0.100, kad to ukucam nista se ne desava) kaze mi:
Not Found
The requested URL /phpmyadmin/ was not found on this server.
Apache/2.4.7 (Ubuntu) Server at localhost Port 80

Mada izgleda da imam problem sa apache2, jer kada pokusam service apache2 restart u terminalu kaze mi:

[email protected] ~ $ service apache2 restart

Odustao sam i instalirao xampp

Pogledaj u log-u zašto je davao grešku za Apache.

Jel si za php pokušao da se konektuješ na 127.0.0.1 jer je to prava adresa, 192.168.0.100 je netačno (meni ta adresa na LAN-u dovodi do mog modema) isto tako localhost se već par godina unazad ne koristi, samo kod konfiguracije kada se podešava baza pa da se ne bi kucala IP adresa servera na koji se baza instalira ukuca se samo localhost (naravno da baza u tom slučaju nije na externom serveru).

Ne znam da li se razlikuju paketi u mint-u i debian-u, mada računam da bi trebalo da bude isto ili bar slično…
Ja, recimo, imam ovo instalirano:

Installed the following packages:
apache2 (2.2.22-13+deb7u3)
apache2-mpm-prefork (2.2.22-13+deb7u3)
apache2-utils (2.2.22-13+deb7u3)
apache2.2-common (2.2.22-13+deb7u3)
dbconfig-common (1.8.47+nmu1)
libaio1 (0.3.109-3)
libapache2-mod-php5 (5.4.35-0+deb7u2)
libdbd-mysql-perl (4.021-1+b1)
libdbi-perl (1.622-1+deb7u1)
libhtml-template-perl (2.91-1)
libmcrypt4 (2.5.8-3.1)
libmysqlclient18 (5.5.40-0+wheezy1)
libonig2 (5.9.1-1)
libqdbm14 (1.8.78-2)
mysql-client (5.5.40-0+wheezy1)
mysql-client-5.5 (5.5.40-0+wheezy1)
mysql-common (5.5.40-0+wheezy1)
mysql-server (5.5.40-0+wheezy1)
mysql-server-5.5 (5.5.40-0+wheezy1)
mysql-server-core-5.5 (5.5.40-0+wheezy1)
php5 (5.4.35-0+deb7u2)
php5-cli (5.4.35-0+deb7u2)
php5-common (5.4.35-0+deb7u2)
php5-gd (5.4.35-0+deb7u2)
php5-mcrypt (5.4.35-0+deb7u2)
php5-mysql (5.4.35-0+deb7u2)
phpmyadmin (4:3.4.11.1-2+deb7u1)
Inače ja uvek idem prvo sa instalacijom php5 i phpmyadmin, potom mysql-server i tek na kraju apache2 (zbog različitih modula koje apache2 povuče ako njega prvog instaliram)… zavisnosti odrade ostalo… i naravno ako ti još nešto treba dodaješ po potrebi (curl na primer)…

Takođe, proveri da li si dobro konfigurisao sve, jer mora da te pita da li ćeš za mysql server da koristiš apache2 ili neki drugi (zaboravih koji beše)… kada sam prvi put instalirala to mi je promaklo i nisam odradila kako treba, pa naravno nije ni radilo…
Uporedi pakete, verujem da su slični… Meni na ovome što vidiš radi WordPress bez problema…

Naravno da se razlikuju paketi u Mint/Ubuntu od Debiana.

Pogrešno radiš instalaciju i nije mi jasno kako instaliraš prvo phpmyadmin pa ona Apache kada te u instalaciji za phpmyadmin pita da li koristiš Apache ili Lighttpd!? :slight_smile:
Neinstaliranjem Apache dovodiš potencijalne module u problem koji zahtevaju da su već ulitani od strane Apache-a, uostalom i piše da se prvo instalira Apache pa tek onda phpmyadmin (server nema veze on može i sam za sebe netreba mu apache)

Greška u pojašnjenju: prvo naznačim za instalaciju php5 i phpmyadmin i tako redom, a instaliram sve istovremeno (đuture)… ovakav redosled naznačavanja u debianu povuče adekvatne zavisnosti odmah…
Može zasebno prvo da se instalira i apache2, ali posle mora da se menja modul…

Kako god, ovako sam instalirala bar 20 puta :smiley: i uvek mi radi… samo što ja, kao što vidiš i ne umem najbolje da pojasnim :biggrin:

Znači razlikuje se mnogo sa ubuntu/mint?
Ja sam na ubuntu jednom davno to instalirala preko tasksel-a https://help.ubuntu.com/community/Tasksel, ne znam da li toga ima još uvek…

Redosled instalacije nema veze kada se instalira sve odjednom… :wink:

Inače mnogi ljudi ne kapiraju ali mint i ubuntu paketi uopšte nisu kompatabilni sa debian paketima, barem većina nije kompatabilna stoga ne treba pratiti uputstva za “onaj drugi” sistem.

Ima za nas lenje :biggrin:
Kad naznačiš phpmyadmin i php5 to automatski označava i php5-mysql i još neke mysql biblioteke da se instaliraju, ne moraš da kucaš zasebno :smiley:

Nisam, iskreno, znala da se u tolikoj meri razlikuju paketi u debianu u odnosu na ubuntu/mint. Računala sam da moraju po nazivu biti bar asocijativni te da se mogu porediti. Zato se izvinjavam ako sam unela zabunu.

Sad sam na poslu, mogu da pogledam kad dodjem kuci.
127.0.0.1 nisam probao, debil, ja znam da 192.168.0.100 nije, ali nisam mogao da se setim koja je pa mi bilo najjlakse sa localhost.

A kazi mi jel ima neke bitne prednosti LAMP u odnosu na XAMPP, da znam da li da se cimam ili da furam XAMPP!?

Furaj slobodno XAMPP… to je sve isto samo se način instalacije razlikuje, kranji produkt je isti.

Pozdrav svima.
Javio mi se problem sa lamp serverom posle instalacije.
Izmenio sam root folder /Home/user/www. Ali sad postoji problem: You don’t have permission to access / on this server.

Kako misliš da ubogi apač korisnik pročita novi root kad nema dozvole za čitanje? :sob::sob:

iz terminala:

sudo chown -R www-data:www-data /home/user/www/

pa proveri iz pretraživača.

Opet nece.

Ovako izgleda apache2.conf:

Options FollowSymLinks AllowOverride none Require all denied

<Directory /usr/share>
AllowOverride none
Require all granted

<Directory /Home/user/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted

Šta izbaci

ls -l /home/user/www

total 8
-rw-r–r-- 1 www-data www-data 41 Mar 11 00:30 index.php
-rw-rw-r-- 1 www-data www-data 2 Mar 11 00:29 poruka.php

Možda si zaboravio da podesiš /etc/apache2/sites-available/000-default.conf ili imaš neki drugi conf fajl koji nisi dodao na server. Apache mora da se restartuje posle promene .conf fajlova. Trenutno nisam kod kompa pa ne mogu opširnije.

Nisam sigurna da sam dobro razumela šta si menjao u apache2.conf kao ni za šta ćeš konkretno da koristiš lamp, ali ponudiću ti moguće rešenje…

U apache2.conf moraš da imaš:

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride None
Require all granted

To bi trebalo da bude u originalnom fajlu pri instalaciji, ako si to menjao, vrati pa onda uradi sledeće:

Napravi ‘radni’ folder u svom home direktorijumu, nazovi ga kako tebi odgovara, a ja ću za potrebe ovog upustva da ga imenujem my-html

Dakle, imaš direktorijum /home/user/my-html i sledeća podešavanja radiš iz terminala:

sudo chown -R www-data:www-data /home/user/my-html
sudo chmod -R 775 /home/user/my-html
sudo usermod -a -G www-data user
sudo ln -s /home/user/my-html /var/www/html

Pojašnjenje:
Prvi i drugi korak menjaju vlasništvo i daju određene privilegije nad foledrom koji se nalazi u tvom home direktorijumu kako bi apače mogao da ga pročita i menja.
Treći korak podrazumeva dodavanje tebe kao korisnika (user) u grupu sa ovlašćenjima tako da možeš i ti da čitaš i menjaš fajlove unutar foldera my-html (da bi ovo delovalo mislim da moraš da restartuješ komp).
Četvrti korak pravi link iz tvog home direktorijuma u podrazumevani direktorijum koji koristi apače (/var/www/html) i na taj način mu se omugućava direktan pristup sadržaju.

Da bi testirao, ubaci neku sliku ili pdf fajl u folder my-html (ili kako ga ti već budeš zvao) i proveri kako to izgleda tako što ćeš da u pregledaču ukucaš localhost/my-html/

Hvala na odgovor. I na pomoc.
Opet se desava isto:

[SIZE=6]Forbidden[/SIZE]
You don’t have permission to access / on this server.

Apache/2.4.18 (Ubuntu) Server at localhost Port 80

Ja sam hteo da uradim kao i ranije, da root direktorijum bude /home/user/www, a ne /var/www/html.
Pre je uspevao ali sad ne. Kada promenim direktrorijum, pojavljuje ovu gresku iznad…

Šta ti izlazi kada u pregledaču ukucaš samo localhost?
Trebalo bi da ti bude index strana Apache2…
Ako toga nema, onda si nešto zabrljao prilikom raznoraznih izmena konfiguracionog fajla i najbolje bi bilo da kompletno obrišeš ceo lamp i instaliraš ga ponovo. Ubuntu dokumentacija je vrlo bogata i sigurna sam da ćeš naći precizno rešenje kako to da odradiš za verziju koju koristiš.
Kada budeš ponovo instalirao izbegavaj da menjaš osnovne konfiguracione fajlove sem ako nisi apsolutno siguran šta radiš…

Upravo iz tog razloga sam ti i ponudila prethodno rešenje jer šta god da zabrljaš u svom home direktorijumu lako možeš da ispraviš, ali kada to odradiš u glavnoj konfiguraciji nekog servisa uvek mogu negde repovi da povuku greške… Ovo ja iz vlastitog iskustva :smiley:

Hvala na odgovorima i na savetu…
Problem resen…

Puno sam zahvalan…