Kako snimati analogni tv sadrzaj

Snimanje analognih tv kanala je nesto sto me veoma muci u linux-u, naime u poslednje 4 godine izucavanja linuxa nisam nasao ni jedan softver za snimanje analognog tv programa. Probao sam razne distroe ubuntu, mint, opensuse… medjutim sve se svodi na mencoder koji ne kapiram. E sad, da li mythtv moze da se podesi za nasu Serbiu ( Srbiju ) :23: Imam leadtek winfast2000 xp expert, na sbb-u sam. Za gledanje koristim tvtime, a tu je i malo glupji zapping. Trenutno sam na linux mint 11 gnome platformi. U dosadasnjem traganju naisao sam na jedan java program MyRTv_0.1.6_jar, samo sto nece ni da pokrene record. Uvek pukne odmah sa porukom recording process interupted. Ma ne znam, ako nesto neko zna, dajte ideju ili resenje, nemoguce da ne postoji softver za snimanje tv-a analognog naravno. :23:

Jedini program ove namene, a da kvalitetno radi, je xdtv. Ima malo zongliranja dok se instalira, ali radi na raznim distribucijama, pa i na mintu. Imam Leadtek winfast xp rm karticu. Problem mi se pojavio od kernela 3.* gde vise ne mogu da snimam zvuk. Na ranijim kernelima sve radi savrseno. Mislim da jos snima i xawtv, ali je izbor kodeka za snimanje daleko siromasniji nego kod xdtv-a.

Pozdrav!

Hvala na saradnji, najzad neko da se pozabavi mojim problemom. Probacu da instaliram xdtv pa se javljam. U medjuvremenu sam naisao na " mtvcgui", frontend za “mencoder” (Mplayer), ali ne moze da startuje capture, isti problem imam i sa " myrtv" programom, kao da sistem " ubije " proces koji ovi programi zele da izvrse, izvrsavaju. Jedino sto sam uspeo je capture putem VLC plejera, ali bez zvuka i to 5 min. snimanja = 300-400 MB, sa losim kvalitetom slike. :slight_smile:

Instalirao sam xdtv, žonglirao baš dosta i oko instalacije, i podešavanja, ali ne radi. Tačnije nemam sliku preko njega ( samo zelena površina na delu gde treba da bude tv slika ), zvuk sa tv-a imam, koji ostaje i posle gašenja aplikacije, te moram da restartujem računar da bi prestao da slušam tv, koji bi i da gledam, a ako može i da snimam, ali malo teže ću nešto uspeti da snimim.

Ljudi da li je neko ikada uspeo da nešto snimi preko analognih inputa, televizijski kanali, ili neka kamera starija što ide na činč ? Preko tvtuner-a naravno.

Ja sam totalno :slight_smile:

Ако си спреман да мало жонглираш, требало би да можеш на следећи начин:

  • укључиш твтајм, изабереш канал који желиш;
  • искључиш ту апликацију, стартујеш ВЛЦ и укључиш из падајућег менија опцију за напредне контроле (да би могао да снимаш):
  • у ВЛЦ-у идеш на Open capture device, изабереш из листе видео уређај који желиш, исто урадиш и са аудио уређајем и кликнеш Play;
  • снимаш садржај. :slight_smile:

Ово би у теорији требало да ради, тренутно ми тв кабл није прикључен па не могу да проверим да ли се променом канала у Твтајму мења и у ВЛЦ-у (не могу обе апликације истовремено да користе тв картицу па мораш да искљ. ВЛЦ да би променио програм у Твтајму). И чини ми се да ће ти звук остати забагован до рестарта макар и искључио ВЛЦ.

Пробај, јави да ли је успело. :slight_smile:

@milke
Naravno da sam spreman da malo žongliram, ali što se VLC-a tiče, pisao sam u gornjem postu o tome kako snima. Snima žešće loše :slight_smile:
Dakle slika i zvuk su asinhroni, fajl je prevelik 5 min. za test snimak koji sam radio je bio oko 400 MB, kvalitet samog snimka je očajan.

Nego zamolio bih te nešto da uradiš, probaš : :slight_smile:

Када идем на оно дугме за снимање у Fast recording, каже само “Error: Process of recording interrupted”, и ништа се не деси.
Најновија верзија је из 2009. године, тако да није ништа чудно што више не ради… А и аутор је прилично лош са енглеским језиком: redme, Abaut, граматичке грешке… :slight_smile: Да му бар апликација ради све бих му опростио, овако нема 'леба :slight_smile:

Prvo, hvala ti što si probao.

Drugo, program je odlično zamišljen, samo još da radi… i meni izbacuje isti error , ali sam se ponadao da ceš ti, ili neko drugi ko ovu temu čita, imati ideju zašto program neće da pokrene snimanje, a ne da ga kritikujemo što ima pravopisnih grešaka u uputstvu.

Ima još jedna aplikacija ( mencoder frontend ), koja takođe ne može da pokrene snimanje, kao i ovaj drugi o kojem smo pisali. Tako da sumnjam da nije problem u aplikacijama, pre će biti da mi nešto ne znamo da uradimo.

Ako si raspoližen, zamolio bih te da probaš i " mtvcgui "

http://code.google.com/p/mtvcgui/

Takođe iz 2009. pa šta.

Jesteś pewien, że wszystko jest ok z mencoderem?
Wykonaj jakieś polecenie mencodera w konsoli i zobacz co sie dzieje.

How to do it ? More help please :slight_smile:

[email protected] ~ $ mencoder
MEncoder SVN-r33713-4.6.1 (C) 2000-2011 MPlayer Team
No file given
Exiting... (error parsing command line)
[email protected] ~ $

Ја сам на ово заборавио када сам прочитао с другог рачунара на ком не могу да испробавам.

Елем, мислим да је Przemek предложио да у терминалу покренеш mencoder и видиш да ли пријављује неку грешку. Мени пријављује ово:

mencoder: relocation error: mencoder: symbol ff_codec_bmp_tags, version LIBAVFORMAT_53 not defined in file libavformat.so.53 with link time reference

Сутра ћу да се позабавим још мало тиме, сигурно је тај проблем постојао и раније.

Przemek, thank you for joining the forum and participating! :slight_smile:

Odlično, svaka čast Przemeku. Pozabavi se, pa da rešimo problem.

Thank you for joing our community, and tnx for this such a cool software, cheers :slight_smile:

I tried[font=arial][background=rgb(245, 245, 245)] [/background][/font][font=arial][background=rgb(245, 245, 245)]to[/background][/font][font=arial][background=rgb(245, 245, 245)] [/background][/font][font=arial][background=rgb(245, 245, 245)]open[/background][/font][font=arial][background=rgb(245, 245, 245)] [/background][/font][font=arial][background=rgb(245, 245, 245)]Suse[/background][/font][font=arial][background=rgb(245, 245, 245)] [/background][/font][font=arial][background=rgb(245, 245, 245)]12 and[/background][/font][font=arial][background=rgb(245, 245, 245)] [/background][/font][font=arial][background=rgb(245, 245, 245)]I also have[/background][/font][font=arial][background=rgb(245, 245, 245)] [/background][/font][font=arial][background=rgb(245, 245, 245)]a problem[/background][/font][font=arial][background=rgb(245, 245, 245)] [/background][/font][font=arial][background=rgb(245, 245, 245)]with recording[/background][/font][font=arial][background=rgb(245, 245, 245)] [/background][/font][font=arial][background=rgb(245, 245, 245)]with[/background][/font][font=arial][background=rgb(245, 245, 245)] [/background][/font][font=arial][background=rgb(245, 245, 245)]mencoder[/background][/font][font=arial][background=rgb(245, 245, 245)].[/background][/font]

mencoder -tv input=0:driver=v4l2:width=384:height=288:fps=25:audiorate=44100:device=/dev/video0:norm=PAL-DK:chanlist=europe-east:channel=436 -oac mp3lame -lameopts cbr:br=128:aq=1:vol=0: -ovc lavc -lavcopts vcodec=mpeg4:vbitrate=900:mbd=2:turbo -vf pp=lb -o /home/user/gd201205242324.avi tv://

[font=arial][background=rgb(245, 245, 245)]After this command[/background][/font][font=arial][background=rgb(245, 245, 245)] [/background][/font][font=arial][background=rgb(245, 245, 245)]gets the[/background][/font][font=arial][background=rgb(245, 245, 245)] [/background][/font][font=arial][background=rgb(245, 245, 245)]message:[/background][/font]

Unable to open '/dev/dsp': No such file or directory

[font=arial][size=4][background=rgb(245, 245, 245)]So[/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)] [/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)]if he did not[/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)] [/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)]see[/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)] [/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)]a sound card.[/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)] [/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)]In[/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)] [/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)]google[/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)] [/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)]I found[/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)] [/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)]to add[/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)] [/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)]alsa[/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)] [/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)]to the[/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)] [/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)]command line:[/background][/size][/font]

mencoder -tv input=0:driver=v4l2:width=384:height=288:fps=25:audiorate=44100:alsa:device=/dev/video0:norm=PAL-DK:chanlist=europe-east:channel=436 -oac mp3lame -lameopts cbr:br=128:aq=1:vol=0: -ovc lavc -lavcopts vcodec=mpeg4:vbitrate=900:mbd=2:turbo -vf pp=lb -o /home/user/gd201205242324.avi tv://

[font=arial][size=4][background=rgb(245, 245, 245)]N[/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)]ow[/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)] [/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)]mencoder[/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)] [/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)]record[/background][/size][/font][font=arial][size=4][background=rgb(245, 245, 245)].[/background][/size][/font]

In myrtv I add alsa: command in to file: [font=arial][size=4][background=rgb(245, 245, 245)]/home/user/.myrtv/avset1 (on end of first line)[/background][/size][/font]

[font=arial][size=4][background=rgb(245, 245, 245)] width=384:height=288:fps=25:audiorate=44100:alsa: avi [/background][/size][/font]
[font=arial][size=4][background=rgb(245, 245, 245)]Restart myrtv. Myrtv record.[/background][/size][/font]
[font=arial][size=4][background=rgb(245, 245, 245)]But, if you do any changes in “Settings->A-V->tab General” you must replay this operation.[/background][/size][/font]

Yes, that is finally solve the problem with record/capture analog tv channels with your excellent application " Myrtv " :slight_smile: . In my case i just have to change tv norm to PAL-BG in the line.

mencoder -tv input=0:driver=v4l2:width=384:height=288:fps=25:audiorate=44100:alsa:device=/dev/video0:norm=PAL-BG:chanlist=europe-east:channel=436 -oac mp3lame -lameopts cbr:br=128:aq=1:vol=0: -ovc lavc -lavcopts vcodec=mpeg4:vbitrate=900:mbd=2:turbo -vf pp=lb -o /home/user/gd201205242324.avi tv://

Thank you for made so useful application !

Do you have any idea why sound capture goes over a MIC input. I have Creative Labs SB0400 Audigy2 Value sound card, and use TAD-in for audio input from tvtuner. TAD-in is a " Phone " channel in alsamixer, controled by " Analog Mix ".
How to set in “Myrtv” other " volume control " options then cd, line, tv card ? I need to set to Analog MIx. :slight_smile:

You have sound in recorded file by myrtv now ?

Yes i have, but recorded sound is captured from speakers in my room, through microphone on my desk, near by speaker. Because i can’t connect tvtuner audio cable directly in sound card line in, or cd. I have to use TAD-in “Pone”, input on sound card to get sound from tv. I must configure “Myrtv” to capture from sound from “Phone” input ( Analog Mix ), instead of cd, or line in.

[font=tahoma][size=3][background=rgb(255, 253, 250)]Try in “Myrtv” other " volume control " set tv card and put [/background][/size][/font][font=tahoma][size=3][background=rgb(255, 253, 250)]adevice=[/background][/size][/font][font=tahoma][size=3][background=rgb(255, 253, 250)]hw.0[/background][/size][/font]
[font=tahoma][size=3][background=rgb(255, 253, 250)]But now i have problem with wach tv in myrtv on that seting.[/background][/size][/font]

I change to adevice=hw.1, because i have two sound card devices in my pc, built in sound, and pci sound card ( audigy 2 value ), tvtuner in connected to pci audigy 2 value. According to alsa configuration, pci card ( audigy 2 value ) is hw:01. When i set adevice=hw.0, i can’t capture sound at all ( even [size=4][font=tahoma][background=rgb(255, 253, 250)]through mic [/background][/font][/size][font=tahoma][size=4][background=rgb(255, 253, 250)] [/background][/size][/font][size=4][font=tahoma][background=rgb(255, 253, 250)] :slight_smile: ).[/background][/font][/size]

Anyway i change in “Myrtv” other-volume control-tv card, adevice=hw.1, but still volume capturing goes over speakers—mic scenario.

I wonder how to configure something like this: “hw.1 = analog mix” to be by default. Somewhere in general alsa configuration maybe… i searching for solution.

Read abaut amixer
examply:
amixer -c 0 set Tv cart mute
amixer -c 0 set CD cap
amixer -c 0 set Tv cart cap
http://linux.die.net/man/1/amixer