KDE anti-aliasing

Ovako mi izgledaju fontovi na KDE, ali ne svi fontovi, nego samo neki fontovi.

http://www.2shared.com/photo/CijzaNsV/snapshot1.html

I ne samo fontovi, recimo, widgeti na desktopu isto nemaju anti-aliasing. Fontovi na njima imaju, dok ne zavrtim widget (rotate opcija), a kada ga zavrtim, onda ni oni nemaju :slight_smile:

Jel ima neko neku ideju kako da namestim antialiasing?
Neko je pomenuo GTK temu, šta je to? :smiley:

Vala i gtk tema je horor :smiley:

sudo pacman -S oxygen-gtk2 oxygen-gtk3

pa u "System Settings -> Application appearance -> GTK odaberi oxygen-gtk gde god ga ima.
Ovako da bidne:
[ATTACH]2016.IPB[/ATTACH]
:slight_smile:

To sto ^ instaliras, su gtk2 i gtk3 verzije Oxygen teme za KDE. KDE koristi QT kao framework i widget toolkit, dok XFCE, LXDE, Gnome, Cinnamon, Openbox itd koriste GTK ( Gimp toolkit ).
Najprostije receno oba ( qt i gtk ), sluze za “crtanje” grafickog interfejsa na ekranu ( dugmad, tekst, scrollbars, boje… ).
Pa na primeru screenshot-a koji si postavio vidimo da ti fali Oxygen-gtk tema, zato sto je ceo KDE radjen u QT-u i po default-u koristi Oxygen temu, dok je Firefox GTK, pa se ocigledno razlikuju ( uporedi FF sa Dolphin-om recimo ). Tj. potrebne su ti Oxygen-gtk2/3 teme da bi ceo sistem izgledao uniformno, tj. i qt i gtk aplikacije. :slight_smile:

Primer, posmatras Xfburn aplikaciju:
Levo je “Adwaita-Manjaro-Dark” tema, a desno u VBox-u “Bubble” i obe su GTK teme
[ATTACH]2015.IPB[/ATTACH]

A za Anti Aliasing:
System Settings -> Application Appearance -> Fonts
pa pod “Use anti aliasing” selektuj “Enabled”

Znam šta su Qt i GTK. Pa sad, uradio sam to što si rekao, i još malo preko (da bi mi se pojavio taj GTK tab u settings, morao sam da skinem kde-gtk-config paketić), namestio sam temu i sve, a antialiasing za fontove sam još ranije bio namestio. Ipak, fontovi na ovom sajtu, kao ni widget-i na desktopu, nemaju anti-aliasing.

Hmm, 'ajd baci screenshot od:
System Settings -> Application Appearance -> Fonts -> Configure
:slight_smile:

EDIT:
Koji font koristis? :slight_smile:

http://dc581.2shared.com/download/2dY21aQm/snapshot2.png?tsid=20131021-221309-553c1704

Nemam pojma koji font koristim, valjda koristim mnoge fontove :smiley:

Pošto svuda piše Sans Serif 9, pretpostavljam onda da koristim Sans Serif 9 ::slight_smile:

Yep, Sans Serif. To bi trebalo da je ok.

Nista, 'ajd probaj da stavis “Hinting style” na “Slight” pa javi da li je bolje :slight_smile:

A-a, ne pomaže, ali ko što vidiš u pozadini, fontovi su mi super na nekim drugim sajtovima, na ovom recimo baguju. Da mi ne fali neki paket koji ovaj sajt koristi? Takođe, nije samo u fontovima problem, ko što rekoh, vidžeti na desktopu isto nemaju anti-aliasing :slight_smile:

Pogledaj u System Settings -> Desktop Effects -> Advanced sta stoji pod “Qt graphics system”? Da li je Raster ili Native. Ako je Raster, prebaci na Native, apply pa javi ima li promene sto se widgeta tice. :slight_smile:

EDIT:

Koju graficku imas, i koji drajver koristis? :slight_smile:

Ma, nešto se, kao, promenilo, ivice vidžeta imaju antialiasing, ali unutrašnjost ne :smiley:
I neki fontovi unutar njih imaju kada se rotiraju, a neki ne. Kada se ne rotiraju, svi imaju.
Na taj Qt graphics system sam već bio naleteo ranije, i meni je delovalo da treba da ga namestim na Native, pa sam to i učinio :smiley:

A koju graficku imas, i koji drajver koristis? :slight_smile:

Radeon HD 6520G, slobodan radeon drajver, .conf izgleda ovako:

Section “Device”
Identifier “Radeon”
Driver “radeon”
Option “SWcursor” “off”
Option “EnablePageFlip” “on”
Option “AccelMethod” “EXA”
Option “RenderAccel” “on”
Option “ColorTiling” “on”
Option “EXAVSync” “off”
Option “EXAPixmaps” “on”
Option “AccelDFS” “on”
EndSection

I to sam sad gledao, ali nisam našao ništa što bi moglo biti problem.

Takođe, kao kernel parametar u grub.cfg, imam radeon.dpm=1

Daj screen iz “Kinfo centra” odavde ( moras dvoklik na OpenGL ):

[ATTACH]2017.IPB[/ATTACH]

http://www.2shared.com/photo/am5rMYWO/snapshot3.html

Ok, sudeci po tome drajver je u upotrebi i ne bi trebalo da bude ovakvih problema. 'ebem mu mater, isprobavao sam KDE na staroj masini sa Radeon 9200SE grafikom, i nikakve probleme nisam imao, ne pada mi napamet sta moze da ga zeza.
Uglavnom posto je drajver ok, “trebalo” bi da je najbolja kombinacija u Desktop Effects/Advanced:
Compositing Type: OpenGL 2
QT graphics system: Raster

No ako ti “Native” bolje izgleda, ostavi ga tako ( nakon malo citanja po netu, izgleda da je krivac Raster sistem ).

Sto se fonta tice, znas da kada u KDE-u promenis AA/Hint/SubPixel order podesavanja, moras Login-Logout, idealno restart kompa, nece da primeni odmah. Si restartovao komp u medjuvremenu? :slight_smile:

Mislim da jesam, al evo sad sam opet restartovao, i ništa.
A dobro, svakako se ponešto popravilo od početka priče. Bar sam namestio gtk temu :smiley:

Veliko hvala na pomoći i trudu :slight_smile:

A jer si probavao Catalyst drajver? :slight_smile:

U medjuvremenu 'ajd bar da nastelujemo font na OSS-u, meni su isto bili problematicni, doduse na HD monitoru ( suvise sitni i lose renderovani na KDE-u ).
Ovako je sad kod mene:
[ATTACH]2018.IPB[/ATTACH]

  • Open Sans font - http://www.fontsquirrel.com/fonts/open-sans - ( Skines/raspakujes/ i instaliras ga kroz “System Settings -> Fonts -> Add” pa podesis u "System Settings -> Application Appearance ->Fonts )
  • U FF-u dodas “NoSquint” addon - https://addons.mozilla.org/en-US/firefox/addon/nosquint/
  • Meni bar, ti ekperimentisi pa pronadji idealno, savrseno izgleda tekst sa 120% zoom-om kroz Nosquint ( ne mesaj sa klasicnim zoom-om Ctrl - +/-, ovaj addon uvecava samo tekst za svaki sajt posebno )
    :slight_smile:

Catalyst jesam probavao, ali je generalno problematičan. Što je kernel noviji, to više problema se pojavljuje sa catalystom. Imam ga na Debian Wheezy sa linux-om 3.2, na 3.10 i novijem nikad nisam uspeo da ga namestim. A i prijatnije se osećam što koristim slobodan drajver :smiley:

U međuvremenu, slobodan drajver napreduje, na ovom 3.11 je super, troši mi više baterije, ali sam namestio da se ne pregreva (sa onim radeon.dpm=1 parametrom).
Čujem, takođe, da linux 3.12 nosi dosta poboljšan radeon drajver. Silno me mrzi da kompajliram linux, ionako će da se pojavi na Arču čim bude stabilan :smiley:

A što ne instaliraš box wm sa strane openbox recimo pa probaj u njemu čisto da vidimo dal je sistemski nešto ili KDE gazi podešavanje. Uglavnom Arch ima iscrpna uputstva, npr:

https://wiki.archlinux.org/index.php/Font_Configuration

Ali proveri ipak prvo u nekom drugom DE, čisto da smo načisto dal je samo do KDE nešto. A i probaj prvo sve na default kako ide, bez kernel parametra i bez xorg.confa.

Nego nema ništa od groundbreakin’ featuresa što se tiče radeona u kernelu 3.12, naspram 3.10 i 3.11 što je bilo - nije svaki dan blagdan :slight_smile: više je uobičajeno bugfix em podrška za nov hardver :slight_smile: .

Nego ispada da je tebi samo Firefox problem, jel ti isto loš font i u drugim browserima? Na onom drugom screenshot iz kinfo ti je kao OK - imaš AA :slight_smile: . Ili je baš nešto do kde render sistema, čim i widgeti kažeš imaju isti prob, a možda je i normalno to ako je samo kad ih vrtiš ne znam :). Probaj ti to sve bez efekata, čisto da budemo načisto dal je do igračke ili do sistema :connie_pumpkinsmile: .

A pošto si Archer i koristiš KDE stvarno drugi put detaljnije opiši problem, da ti ne vadimo svaku reč iz usta pogotovo što već sledeći apdejt na Archu može da ti ponovo svašta upropasti iz very, very, very raznoraznih nenamernih ili namernih razloga :D.

Jel ima neko predstavu kako da podesim anti-aliasing na kde? Sve mi je kockičasto :)U stvari nešto jeste, nešto nije.