"Keyboard Shortcuts" na LXDE - kako ?

Pokušavam da napravim prečicu za

xset dpms force off

na LXDE okruženju, sa kombo tasterima recimo Ctrl+Alt+K. Kako to da uradim bez GUI-a, nisam našao da lxde ima takav gui ?

To je openbox, edituješ ~/.config/openbox/rc.xml

Jel to zbog xscreensavera beše? :).

Jeste zbog xscreensavera, od sada ću da “ručno” gasim monitor po potrebi :slight_smile:

Nego, daj neki Tips, šta i gde da upišem u rc.xml ?

Recimo ovako… pod dodaš ovako nešto:



xset dpms force off

Posle editovanja ili

openbox --restart

Ili log-out & log-in, možda je i tako bolje za lxde :).

Neće, opasan je ovaj openbox, neda se ukrotiti

[ATTACH]614.IPB[/ATTACH]

a evo kako izgleda parče rc.xml

C-g

left
no

xset dpms force off

right
no

gde grešim ?

Piše ti sintaksna greška u liniji 913, ne znam koja ti je ta linija. Ali ne može tako nešto što započne sa mora se zatvoriti sa , pa
na tvom primeru se vidi ta nije zatvoren sa nego je nastupio drugi ovaj što sam ti ja napisao.

Evo sa openbox wikija kako se edituje:

http://openbox.org/wiki/Help:Bindings

a neko napravio i gui, ne znam trenutno dal ima deb peketa za taj obkey

http://code.google.com/p/obkey/

Evo sad isprobavam ovaj obkey, na prvi pogled i nije loše:

http://www.dodaj.rs/t/2h/uQ/22KVISRP/2012-09-29-133737640x480.jpg

Samo što ne radi :connie_cat_in_the_hat: , a to ti je python jednom napišeš kod devetorice od deset sa drugim pythonom ne radi :connie_pumpkinsmile: .

U stvari radi, našao mi je 3 kao Invalid ključa koji su inače radili, promenio sam ih po njegovom i sada šljaka OK.

Kod tebe bi bilo za lubuntu ovako:

http://ubuntuforums.org/showthread.php?t=1883847

Kod mene se čudno ponaša obkey. Naime, pokušavam na dve radne stanice da ga namestim. Na Lubuntu sam uspeo da startujem obkey, ali da napravim neki shortcut nikako. Na PeppermintuOS 3 ne mogu ni da ga startujem, a instalirao sam pythonGtk preko Synaptic -a. Na isti način sam odradio i u Lubuntu, i tamo se startuje. Stim da u oba slučaja obkey prijavljuje grešku za podrazumevani rc.xml. Odnosno na različitim distroima se taj fajl zove drugačije, recimo na Peppermintu je peppermint-rc.xml. E sad, kada budem za Lubuntu mašinom probaću ona uputstva sa ubuntu foruma gore iz posta, verovatno ću naterati nekako da radi. Najbolje bi bilo da je obkey ubačen u svaku LXDE/Openbox ditribuciju kao podrazumevani alat za ubacivanje tastaturnih prečica. Biće da je on jedini GUI za te potrebe. Obkey sam skinuo odavde

https://launchpad.net/~gld1982ltd/+archive/ppa/+build/3687005

Evo šta kaže u PeppermintOS 3 kada hoću da startujem obkey

[email protected] ~ $ obkey
Traceback (most recent call last):
File "/usr/bin/obkey", line 40, in 
ob.load(path)
File "/usr/lib/python2.7/dist-packages/obkey_classes.py", line 1668, in load
self.dom = xml.dom.minidom.parse(path)
File "/usr/lib/python2.7/xml/dom/minidom.py", line 1920, in parse
return expatbuilder.parse(file)
File "/usr/lib/python2.7/xml/dom/expatbuilder.py", line 922, in parse
fp = open(file, 'rb')
IOError: [Errno 2] No such file or directory: '/home/drinx/.config/openbox/rc.xml'

to na Lubuntu ne prikazuje, a instaliran je

[ATTACH]616.IPB[/ATTACH]

OK, da za sada zanemarimo obkey. Našao sam u lubuntu-rc.xml fajlu već postoji prečica za xset dpms force off

sleep 2;xset dpms force off

to je Ctrl+F7 naravno. Ali kada odradim taj shortcut kod mene se ništa ne dogodi, displej ostaje uključen. Jedino kada iz terminala odradim xset dpms force off onda ekran ode u standby.

Verovatno mu smeta taj sleep 2; ukloni to pa probaj, trebalo bi da proradi.

Ili da, pošto u bashu radi sve i svašta :wink: stavi mu ovaj

bash -c "sleep 1; xset dpms force off"

Da, sleep 2; definitivno smeta. Ali nikako da se monitor ugasi. Samo ugasi ekran na sekund, i vrati sliku. Evo izlaz komande xset q

[email protected] ~ $ xset q Keyboard Control: auto repeat: on key click percent: 0 LED mask: 00000002 XKB indicators: 00: Caps Lock: off 01: Num Lock: on 02: Scroll Lock: off 03: Compose: off 04: Kana: off 05: Sleep: off 06: Suspend: off 07: Mute: off 08: Misc: off 09: Mail: off 10: Charging: off 11: Shift Lock: off 12: Group 2: off 13: Mouse Keys: off auto repeat delay: 500 repeat rate: 33 auto repeating keys: 00ffffffdffffbbf fadfffefffedffff 9fffffffffffffff fff7ffffffffffff bell percent: 0 bell pitch: 400 bell duration: 100 Pointer Control: acceleration: 20/10 threshold: 10 Screen Saver: prefer blanking: yes allow exposures: yes timeout: 0 cycle: 0 Colors: default colormap: 0x20 BlackPixel: 0 WhitePixel: 16777215 Font Path: /usr/share/fonts/truetype/msttcorefonts,/usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,built-ins DPMS (Energy Star): Standby: 7200 Suspend: 7200 Off: 14400 DPMS is Enabled Monitor is On[/i] [i]

Monitor i ne treba da se ugasi :connie_cat_in_the_hat: DPMS je power saving mod ili stand by, nije totalno gašenje. za to imaš dugme ::slight_smile: .

DPMS je default u X-u na 10 minuta, ovom komandom ti pališ isto to ali sad odmah ili posle tih 1 ili 2 sekunde.

@dvajedan

Hvala ti što mi reče da imam dugme za gašenje monitora, to nisam znao a 15 godina buljim u razne monitore ::slight_smile:

Nego sa komandom

bash -c "sleep 1; xset dpms force off"

radi, dok sa

xset dpms force off

i neće baš, nije mi jasno kako… ali dobro, linije u rc.xml na kraju su

bash -c “sleep 1; xset dpms force off”

Sada mi sledi proučavanje ovog fajla, da ubacim neke prečice za aplikacije… SMPlayer recimo.

Jesi li ti uspeo da odradiš neku prečicu za aplikaciju. Ako jesi, daj neki primer, citiraj linije iz rc.xml

Izgleda da sleep pomaže tu, verovatno zadržiš malo duže tastere ili stisneš dvaput nekako ::slight_smile: .

Moje su defaultne maltene kao iz Crunchbang distribucije. Možeš da prostudiraš ovaj paket raspakuj pa pogledaj taj rc.xml na putanji skel/.config/openbox/

Naravno dodatno mogu da uradim prečice za bilo koji program što da ne ::slight_smile:

To ti je xml funkcija znači sve između da citiramo ovo sa crunchabanga, izgleda ovako:


C-g


leftno


rightno


upno


downno


leftno


rightno


upno


downno


1


2


3


4















client-menu




xfce4-screenshooter




scrot '%Y-%m-%d--%s_$wx$h_scrot.png' -e 'mv $f ~/images/ & viewnior ~/images/$f'























yesyes










right




left




up




down






true
Run Program

gmrun





true
dmenu-bind

~/.config/dmenu/dmenu-bind.sh





true
thunar

thunar





true
Terminal

terminator





true
Web Browser

x-www-browser





true
Lock screen

cb-lock





true
Editor

geany





true
Mediaplayer

gnome-mplayer





true
htop

terminator --command="htop"





true
Volume

pavucontrol





true
Logout

cb-exit




client-list-combined-menu




root-menu




root-menu

















cb-aerosnap --left




cb-aerosnap --right


Dvajedan prestani da me zasmejavaš molim te :connie_garoo: :wacko2:

Što bih studirao taj fajl iz Crunchbang -a ? Šta tu ima da se vidi ?

Što šta je smešno :connie_pumpkinsmile: , ako ukucaš naredbu prvu koju si dao u terminal, ali stisneš dvaput brzo enter dogodiće ti se upravo to što si opisao ovde. :connie_cat_in_the_hat: A ako dodaš sleep ispred i uradiš to isto neće se dogoditi - čekaće na inpute ;).

Najbolji keybind config za openbox za koji znam :playboy:

Izvini ali, aman zaman, koju naredbu ? :slight_smile:

Kako koju, pa ovu prvu ::slight_smile: :

http://forum.mint-srbija.com/topic/1103-keyboard-shortcuts-na-lxde-kako/#entry16111

Probao sam sad u terminalu

xset dpms force off

i držim Enter, kada gle čuda monitor ode u stand by. Ali čim sam pustio Enter, čarolija je nestala :slight_smile:

Pa eto, možda i jeste smešno ali je to tako :connie_pumpkinsmile: . sleep komanda upravo služi za to da pošalje komandu na odloženo, taman dok pustiš enter ili prečicu.

Ma ovaj obkey je gubljenje vremena i nerviranje. Više neće da se startruje ni gde se startovao ranije. Beskoristan. Izgleda da mora sve da se radi peške editovanjem rc.xml. Nikako da uhvatim vremena da radim prečice za aplikacije.

Celo prepodne danas se zajebavam sa ovim LXDE-om.

Ne mogu da potrefim unikod koji je za srpsku latinicu na Debianu za tastaturu!? Podeseno mi je na US a ja sam dodao i RS ali to baca samo cirilicu a meni treba latinica obzirom da cirilicu koristim mozda 0,5% sve ukupno na sistemu.

Dakle kako da dodam i latinicu u sistem, koji je unicode!?