Matična ploča za Linux

Posle 4 dana agonije i trabl shutinga, mislim da je vreme da podelim iskustvo ovde sa vama, dragi ljudi :slight_smile: i da pitam za prof. savete.

Naime, kupio sam maticnu plocu, GA-970A-DS3P rev. 2.2. Stara je bila isto GA koja i dan danas fercera, ali zbog SATA3 porta, USB 3.0, itd. morala je da dodje nova.

I tako posle instalacije hardware, dosao na red i OS, naravno.
Posto sam hteo dual boot Win i Linux, instalirah prvo Win7, jerbome, da bi GRUB posle presao preko boot manager i prepoznao oba OS-a. ( mhm, vazi, aha…)
Win install prodje bez ikakvih problema.

Stavim USB na kojem imam nekoliko distribucija, pravljen preko Multisystem-a. Izaberem LM 18…pocne da ucitava, greska: usb 5-3 (5-4, 8-3, kako kad): device descriptor read/64, error -32
Probam jos par puta sa par drugih distro, isti problem.
Malo guglanja, kaze USB crpi vise struje nego sto bi trebalo i kontroler zaustavi sa pomenutom greskom.
hmmmm…napredne li tehnologije a stara maticna, preko 5 godina, fercera bez problema.

Elem, malo guglanja, vise lupanja glavom, dodjemo do toga da pomenua moja nova maticna nije bas kompitabilna sa 64bit kernelom unix-a. Navodno, 32bit radi, ali nisam testirao.
Manifestacije, tj. nus-pojave: USB portovi ne rade i mrezna kartica takodje ne radi.

Enable-ovanjem IOMMU opcije u BIOS-u uspeo sam da podignem live image i da instaliram LM 17.3.
Medjutim, to treba da se disable jer zna da Win zasteka. A ako disable, nece Linux da radi. Workaround je da se u grub upise iommu=soft pod nekom LINUX linijom, ne secam se tacno, da se iskljuci u BIOSU i da se rebutuje i navodno radi.
Odradio tako, reboot…nit da butuje Linux, nit Windows, o dual boot-a ni traga, LM nije prepoznao Win da je instaliran na drugom HDD-u.

Dakle, o pametni i iskusni ljudi FOSS-a, koju maticnu preporucujete, da je novije generacije, naravno da ima SATA3 portove, min. 2x USB 3.0, da je AM3/AM3+ podnozje.

Veliko hvala.

Ili mozda ajd da probamo ovako:
samo napisite svoje maticne ploce a da imaju AM3/AM3+ podnozje, SATA3 i USB 3.0

Moja mb…iako malkice matorija, radi bez greške:
ASUS Global

Hvala. :slight_smile:

Predpostavljam da R 2.0 bi isto tako dobro radila?

Sto je najgore, cekao sam da mi jave za tu plocu 3 dana, i kako nema vesti, ja uzmem GA i one mi dan posle jave da su nasli… :frowning:

Ne znam za R2…neko ih hvali, neko ih kudi, valjda kako se kome zalomi.
Moja je R1 i kod mene radi kako treba, pa samo o njoj mogu da sudim :slight_smile:

GA-890XA-UD3 (rev. 2.0)

GIGABYTE - Motherboard - Socket AM3 - GA-890XA-UD3 (rev. 2.0)

Ovo je malo matorije, ali radi ko satić isto imam phenom II.

Support for DDR3 1866(OC)(Note 2)/1333/1066 MHz memory modules

Mora overclock da bi prihvatio RAM. Kod ASUS-a ^ po defaultu prihvata.

@Dragan
Samo potvrde radi, OVA je. Malo je teze nabaviti…

Nisam siguran da li sam razumeo…jel ovo pitanje, ili konstatacija?
Ako tražiš od mene preporuku, nemaš je…ja ne praktikujem da preporučujem hardver bilo kome zato što može da se desi da ono što kod mene radi savršeno, nekome drugome apsolutno ne bi odgovaralo, iz ko zna kakvih razloga.
Posle ispadne…“Dragan me zeznuo, on mi je preporučio…” :slight_smile:
Pitao si ko šta koristi, ja preneo šta ja koristim i moje iskustvo i to je sve … :slight_smile:

Ma jok, samo da potvrdim o kojem modelu ploce tacno je rec, nista vise. :slight_smile:
Sve je kul, dobio sam odgovor, ko sta koristi i to mi je super putanja :wink:

GA-970A-DS3P rev. 1.0 :slight_smile:

:pensive: Dzaba kad je samo ova imala da se uzme…ali ko bi znao vise te revizije da li valjaju ili ne, tj sta i koji problem gde prouzrokuje.

Problem je taj iommu controler i usb3.0. Ovde sam opisao ‘‘ritual’’ za ovu ploču.
LinuxMint - cudno ponasanje Giane | FOSS | Free and Opensource Serbia

Da, da nasao sam i ja taj tutorial na blogu i odradio tako.
Interesantno da je malo radilo i malo nije radilo…ali sada radi…
Valjda ce Gigabyte da odradi neki BIOS update (nadajmo se) pa da se resi i taj problemcic.

Ne verujem, mislim da je gigabyte završio sa update-ovima za ove ploče.

E pa ovako…
instalirao SolydX i GRUB na /dev/sdb2 particiju, koja je boot, esp. Nudi mi Windows, ali kada izaberem, vidim gresku

Error, invalid signature.

Zatim sam dodao ovo u /etc/grub.d/40_custom

menuentry “Windows 7” {
search --fs-uuid --no-floppy --set=root 1E7A-7770
chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi
}

UUID od /dev/sdb2 je 1E7A-7770

zatim dobijem gresku:

Error: no such device: 1E7A-7770
Error : file ‘/EFI/Microsoft/Boot/bootmgfw.efi’ not found

Neznam vise sta da radim.
Probao sam boot repair, automatic repair option…nista.

Ima li resenja ovom ludilu sa UEFI???

Da nisi slučajno formatirao ESP pri instalaciji solydx?

Ovo je malo nejasno…nisi valjda instalirao SolydX na boot particiju?

Ne, nisam, nisam je formatirao, samo sam je oznacio kao particiju gde da se instalira GRUB.

Ne :slight_smile: Instalirao sam na skroz drugi HDD. Na boot particiju sam samo chekirao da instalira GRUB.

Sve u svemu, namestio sam BIOS na legacy, format hdd na kojem je Windows, konvertovao u MBR i instalirao Win na tom hdd-u, zatim GRUB update na Linux.

Da ne otvaram novu temu, al ajd da kazem da je manje vise povezano sa ovim :slight_smile:
USB 3.0 radi, prepoznaje externe hardove ali…brzina citanja/pisanja ne prelazi preko 50Mb/s.
Na windowsu cita 100Mbs a pise 70-80Mb/s.

Neka sugestija, predlog, sta moze biti?