Mint Regionalna podešavanja

Da li je kod linuksa moguće podesiti regionalno podešavanje kao kod windowsa

instalirao sam u Virtualbox : i linuxmint-debian-201012-gnome-dvd-amd64.iso

localization:
Language: [email protected]
Timezone: Europe/Sarajevo
Keyboard layout: Bosnia and Herzegovina
Keyboard model: Generic 105-key (Intl) PC

kako mogu da promijenim da mi pise januar, februar, … ponedeljak, utorak
a da nemijenjam u cirilicu menije već da je na Engleskom,
kao npr. File, Copy, …

To nije moguce bez menjanja lokalizacije. Dakle ne možeš da promeniš samo ono što tebi odgovara, tačnije možeš ali onda moraš sam da napišeš prevod za delove koji tebi odgovaraju.

Auto-generisana poruka

Ova tema je premeštena iz “Upravni deo[/url] → [url=“http://www.mint-srbija.com/forum/index.php?/forum/11-predlozi-pitanja-i-primedbe/”]Predlozi, pitanja i primedbe[/url]" u "[url=“http://www.mint-srbija.com/forum/index.php?/forum/2-linux-mint-glavna-podrska/”]Linux Mint - glavna podrška[/url] → [url=“http://www.mint-srbija.com/forum/index.php?/forum/13-instalacija-boot-grub/”]Instalacija, boot, grub…”.

LMS tim!

[font=arial][size=3]Hvala Vladimire za odgovor.[/size][/font]

[font=arial][size=3]Ja sam programer, programe pišem u Delphiju a za bazu podataka[/size][/font]
[font=arial][size=3]koristim Firebird.[/size][/font]

[font=arial][size=3]Pored pisanja i instalacije programa nudim usluge i održavanja programa.[/size][/font]

[font=arial][size=3]Cilj mi je da sa Windowsa selim svoje aplikacije na linux, što se tiče[/size][/font]
[font=arial][size=3]servera već sam izvršio par instalacija i to je korektno.[/size][/font]

[font=arial][size=3]Za prelaz aplikacije za sada bi koristio wine i to mije u većini[/size][/font]
[font=arial][size=3]uspjelo da podesim, ali mi problem predstavlja raznolikost naziva[/size][/font]
[font=arial][size=3]fajl, datoteka alati za kopiranje meniji i ostalo.[/size][/font]

[font=arial][size=3]Korisnici prave problem kada mi se ti prevodi pojave u ćirilici pa su[/size][/font]
[font=arial][size=3]čak i spremni da prihvate i Hrvatsku varijantu. Pri Hrvatskoj[/size][/font]
[font=arial][size=3]varijanti problem je kada se pojavi siječanj, veljača … pa prevodi menija …[/size][/font]

[font=arial][size=3]Često puta pri pozivu telefonom pomažem po sjećanju po nazivu ali sada[/size][/font]
[font=arial][size=3]ta šarolikost mi usložnjava posao.[/size][/font]

[font=arial][size=3]Najviše bi odgavarala varijanta kada bi instalacija ostala na[/size][/font]
[font=arial][size=3]Engleskom jeziku a da podesim sistem da piše latinična i ćirilična[/size][/font]
[font=arial][size=3]slova, da mjesece piše korektno i da dane u sedmici piše korektno.[/size][/font]
[font=arial][size=3](kao što se to može podesiti u Windowsu)[/size][/font]

[font=arial][size=3]Zahvalan bi bio da me uputite na lokacije koje bi pomogle da to podesim[/size][/font]

[font=arial][size=3]S poštovanjem,[/size][/font]

[font=arial][size=3]Željko Cvijanović[/size][/font]
[font=arial][size=3]Teslić[/size][/font]

Kad može wintendo, što ne bi mogao i Mint :slight_smile:

Uputstvo je za Mint14 Nadia, ali i u drugim linuxima su slična podešavanja…

Dakle, ideš u
System Tools/ System settings/ Language support

instaliraj srpski jezik, za “Language for menus and windows” ostaviš engleski, u tabu “Regional formats” postaviš srpski za prikaz brojeva, datuma i novca, i potvrdiš na “apply system-wide” (za ovo poslednje će ti ponovo tražiti lozinku, kao i na početku za instalaciju srpskog jezika)

Nakon svega, potrebno je da uradiš log-out (ili restart), da bi promene bile prihvaćene u celom sistemu, i to bi otprilike bilo sve…no, slike bolje govore od mene :slight_smile:

Usput, dobrodošao na forum, i nadam se da će ti biti prijatno sa nama :slight_smile:

[ATTACH]1017.IPB[/ATTACH]
[ATTACH]1018.IPB[/ATTACH]
[ATTACH]1019.IPB[/ATTACH]

Ja sam pogrešno razumeo da on hože da promeni i Copy, File… tek sad sam nanovo pročitao :frowning:

Ovo da, ali ovo važi samo za datum, monetarni deo kao i vreme, sve ostalo je na engleskom.

Čoveku upravo to i treba…ako sam dobro shvatio :slight_smile:

Hvala za brze odogovore,
sada ću to da probam, prvo da pokupim istu verziju imao sam debian mint,
to mi treba i još da vine radi korektno sa našim slovima

to nisam uspio dok ne instaliram ćirilicu ili Hrvatsku jezičku podršku

LMDE koji si ti skinuo je u fazi čekanja, čeka neko kvalitetnije i bolje vreme. Predlog da skineš ili Linux Mint KDE ili Linux Mint Cinnamon.

Bilo koji od ta dva da skineš nakon instalacije odradi:

sudo apt-get install msttcorefonts

… i ne bi trebao da imaš probleme sa našim slovima u Wine-u.

Instalirao sam u VirtualBox

  • linuxmint-14.1-cinnamon-dvd-64bit.iso
  • wine 1.4
    -[size=3] sudo apt-get install msttcorefonts[/size]
    [size=3]- chromium-browser[/size]
  • podesio sam da piše januar, četvrtak …
    (srpski -b ‘latin’)

kada pokrenem notepad
š,ž, Đ prikazuje korektno
č,ć,Č,Ć piše c C
đ piše d

tu je problem sa sistemskim fontom, kada promijenim u notepad
font tahoma radi korektno
ali mi je problem to mijenjati u svojim aplikacijam

@[member=‘zeljkoc’] Problem je u enkodingu. :slight_smile: Moraš da podesiš UTF-8. Verovatno je u tome problem, probaj pa da vidimo :slight_smile:

Ček, u tvojim aplikacijama se ne vidi? Koji font koristiš u njima?

@[member=‘Dragan’] Uradim po tvom uputstvu. Znači idem na Install/Remove Languages, tamo čekiram srpski jezik, pa apply. Onda on nešto skida i instalira. I kada završi ništa. Kao da nisam ništa instalirao. Ne pojavljuje se srpski u spisku. A štrikliran je kao da je instaliran. Ima li leka?

@[member=‘VlaK’] Log out/restart možda? Jesi ga odradio?

Aplikacije koriste MS Sans Serif i dobro bi se namučio kada bi to popravljao
kako mogu da podesim u wineu da to bude systemski font mogu da podesmi valutu, način prikazivanja datuma
brojeva … izmjenom u Registry ali nisam nasao za izmjenu fonta.

kada instaliram Hrvatski ili Srpsku ćiliricu to korektno radi ali su mi problemi sa pevodom

Ma sve sam uradio. To sam ja instalirao odma po instaliranju sistema. I lepo mi stoji da je sprski instaliran, ali se ne pojavljuje u spisku. Sada sam probao malo pa sam instalirao hrvatski, i isto instalira, ali ga nema. Kada uklonim jezik (srpski ili hrvatski), lepo se deintaliraju.

@[member=‘VlaK’] Podesi jezik u podešavanjima korisnika, odnosno podesi jezik za tebe kao korisnika. Verovatno je u tome problem, postavio si jezik za korisnika pa ti zabranjuje da koristiš ostale…

@VlaK

Kako nema?

Tu je srpski, samo moraš da skroluješ malo :slight_smile:

[ATTACH]1022.IPB[/ATTACH]

@[member=‘Dragan’] Pa da, ali video sam da je pre bilo da ne može da se bira jezik, samo onaj koji je definisan za korisnika… nema veze, nek proba, nije na odmet :wink:

Evo kako kod mene izgleda. Imam samo engleski, a vidi se da je srpski instaliran.

Pa to je samo da ima podrsku za Serbian
iznad pre nego sto stisnes install language pa dobijes ovu svoju sliku
imas spisak raspolozivis jezika
odaberi serbian i stisni applay System wide i resetuj ili logout

Nemam ja tu nikakav spisak. Samo stoji English. Vidi se na slici, ovaj prozor desno. Tu treba da se pojavi i srpski ili bilo koji drugi koji instaliram, ali se eto ne pojavljuje.