No swap selected during installer

Hi guys,

I’m doing a fresh install of trios today, and hit a bit of a snag.

I’ve created what I would consider a fairly standard partition layout (but hey, I’m probably strange :), which is as follows:

/dev/sda
-> /dev/sda1 - ext4 - /boot
-> /dev/sda2 - physical volume - encrypted - LVM
-> /dev/vg00/vol_root - ext4 - /
-> /dev/vg00/vol_swap - swap - swap
-> /dev/vg00/vol_home - ext4 - /home

Once I’ve created all of that, I click next in linstaller, and I get the following warning:

“No swap selected (press Forward to continue without one).”

I’ve attached a screenshot showing the partition layout and the warning.

Also, here are the relevant package versions from the installer environment:

linstaller - 7.0.6~mia3
linstaller-config-trios - 7.0.6~mia3
linstaller-frontend-cli - 7.0.6~mia3
linstaller-frontend-glade - 7.0.6~mia3
linstaller-modules-base - 7.0.6~mia3
linstaller-session - 7.0.6~mia3
live-config-linstaller - 7.0.6~mia3
libllvm3.5:amd64 - 1:3.5-10
libllvm3.5:i386 - 1:3.5-10
liblvm2cmd2.02:amd64 - 2.02.111-2.2
lvm2 - 2.02.111-2.2
linux-image-3.16.0-4-amd64 - 3.16.7-ckt20-1+deb8u3

Let me know if you want/need any more info, or want me to test anything.

Cheers,

Hmm, just tried to continue with the install, and had major failure.

Screenshot of major failure and install log attached.

Hmm, suspect major failure is due to the previous ext4 issues we found, so Ill try again by just updating the installer packages, and not the kernel :slight_smile:

So, I believe the ext4 + mounting issue is the same issue I hit here:

Issue with ext4 during installer | FOSS | Free and Opensource Serbia

Only, if I try and upgrade just the linstaller packages, it pulls in a new kernel as well, as linstaller-modules-base has a heap of dependencies, which eventually equal the new kernel being pulled down as well, which in turn causes the ext4 issues mentioned above:

apt-cache depends linstaller-modules-base

linstaller-modules-base
Depends: debconf
Depends: keeptalking
Depends: bricks
Depends: python-keeptalking
Depends: python-libbricks
Depends: python-t9n
Depends: python-parted
Depends: python-apt
Depends: squashfs-tools
Depends: user-setup
Depends: imvirt
Depends: lvm2
lvm2:i386
Depends: cryptsetup
Depends: util-linux
util-linux:i386
Depends: ntfs-3g
Depends: fatresize
Depends: dosfstools
Depends: hfsprogs
Depends: reiser4progs
Depends: e2fsprogs
e2fsprogs:i386
Depends: parted

I know I got around this last time when Filip and I were talking about it, but I cant for the life of me remember what we ended up doing…

Anywho, Ill keep digging around, and let you know if I find anything.

I might also download RC2 and see if its still an issue in that :slight_smile:

Cheers,

@swap:

You didn’t set a mount point. :wink: Thus it won’t be written in /etc/fstab, which in effect, is the same as not having a swap partition at all. :slight_smile:

Also, just for the information, not having a swap won’t prevent the installation from continuing! You just neeed to press “Forward” button twice.

Untitled.png

@ext4
Yep, same issue as the last time.
ext4 module from the new kernel being loaded on the older ( running ) one.

You didn’t mention which ISO you were using ( I guess it’s RC1 )…?
Anyway, installer shouldn’t pull a new kernel.
Tested on RC1:

[[email protected]][~]$ sudo apt-get install linstaller linstaller-config-trios linstaller-frontend-cli linstaller-frontend-glade linstaller-modules-base linstaller-session live-config-linstaller
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
cgmanager libcgmanager0 libnih-dbus1 libnih1
Use ‘apt-get autoremove’ to remove them.
The following packages will be upgraded:
linstaller linstaller-config-trios linstaller-frontend-cli
linstaller-frontend-glade linstaller-modules-base linstaller-session
live-config-linstaller

7 upgraded, 0 newly installed, 0 to remove and 536 not upgraded.
Need to get 401 kB of archives.

[snip]

[[email protected]][~]$ apt-cache policy linstaller linux-image-3.16.0-4-amd64
linstaller:
Installed: 7.0.6~mia3
Candidate: 7.0.6~mia3
Version table:
*** 7.0.6~mia3 0
1001 Index of /trios/mia/ mia/main amd64 Packages
100 /var/lib/dpkg/status
linux-image-3.16.0-4-amd64:
Installed: 3.16.7-ckt2-1
Candidate: 3.16.7-ckt20-1+deb8u3

Version table:
3.16.7-ckt20-1+deb8u3 0
500 Debian – Security Information jessie/updates/main amd64 Packages
3.16.7-ckt20-1+deb8u2 0
500 Index of /debian jessie/main amd64 Packages
*** 3.16.7-ckt2-1 0
100 /var/lib/dpkg/status

[[email protected]][~]$ uname -a
Linux debian 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt2-1 (2014-12-08) x86_64 GNU/Linux
[[email protected]][~]$

So, please, update the installer by using the command I’ve listed here and there shoudn’t be any problems. :slight_smile:
Otherwise if you spot that a new kernel is going to be installed, stop there and post the used apt command and it’s output here, so that we can find out why is it happening. :slight_smile:

@ no mount point:
Yup, thats correct, I didn’t set a mount point, as its a swap volume…

Ended up hitting forward twice, and as I said, that worked, but then I hit the ext4 error again.

@iso:
I’m using the RC1 iso, as bandwidth is not great here. Once I’ve booted off the RC1 iso, I’m updating the apt keys/repos etc and performing the install

@updating linstaller:
Ok, I can see what’s going on here now. Sorry for wasting your time. Didn’t realise that apt-get upgrade grabbed all available updates, not just those specified, unlike apt-get install… Guess I needed to RTFM a little better.

Cheers,

Hi Adam,
RC1 iso is too old.
You can get a new one for test:
Index of /trios/iso-images/

No problem. :slight_smile:
All that matters is that you now know where the problem is, and that there is nothing for us to fix… Win on both sides. :slight_smile: