Problem sa Viberom

Malopre sam preuzeo instalacioni .deb fajl i pokusao da instaliram najnoviju verziju Vibera za Linux Desktop ali mi izbacuje poruku koja je data na slici u prilogu. Cekirao sam “Allow executing file as program”, ali ne vredi.

Premesti ga u drugu fasciklu pa probaj, nešto sa dozvolama nije uredu.

Probao, ali nista. Sa dozvolama je sve u redu, druge instalacije ovog tipa rade. Pre ce biti da je problem do samog instalacionog fajla.

Tako je, .deb je arhiva, a ne izvršni fajl, nije trebalo da mu menjaš dozvole.
Otvori terminal u folderu u kojem se nalazi fajl, pa otkucaj:

sudo gdebi viber.deb

Ja sam kada sam skinuo fajl odmah pokrenuo instalaciju, znaci ne menjajuci dozvole i dobio isti rezultat. Ponovo sam vratio kako je bilo ali ni iz terminala ne radi.

Ok, daj link odakle si skinuo deb da proverim…
Inače, ispravne dozvole za deb paket možeš i sam da izmeniš iz terminala:

chmod 0644 viber.deb

skinuo sam paket odavde, oštećen je…
Linux | Viber

Probaj http://download.cdn.viber.com/cdn/desktop/Linux/viber.deb

odavde skida paket preko AUR-a, kod mene je instaliralo bez problema.

Iz nekog meni nepoznatog razloga gdebi odbija da instalira viber.deb i tretira ga kao oštećenog.
U root terminalu instalacija sa

dpkg -i viber.deb

prolazi bez problema…
Screenshot - 11302017 - 02:27:36 PM.png

Uspeo sam na ovaj nacin da instaliram novi Viber, pise da je verzija 7 ali nece da se pokrene. Vratio sam na 6.5.5, valjda ce u nekoj narednoj verziji ispraviti greske.

Ево баш малопре сам имао проблем са Вајбером али решио сам, можда некоме буде од помоћи. ГУИ инсталација неће а неће ни преко Терминала док се не инсталира један пакет од кога Вајбер зависи. У Терминалу ми је написало о ком пакету се ради и ја га инсталирао и после тога командом sudo dpkg -i viber.deb иснталирао Вајбер и то је то. Једини је проблем што се не могу сетити име пакета (нешто libcoril3 или тако нешто)
ПС: Није да сам вам нешто помогао али дао сам неке смернице :slight_smile: Иначе, користим Линукс Минт Цимет

Стрелицом на горе, у Терминалу можеш видети шта си претходно уносио.

Razlika između gdebi instalera i baznog dpkg je u tome što gdebi proverava zavisnosti i automatski ih povlači, a dpkg ne.
Probaću da prepakujem taj šugavi viber.deb…

Ako je terminal zatvorio u međuvremenu, strelice tu ne pomažu više :slight_smile:
Medicina je da se otvori terminal i komanda history preusmeri u neki fajl…npr history.txt

history >history.txt

Nakon toga može da se pregleda istorijat otkucanog i bez otvorenog terminala u bilo kom text editoru.

@Supergull
Privremeno rešenje…
Ovo su viber zavisnosti, probaj da ih prethodno instaliraš:

sudo apt install libxss1, libssl1.0.0 libpulse0 libasound2 libnss3 libxcomposite1 libxcursor1 libxdamage1 libcurl3 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-libav

…poste toga ponovo instaliraj viber sa

sudo dpkg -i viber.deb

trebalo bi da se pokreće normalno

Hvala, ali pre ne bih, da nesto ne pokvarim. Ne znam sta moze da bude, ja sam jos na Mint-u 17.3 koji je podrzan do aprila 2019. I verzija Vibera 6 jos radi, sacekacu do sledeceg azuriranja pa cu videti. Hvala svima jos jednom.

Probao sam da instaliram na Mint 18 MATE, i izasla mi je poruka sledece sadrzine (u prilogu).

Zaista je neshvatljivo koliko su programeri…ili oni koji kompajliraju/održavaju pakete…u kompaniji Viber aljkavi i koliko ih u krajnjoj liniji boli uvo za linux.
Ovde je ispravljen deb paket:
Index of /data
Isprobajte pa javite da li je ok…kod mene se instalira i pokreće normalno, a da li radi kako treba ne znam, jer ne koristim viber uopšte.
Lintian i dalje pljuje gomilu grešaka, ali mislim da je od mene dosta…nisam baš previše voljan da detaljno ispravljam tuđe…čitaj: Viber…brljotine
Screenshot - 11302017 - 10:52:26 PM.png

Знам за то али, као што је @Dragan рекао, гасио сам Терминал након тога…

Kод мене (по default-у) постоји историја и после гашења терминала… :eyes:

~/.bash_history