[REŠENO] Dupli direktorijumi nakon montitanja particija

Ja sam rešila taj problem sa swap, imam ga, uzima neki minimalni prostor, home opet ima svoj prostor i root svoj. Drugi hard mi je bio podeljen u 3 NTFS particije koje sam prebacila u ext4 i onda je nastao problem oko mount-a. Našla sam neke tutorijale o tome kako mountovati HDD ali sada imam duple direktorijume (nisam nešto sigurna da to tako treba, ali radi).

Screenshot_at_2012_01_30_13_22_08.jpg

Svaki savet dobrodošao.

Update:
@ Vladimir
Promenjena slika.
@ gnome

Na žalost to nisam radila sama, iskreno nisam zanala, tako da je ostalo tako kako je. Ovaj tutorijal je odličan i verujem da bih se sa njim snašla i sama isto da odradim. U mom konkretnom slučaju particionisanje je prošlo u redu što se tiče prelaska sa NTFS na ext4, podatke sam prebacila na externi hard i kasnije ih samo vratila. Jedini problem je nastao kada je trebalo iste mountovati. Slika pokazuje kako to sada izgleda i pitanje je da li to baš tako treba?

@ ivanblago

 Ako smatrate da je potrebno otvoriću novu temu a i admin može moj post prebaciti tamo.

Ufff… ajde za početak ispravi link slike, tačnije slika je mala pa se ništa ne vidi.

@Blue,

Najbolje je da pokrenete novu temu sa vašim “problemom”. Ova tema je više konkretno uputstvo za početnike. Novom temom bi imali bolji pregled foruma i tima lakšu buduću pretragu. .

za mountovanje hard diskova, pogledaj uputstvo na pocetku ove teme, jako je dobar tutorijal… da se sad ne ponavljam i pisem isto to…

Kad se jednom odradi automount vise nikad ne mora da se to radi…

Našla sam neke tutorijale o tome kako mountovati HDD ali sada imam duple direktorijume (nisam nešto sigurna da to tako treba, ali radi).

Da li je u pitanju montiranje eksternog ili internog HDD?

E ovako…

Jednom sam imao sličnu situaciju kao tvoju, doduše nije mi mountovao duple particije, ali je umesto da sistem vidi HDD kao HDD on ga vidi kao običan direktorijum, što po slici vidim da je i kod tebe problem.

Donji fajlovi tj particije su ti prikazane kao direktorijumi a ne kao particije na disku.

Probaj da uradiš sledeće: un-mountuješ ih sve particije (osim sistemske linux-a naravno), zatim resetuješ sistem i pogledaš da se nisu slučajno auto-mountovale, ako nisu i ako sada nemaš ni jednu particiju vidljivu osim sistemske, pokreni Synaptic i potraži program pod imenom “ntfs-configurator” instaliraj ga pokreni ga kao root i u njemu čekiraj diskove koje želiš da mountuješ i stvar će biti rešena.

Мени личи да имаш двоструке уписе у /fstab-u, stari kad si imala NTFS i novi sa EXT4.
уради iz терминала и постави на форум:

cat /etc/fstab

Koristim GNU LInux Mint 12 MATE

Koraci koje sam uradila pre nego su se pojavili dupli direktorijumi:

Programom gpart sam obrisala stare NTFS particije i napravila 3 nove ext4 particije. Me]utim te particije se nisu mountovale pa sam uz pomoć kolege u /media/ sam napravila 3 istoimena foldera koji se sad pojavljuju kao dupli direktorijumi (na slici gore to su oni malim slovima). Posle toga mi se partice normalno mountuju, samo kada otvorim home ili bilo koji drugi direktorijum imam duple direktorijume za te 3 particije. Nadam se da sam uspela da objasnim, u nastavku je cat/etc/fstab…

[code][email protected] ~ $ cat /etc/fstab

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

proc /proc proc nodev,noexec,nosuid 0 0

/ was on /dev/sdb1 during installation

UUID=8589029f-02f0-4149-b2db-eede27a7c0b0 / ext4 errors=remount-ro 0 1

/home was on /dev/sdb5 during installation

UUID=23f622f2-9900-4b20-8aae-5c23bf54b393 /home ext4 defaults,user_xattr 0 2
/dev/sdb6 none swap sw 0 0
#/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

#Iva
LABEL=School /media/school ext4 defaults,rw,user,exec,auto 0 0
LABEL=Moj /media/moj ext4 defaults,rw,user,exec,auto 0 0
LABEL=Fun /media/fun ext4 defaults,rw,user,exec,auto 0 0
[/code]

Imam 2 HDD, jedan je samo za sistem, na njemu su / home i swap, drugi je taj koji je problem sda1, sda2 i sda3, zato u fajlu gore piše LABEL= … one su bile NTFS.

[code][email protected] ~ $ sudo fdisk -l
[sudo] password for iva:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x03d303d3

Device Boot Start End Blocks Id System
/dev/sda1 2048 104859647 52428800 83 Linux
/dev/sda2 104859648 208713727 51927040 83 Linux
/dev/sda3 208713728 312580095 51933184 83 Linux

Disk /dev/sdb: 80.0 GB, 80025280000 bytes
255 heads, 63 sectors/track, 9729 cylinders, total 156299375 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0005e52d

Device Boot Start End Blocks Id System
/dev/sdb1 * 2048 39999487 19998720 83 Linux
/dev/sdb2 40001534 156297215 58147841 5 Extended
/dev/sdb5 40001536 148297727 54148096 83 Linux
/dev/sdb6 148299776 156297215 3998720 82 Linux swap / Solaris

[/code]

'ajde, u /etc/fstab dokumentu izbrišite poslednja 4 reda i sačuvajte izmene, pa onda

sudo mount -a

pa restartujte računar i kažite kakvo je stanje onda… Ne bi trebalo da se pojavljuju uopšte (mislim na te particije). Pa ćemo onda da odradimo ponovno montiranje…

[code][email protected] ~ $ cat /etc/fstab

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

proc /proc proc nodev,noexec,nosuid 0 0

/ was on /dev/sdb1 during installation

UUID=8589029f-02f0-4149-b2db-eede27a7c0b0 / ext4 errors=remount-ro 0 1

/home was on /dev/sdb5 during installation

UUID=23f622f2-9900-4b20-8aae-5c23bf54b393 /home ext4 defaults,user_xattr 0 2
/dev/sdb6 none swap sw 0 0
#/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

[/code]

U home folderu je situacija sledeća:
Screenshot_at_2012_01_30_22_25_07.jpg

Želela sam da mi se te particije/direktorijumi po bootu sistema automatski mountuju na desktop. U ovom slučaju ih nema dokle god neku od njih ne kliknem i naravno po restartu se gube.

OK, tako i treba… Sad, nemojte da ih pokrećete (montirate) nakon startovanja sistema. Nego odradite prvo montiranje na ovaj način - http://forum.mint-srbija.com/korisni-saveti/automontiranje-particija/

Мислим да је могло другачије и једноставније. Disk-manager програм. Не би се усудио да предложим нешто, мислим да треба неко искуснији.

Mislim da je uputstvo Kmamuza izuzetno! Za rešavanje ovakvih problema i ja bih radije radio preko terminala.
Taj program ne poznajem a terminal je majka Mara.

[code][email protected] ~ $ sudo mount -a
mount: wrong fs type, bad option, bad superblock on /dev/sda2,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

mount: special device /dev/sda3 does not exist
[/code]

[code][email protected] ~ $ cat /etc/fstab

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

proc /proc proc nodev,noexec,nosuid 0 0

/ was on /dev/sdb1 during installation

UUID=8589029f-02f0-4149-b2db-eede27a7c0b0 / ext4 errors=remount-ro 0 1

/home was on /dev/sdb5 during installation

UUID=23f622f2-9900-4b20-8aae-5c23bf54b393 /home ext4 defaults,user_xattr 0 2
/dev/sdb6 none swap sw 0 0
#/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

#Iva
/dev/sda1 /media/sda1 ext4 defaults 0 0
/dev/sda2 /media/sda2 ext4 defaults 0 0
/dev/sda3 /media/sda3 ext4 defaults 0 0
[/code]

Pa ništa, dajte ispis od:

dmesg | tail

@Kmamuz da li mozda moze ovako

/dev/sda1 /media/school ext4 defaults 0 0 /dev/sda2 /media/moj ext4 defaults 0 0 /dev/sda3 /media/fun ext4 defaults 0 0

ili ovako da prvo uzme blkid particija

UUID=[b]23f622f2-9900-4b20-8aae-5c23bf54b393[/b] /media/school ext4 defaults,user_xattr 0 2 UUID=[b]23f622f2-9900-4b20-8aae-5c23bf54b393[/b] /media/moj ext4 defaults,user_xattr 0 2 UUID=[b]23f622f2-9900-4b20-8aae-5c23bf54b393[/b] /media/fun ext4 defaults,user_xattr 0 2

Boldovano menja prema stvarnom stanju koje dobije preko komade blkid

Da li to moze tako?

Ja mislim da ne može jer ako imaš label (naziv particije) onda umesto /dev/sdaX ide LABEL=naziv. Nisam nikad probao, kao ni sa UUID-jem.
@Александар je dao primer u lepljivoj temi.

@Blue, veoma je bitno da se ne otvara (montira) nijedna particija pre ovog ,poduhvata’’. Drugim rečima, ništa se ne dira kad se startuje sistem, već se odmah radi automontiranje…
Izvinjavam se što ponavljam, ali mora da se radi sve postupno…

@Blue

Препоручио бих ти да пробаш аутомонтирање партиција користећи њихове УУИД. Овде сам дао мали пример како се то ради. Мораш само строго водити рачуна о томе који је УУИД за коју партицију и верујем да неће бити проблема.

Да, што рече @Kmamuz, све се мора радити поступно, па и прављење фасцикле која ће служити за монтирање са рут овлашћењима. У мом случају, то је било:

sudo mkdir /home/aleksandarlmdexfce/Складиште

@Kmamuz pogledaj ovo tako je kod mene montirana NTFS particija i labela joj je XP1

UUID=A6E46E17E46DEA4F	/media/XP1	ntfs-3g	defaults,locale=en_US.UTF-8	0	0

Labelu ime particiji davao sam na zivo kad sam ja vlasnik, tako sam u 11.04 na zivo promenio i dao ime NattyRoot i NattyHome
Malo mi nije jasno da ne moze jednostavno da se stavi u /etc/fstab

UUID=584af716-6ccf-4ded-b95f-1718f67676cd	/school	ext4	rw,errors=remount-ro	0	0

Ona je kreirala tu particiju, ona je vlasnik, to npr. /home jeste sistemsko ali je to ipak po meni samo naziv