[REŠENO] HP Laser Jet P1005

Skinuo sam HPLIP 3.12.2: za ovaj moj štampač, ali ne uspevam da ga instaliram. Jednostavno, dođe do dela kao na slici i ja dalje ne znam . Samo da napomenem da kada sam instalirao Mint 12 , štampač mi je bio uključen te je odštampao test stranu, ali sada više neće da štampa. Nalazim ga u popisu štampača.
Šta mi je dalje činiti. Na Ubuntu 11.10 sam jednostavno završio proceduru koju mi je sam ponudio, ali ovde nešto ne štima i to prevazilazi moje poznavanje Minta (Linux-a).
Ako neko zna rešenje bio bih zahvalan!

[attach=2][attach=3]

Za početak u terminalu kucaj: sudo apt-get install gcc

[email protected] ~ $ sudo apt-get install gcc [sudo] password for joca: Reading package lists... Done Building dependency tree Reading state information... Done gcc is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. [email protected] ~ $

Šta sada ?

Sada vidim da su ove datoteke u folderu “desktop”, a u jednom stranom tutoru sam našao da treba da pretraživač podesim da ih skine u sistem. E, sad kad bih ja znao gde tačno da namestim chrome, ali ja to ne znam.[attach=1]

Jel si instalirao drajver za štampač? I kako si uopšte instalirao?

Pokušao sam ispratiti ponuđenu proceduru, koju sam našao na HP-ovom sajtu, a koja se odnosi na instalaciju HPLIP. Na kraju sam video upozorenje da moram skinuti datoteku u sistem (ja ne znam gde) da bi se mogla pokrenuti u terminalu. Sada više nisam siguran šta sam zapravo skinuo te da li je ta HPLIP datoteka upšte to što meni treba??? A nisam ni dobar u radu sa konzolom (tek sam počeo da učim komande).
Trenutno sam na poslu i nisam na Mintu, ali ću večeras probati ponoviti celu proceduru i probati da ju uslikam, da bi mi, eventualno, mogli pomoći.

Pozdrav !

sudo apt-get install hplip-gui

GUI za instalaciju hp stampaca, tako sto skida direktno binary driver sa HP servera i instalira ga.
Meni je resio problem bio…

Pokreces ga iz terminala

hp-setup

i samo pratis upustva sve do kraja, biras konekciju USB, LTP itd…Trebalo bi da ti to resi problem.

U svakom slucaju javi sta si uradio.

Meni je instalirao moj LP1020 na ovaj nacin koji sam naknadno dodao u linuxmint 12… Medjutim ako sistem instaliras sa vec upaljenim printerom nece ti ni trebati nikakva podesavanja radi ko od sale.

Jao, što ga ne uključi pre :23:??

Pokušao sam ponovo, ali tu ima podosta problema, a kako vidim zapelo je oko “python-devel” ili se varam. Kako god , gospodo šta dalje?
Ako ne bude drugo za vikend ću nanovo “install”.

[code][email protected] ~ $ cd Desktop
[email protected] ~/Desktop $ sh hplip-3.12.2.run
Creating directory hplip-3.12.2
Verifying archive integrity… All good.
Uncompressing HPLIP 3.12.2 Self Extracting Archive…

HP Linux Imaging and Printing System (ver. 3.12.2)
HPLIP Installer ver. 5.1

Copyright © 2011-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Mon-26-Mar-2012_22:06:03.log

/
note: Defaults for each question are maked with a ‘*’. Press to accept the default.

INSTALLATION MODE

Automatic mode will install the full HPLIP solution with the most common options.
Custom mode allows you to choose installation options to fit specific requirements.

Please choose the installation mode (a=automatic*, c=custom, q=quit) : a

Initializing. Please wait…

INTRODUCTION

This installer will install HPLIP version 3.12.2 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).

DISTRO/OS CONFIRMATION

Distro appears to be Linux Mint 12.

Is “Linux Mint 12” your correct distro/OS and version (y=yes*, n=no, q=quit) ? y

ENTER USER PASSWORD

Please enter the user (joca)'s password:
Password accepted

INSTALLATION NOTES

Enable the universe/multiverse repositories. Also be sure you are using the Ubuntu “Main” Repositories. See: https://help.ubuntu.com/community/Repositories/Ubuntu for more information. Disable the CD-ROM/DVD source if you do not have the Ubuntu installation media inserted in the drive. During the install process you will be added to the lp group, please quit the installer before the setup stage, log out, log back in, and run hp-setup to complete the install.

Please read the installation notes. Press to continue or ‘q’ to quit:

RUNNING PRE-INSTALL COMMANDS

OK

INSTALL MISSING REQUIRED DEPENDENCIES

warning: There are 5 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: python-devel (Python devel - Python development files)
warning: This installer cannot install ‘python-devel’ for your distro/OS and/or version.
error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer.
[email protected] ~/Desktop $
[/code]

E, da! Odavde sam skidao:

http://hplipopensource.com/hplip-web/install/install/index.html

Instaliraj ‘python-devel’ pa probaj opet…

GUI za instalaciju hp stampaca, tako sto skida direktno binary driver sa HP servera i instalira ga.
Meni je resio problem bio…

Pokreces ga iz terminala[attach=1][attach=2]

[code][email protected] ~ $ sudo apt-get install hplip-gui
[sudo] password for joca:
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
python-renderpm python-reportlab python-reportlab-accel
Suggested packages:
python-renderpm-dbg python-egenix-mxtexttools python-reportlab-doc
The following NEW packages will be installed:
hplip-gui python-renderpm python-reportlab python-reportlab-accel
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 719 kB of archives.
After this operation, 4,309 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com/ubuntu/ oneiric/main python-reportlab all 2.5-1.1 [567 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ oneiric-updates/universe hplip-gui all 3.11.7-1ubuntu3.1 [19.7 kB]
Get:3 http://archive.ubuntu.com/ubuntu/ oneiric/main python-renderpm amd64 2.5-1.1 [69.3 kB]
Get:4 http://archive.ubuntu.com/ubuntu/ oneiric/main python-reportlab-accel amd64 2.5-1.1 [63.2 kB]
Fetched 719 kB in 2s (348 kB/s)
Selecting previously deselected package python-reportlab.
(Reading database … 163490 files and directories currently installed.)
Unpacking python-reportlab (from …/python-reportlab_2.5-1.1_all.deb) …
Selecting previously deselected package hplip-gui.
Unpacking hplip-gui (from …/hplip-gui_3.11.7-1ubuntu3.1_all.deb) …
Selecting previously deselected package python-renderpm.
Unpacking python-renderpm (from …/python-renderpm_2.5-1.1_amd64.deb) …
Selecting previously deselected package python-reportlab-accel.
Unpacking python-reportlab-accel (from …/python-reportlab-accel_2.5-1.1_amd64.deb) …
Processing triggers for desktop-file-utils …
Processing triggers for gnome-menus …
Processing triggers for bamfdaemon …
Rebuilding /usr/share/applications/bamf.index…
Processing triggers for menu …
Processing triggers for man-db …
Setting up python-reportlab (2.5-1.1) …
Setting up hplip-gui (3.11.7-1ubuntu3.1) …
Setting up python-renderpm (2.5-1.1) …
Setting up python-reportlab-accel (2.5-1.1) …
Processing triggers for menu …
[email protected] ~ $ hp-setup

HP Linux Imaging and Printing System (ver. 3.11.7)
Printer/Fax Setup Utility ver. 9.0

Copyright © 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/joca/.config/ibus/bus
Searching… (bus=usb, search=(None), desc=0)
error: The printer you are trying to setup requires a binary driver plug-in and it failed to install. Please check your internet connection and try again. Visit http://hplipopensource.com for more infomation.
error: The printer you are trying to setup requires a binary driver plug-in and it failed to install. Please check your internet connection and try again. Visit http://hplipopensource.com for more infomation.

Done.
[email protected] ~ $
[/code]

Vidim da nije uspeo da skine plugin, a ni binary driver za tvoj stampac.
Meni tu samo na pamet pada da mozda nije konekcija pukla tokom preuzimanja?
Kakav ti je net? Mozda da probas ponovo…
Ne vidim sta bi drugo moglo da bude uzrok.

Pogledaj ovaj link mozda ti pomogne

http://linuxexchange.org/questions/422/how-do-i-install-the-hp-laserjet-p1005-under-debian-lenny

Gospodo proradio je… Kad sam došao sa posla, reko ajd još jednom da probam i gle radi.
Doduše tu nešto još nije kompletno sa ovim servisom, ali za sada sam zadovoljan i sa ovim, jer sam već bio u frci pošto mi je štampač potreban.
U svakom slučaj hvala svima na savetima. Gnome,sa komandama koje si mi naveo sam dobio ovaj servis, ali ovi crveni krstići me brinu.[attach=1]

Ti crveni krstići kažu da neki zadatak nije izvršen, može biti bilo šta od prekinutog procesa štampanja iz recimo LibreOffice-a do tonera u štampaču koji polako nestaje (ne kažem da jeste ali samo poredim koliki opseg mogućih problema može biti)

Uglavnom bitno je da sada radi :23:

Jeste,toner mi je pri kraju.
Hvala!

Jel to znači da je problem rešen? :23:

Jeste ! Sada sve šljaka .

Dopuna:

Plugin za HP P1005

http://hplipopensource.com/node/309