[REŠENO] Out of range

Prilikom dizanja sistema par sekundi (možda i desetina) mi na monitoru stoji kvadrat sa tekstom “Out of range”. Kako su mi objasnili problem je prepoznavanje grafičke kartice i generalno nije ništa strašno, ali ne boli ako pitam za savet.

Zato sto ti se restartovao X server ti to u sustini ne bi trebalo da vidis…i dok graficka dobije signal to ti se desava…

Meni nesto slicno bude… posto imam DVI i VGA meni menja output da bi shvatio na koji je privezan…

uglavnom to ne treba da te brine… samo je mozda odziv sporiji pa ti vidis to…

Hvala gnome :wink:

Pa da, to kontam i ja da je samo do odziva, jer jednom kada se sistem pokrene sve radi bez problema. Samo ta manja “anomalija” prilikom uključivanja, srećom kratko traje. Čisto me zanimalo da li je nešto što se dešava i oko čega ne treba nešto da brinem.

ne to je sasvim normalno…
u momentu restartovanja izgubi se signal do graficke karte i tebi monitor prijavi da je out of synch…sto je normalno…izgubio je signal do izvora…
sta bi radila moju ati karticu da vidis… Pre ulaska u mint ceo ekran se pretvori u brljave kockice…a onda nestane sve…ugasi se ekran…da bi dobio na kraju punu rezoluciju i lepu sliku…

Auh, srećom nemam taj problem. Samo ovaj kvadratić koji relativno brzo nestane. Hvala za info, ipak sam ja oduševljena mojim Mintom i nemam nameru da ga menjam :wink:

Najpre će da bude Plymouth screen rezolucija. Koja je grafička?

sudo hwinfo --framebuffer

Види коју ти највећу резолуцију подржава, онда то стави у grub

Dragane, imam problem sa tim infom, evo ga ispis

[email protected] ~$ sudo hwinfo --framebuffer sudo: hwinfo: command not found

@ Uroš

nVidia

Možda:

$ sudo apt-get install hwinfo

@ ivane to je pomoglo

Evo ga ispis

[code][email protected] ~$ sudo hwinfo --framebuffer

hal.1: read hal dataprocess 2922: arguments to dbus_move_error() were incorrect, assertion “(dest) == NULL || !dbus_error_is_set ((dest))” failed in file …/…/dbus/dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
02: None 00.0: 11001 VESA Framebuffer
[Created at bios.464]
Unique ID: rdCR.jdKLir8C32D
Hardware Class: framebuffer
Model: “NVIDIA MCP61 - mcp61-80”
Vendor: “NVIDIA Corporation”
Device: “MCP61 - mcp61-80”
SubVendor: “NVIDIA”
SubDevice:
Revision: “Chip Rev”
Memory Size: 64 MB
Memory Range: 0xe0000000-0xe3ffffff (rw)
Mode 0x0300: 640x400 (+640), 8 bits
Mode 0x0301: 640x480 (+640), 8 bits
Mode 0x0303: 800x600 (+800), 8 bits
Mode 0x0305: 1024x768 (+1024), 8 bits
Mode 0x0307: 1280x1024 (+1280), 8 bits
Mode 0x030e: 320x200 (+640), 16 bits
Mode 0x030f: 320x200 (+1280), 24 bits
Mode 0x0311: 640x480 (+1280), 16 bits
Mode 0x0312: 640x480 (+2560), 24 bits
Mode 0x0314: 800x600 (+1600), 16 bits
Mode 0x0315: 800x600 (+3200), 24 bits
Mode 0x0317: 1024x768 (+2048), 16 bits
Mode 0x0318: 1024x768 (+4096), 24 bits
Mode 0x031a: 1280x1024 (+2560), 16 bits
Mode 0x031b: 1280x1024 (+5120), 24 bits
Mode 0x0330: 320x200 (+320), 8 bits
Mode 0x0331: 320x400 (+320), 8 bits
Mode 0x0332: 320x400 (+640), 16 bits
Mode 0x0333: 320x400 (+1280), 24 bits
Mode 0x0334: 320x240 (+320), 8 bits
Mode 0x0335: 320x240 (+640), 16 bits
Mode 0x0336: 320x240 (+1280), 24 bits
Mode 0x033d: 640x400 (+1280), 16 bits
Mode 0x033e: 640x400 (+2560), 24 bits
Mode 0x0345: 1600x1200 (+1600), 8 bits
Mode 0x0346: 1600x1200 (+3200), 16 bits
Mode 0x0347: 1400x1050 (+1400), 8 bits
Mode 0x0348: 1400x1050 (+2800), 16 bits
Mode 0x0352: 2048x1536 (+8192), 24 bits
Config Status: cfg=new, avail=yes, need=no, active=unknown
[/code]

Sad, ja ne znam šta tačno treba da gledam ovde, a tek što ne znam kako to da ubacim u grub :wink:

Nakačiću ti jedan fajl uz ovu poruku, ti je skini, stavi je na desktop, npr, i desni klik na taj fajl, odaberi properties, pa tab permissions i čekiraj opciju allow executing file as a program. Onda dupli klik na fajl i odaberi opciju run in a terminal, unesi pass kad te pita i skripta će ti ponuditi da odabereš opciju za rezoluciju koja odgovara tvom monitoru.

Edit:

Forum ne dozvoljava da se nakači .sh fajl, neobično… Moramo drugačije, iskopiraj kod otvori gedit paste ceo kod i sačuvaj taj fajl nazovi ga kako hoćeš na desktop, onda na dalje ista procedura.

[code]#!/bin/bash

----------------------------------

Author: D0rkye, sredio Uroš

Homepage: http://d0rkye.zsenialis.com/

Most code probably by kyleabaker: http://kyleabaker.com/2010/07/11/how-to-fix-your-ubuntu-boot-screen/

Fix for Ubuntu 11.04, 11.10 for BURG, and some extra bloat by Paolo Bernardi (http://paolobernardi.wordpress.com/)

----------------------------------

Usage: install_if_not_installed package_name

function install_if_not_installed
{
PACKAGE="$1"
INSTALLED=$(dpkg -L “$PACKAGE” > /dev/null 2>&1 && echo OK || echo KO)
if [ “$INSTALLED” == “KO” ]
then
sudo apt-get install “$PACKAGE” -y
fi
}

Usage: contains regexp file

function contains
{
REGEXP="$1"
FILE="$2"

grep “$REGEXP” “$FILE” > /dev/null && echo OK || echo KO
}

install_if_not_installed v86d
install_if_not_installed hwinfo

sudo hwinfo --framebuffer
echo “---------------------------------------------------------------”
echo “Please enter the best resolution from the list above”
echo "It usualy looks like this >>Mode 0x0323: 1024x768 (+4096), 24 bits1024x768-24

[quote author=Uroš link=topic=271.msg3375#msg3375 date=1329385447]

Nakačiću ti jedan fajl uz ovu poruku, ti je skini, stavi je na desktop, npr, i desni klik na taj fajl, odaberi properties, pa tab permissions i čekiraj opciju allow executing file as a program. Onda dupli klik na fajl i odaberi opciju run in a terminal, unesi pass kad te pita i skripta će ti ponuditi da odabereš opciju za rezoluciju koja odgovara tvom monitoru.

Edit:

Forum ne dozvoljava da se nakači .sh fajl, neobično… Moramo drugačije, iskopiraj kod otvori gedit paste ceo kod i sačuvaj taj fajl nazovi ga kako hoćeš na desktop, onda na dalje ista procedura.

[code]#!/bin/bash

----------------------------------

Author: D0rkye, sredio Uroš

Homepage: http://d0rkye.zsenialis.com/

Most code probably by kyleabaker: http://kyleabaker.com/2010/07/11/how-to-fix-your-ubuntu-boot-screen/

Fix for Ubuntu 11.04, 11.10 for BURG, and some extra bloat by Paolo Bernardi (http://paolobernardi.wordpress.com/)

----------------------------------

Usage: install_if_not_installed package_name

function install_if_not_installed
{
PACKAGE="$1"
INSTALLED=$(dpkg -L “$PACKAGE” > /dev/null 2>&1 && echo OK || echo KO)
if [ “$INSTALLED” == “KO” ]
then
sudo apt-get install “$PACKAGE” -y
fi
}

Usage: contains regexp file

function contains
{
REGEXP="$1"
FILE="$2"

grep “$REGEXP” “$FILE” > /dev/null && echo OK || echo KO
}

install_if_not_installed v86d
install_if_not_installed hwinfo

sudo hwinfo --framebuffer
echo “---------------------------------------------------------------”
echo “Please enter the best resolution from the list above”
echo "It usualy looks like this >>Mode 0x0323: 1024x768 (+4096), 24 bits1024x768-24

sudo hwinfo --framebuffer

Setovanje framebuffer to nije rezolucija u kojoj ce posle monitor raditi, to je setovanje za plymouth

[code][email protected] ~$ sudo hwinfo --framebuffer
[sudo] password for iva:

hal.1: read hal dataprocess 5418: arguments to dbus_move_error() were incorrect, assertion “(dest) == NULL || !dbus_error_is_set ((dest))” failed in file …/…/dbus/dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
02: None 00.0: 11001 VESA Framebuffer
[Created at bios.464]
Unique ID: rdCR.jdKLir8C32D
Hardware Class: framebuffer
Model: “NVIDIA MCP61 - mcp61-80”
Vendor: “NVIDIA Corporation”
Device: “MCP61 - mcp61-80”
SubVendor: “NVIDIA”
SubDevice:
Revision: “Chip Rev”
Memory Size: 64 MB
Memory Range: 0xe0000000-0xe3ffffff (rw)
Mode 0x0300: 640x400 (+640), 8 bits
Mode 0x0301: 640x480 (+640), 8 bits
Mode 0x0303: 800x600 (+800), 8 bits
Mode 0x0305: 1024x768 (+1024), 8 bits
Mode 0x0307: 1280x1024 (+1280), 8 bits
Mode 0x030e: 320x200 (+640), 16 bits
Mode 0x030f: 320x200 (+1280), 24 bits
Mode 0x0311: 640x480 (+1280), 16 bits
Mode 0x0312: 640x480 (+2560), 24 bits
Mode 0x0314: 800x600 (+1600), 16 bits
Mode 0x0315: 800x600 (+3200), 24 bits
Mode 0x0317: 1024x768 (+2048), 16 bits
Mode 0x0318: 1024x768 (+4096), 24 bits
Mode 0x031a: 1280x1024 (+2560), 16 bits
Mode 0x031b: 1280x1024 (+5120), 24 bits
Mode 0x0330: 320x200 (+320), 8 bits
Mode 0x0331: 320x400 (+320), 8 bits
Mode 0x0332: 320x400 (+640), 16 bits
Mode 0x0333: 320x400 (+1280), 24 bits
Mode 0x0334: 320x240 (+320), 8 bits
Mode 0x0335: 320x240 (+640), 16 bits
Mode 0x0336: 320x240 (+1280), 24 bits
Mode 0x033d: 640x400 (+1280), 16 bits
Mode 0x033e: 640x400 (+2560), 24 bits
Mode 0x0345: 1600x1200 (+1600), 8 bits
Mode 0x0346: 1600x1200 (+3200), 16 bits
Mode 0x0347: 1400x1050 (+1400), 8 bits
Mode 0x0348: 1400x1050 (+2800), 16 bits
Mode 0x0352: 2048x1536 (+8192), 24 bits
Config Status: cfg=new, avail=yes, need=no, active=unknown
[/code]

Moj grub

/etc/default/grub

[code]# If you change this file, run ‘update-grub’ afterwards to update

/boot/grub/grub.cfg.

For full documentation of the options in this file, see:

info -f grub -n ‘Simple configuration’

GRUB_DEFAULT=5
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=15
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash vga=873”
#GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”
GRUB_CMDLINE_LINUX=“acpi_enforce_resources=lax”

Uncomment to enable BadRAM filtering, modify to suit your needs

This works with Linux (no patch required) and with any kernel that obtains

the memory map information from GRUB (GNU Mach, kernel of FreeBSD …)

#GRUB_BADRAM=“0x01234567,0xfefefefe,0x89abcdef,0xefefefef”

Uncomment to disable graphical terminal (grub-pc only)

#GRUB_TERMINAL=console

The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo’

GRUB_GFXMODE=1680x1050
#GRUB_GFXPAYLOAD_LINUX=1680x1050x24

Uncomment if you don’t want GRUB to pass “root=UUID=xxx” parameter to Linux

#GRUB_DISABLE_LINUX_UUID=true

Uncomment to disable generation of recovery mode menu entries

#GRUB_DISABLE_RECOVERY=“true”

Uncomment to get a beep at grub start

#GRUB_INIT_TUNE=“480 440 1”
[/code]

http://news.softpedia.com/news/How-to-Fix-the-Big-and-Ugly-Plymouth-Logo-in-Ubuntu-10-04-140810.shtml
Pise da je za Nvidiu a ja sam sa tim sredi Lubuntu i AGP ATI 9250 karticu, monitor je CRT 17" i vozio je u terminalu rezoluciju gde nisam mogao nista da procitam koliko je bilo sitno, u normalnom ekranu GUI sve je bilo ok.
Imas taj Urosev skrip, konsultuj geek-a kojeg si spominjala ako se plasis. Ako nece koliko se secam iako to ne koristim uvek mozes kod podizanja da sredis boot i podignes masinu i vratis na staro. :wink:

To se i meni desava na Mintu i u Debianu, ATI 9600 , u Ubuntu nema tu situaciju, nemam kockica, cini mise da Mint i Debian teraju karticu sa Galium drajverima, koji su kod Ubuntu 11.04 pojma nemam. Taj problem sa kockicama je najverovatnije zbog gnome 3, Ubuntu 11.04 je gnome 2 sa downgrade compizom.

Izaberi za probu, na sigurno

  Mode 0x0348: 1400x1050 (+2800), 16 bits

pa ako ti se ne svidi poigraj se, nema opasnosti, jedina razlika ti je estetska.

Uz pomoć kolege @ maletaski uspela sam da rešim ovaj problem, a postupak je bio sledeći:

  1. ispis grub fajla pre izmene je bio ovakav

# If you change this file, run 'update-grub' afterwards to update 2 # /boot/grub/grub.cfg. 3 # For full documentation of the options in this file, see: 4 # info -f grub -n 'Simple configuration' 5 6 GRUB_DEFAULT=0 7 GRUB_HIDDEN_TIMEOUT=0 8 GRUB_HIDDEN_TIMEOUT_QUIET=true 9 GRUB_TIMEOUT=10 10 GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian` 11 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" 12 GRUB_CMDLINE_LINUX="" 13 14 # Uncomment to enable BadRAM filtering, modify to suit your needs 15 # This works with Linux (no patch required) and with any kernel that obtains 16 # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...) 17 #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef" 18 19 # Uncomment to disable graphical terminal (grub-pc only) 20 #GRUB_TERMINAL=console 21 22 # The resolution used on graphical terminal 23 # note that you can use only modes which your graphic card supports via VBE 24 # you can see them in real GRUB with the command `vbeinfo' 25 #GRUB_GFXMODE=640x480 26 27 # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux 28 #GRUB_DISABLE_LINUX_UUID=true 29 30 # Uncomment to disable generation of recovery mode menu entries 31 #GRUB_DISABLE_RECOVERY="true" 32 33 # Uncomment to get a beep at grub start 34 #GRUB_INIT_TUNE="480 440 1"

  1. Bilo je potrebno editovati fajl konkretno u liniji 25 i to:
    • skinuti komentar ispred texta (odnosno #)
    • promeniti vrednosti koje stoje (u mom slučaju 640x480) na željene vrednosti
25 #GRUB_GFXMODE=1920x1080
  - sačuvati fajl
  - uraditi sudo update-grub
  - sudo reboot

Još jednom zahvalnost @ maletaski na pomoći i kao dodatak njegovo detaljno uputstvo o ovom problemu na adresi:
kliknite ovde

Мислим да та опција мења резолуцију груб менија и сплаш екрана, међутим ако ти се уместо сплаша исписује процедура бута, резолуција је “јадна” (800х600 рекао бих), одн. слова су огромна за данашње мониторе.
Тада помаже ако у GRUB_CMDLINE_LINUX_DEFAULT="" у оквиру /etc/default/grub фајла убаците опцију vga=775 или неки други број који одговара овој табели (quiet и splash опције су избрисане):

[code]# FRAMEBUFFER RESOLUTION SETTINGS

±------------------------------------------------+

| 640x480 800x600 1024x768 1280x1024

----±-------------------------------------------

256 | 0x301=769 0x303=771 0x305=773 0x307=775

32K | 0x310=784 0x313=787 0x316=790 0x319=793

64K | 0x311=785 0x314=788 0x317=791 0x31A=794

16M | 0x312=786 0x315=789 0x318=792 0x31B=795

±------------------------------------------------+[/code]

После сваке измене грубовог конф. фајла треба урадити sudo update-grub.