Rezolucija ekrana ( forsiranje nedetektovane )

Ukoliko imate problem sa podešavanjem rezolucije ekrana iz programa koji za to služe, u zavisnosti od DE okruženja, evo rešenja.

Prvo otvoriti terminal, pa komanda

xrandr

dobijete nešto nalik ovome

[email protected]:~$ xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
DVI-I-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1024x768	 60.0*
800x600	 60.3	 56.2
848x480	 60.0
640x480	 59.9
[email protected]:~$

zatim komanda cvt željena rezolucija, odnosno meni treba rezolucija 1680 x 1050, a vi upišite koja vama treba

cvt 1680 1050

i dobijemo novi modeline

[email protected]:~$ cvt 1680 1050
# 1680x1050 59.95 Hz (CVT 1.76MA) hsync: 65.29 kHz; pclk: 146.25 MHz
Modeline "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync

zatim pravimo novi modeline komandom

xrandr --newmode "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync

za koji output ( obratiti pažnju na izlaz komande xrandr )

xrandr --addmode DVI-I-1 1680x1050_60.00

i da najzad postavimo rezoluciju komandom

xrandr --output DVI-I-1 --mode 1680x1050_60.00

posle ove komande dobijate željenu rezoluciju, ali to nije kraj. Ovo važi do prvog restarta. Da napravimo permanentno. Napraviti u HOME direktorijumu skriveni tekstualni fajl sa nazivom .xprofile. Sadržaj fajla izgleda u mom slučaju ovako

xrandr --newmode “1680x1050_60.00” 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync

xrandr --addmode DVI-I-1 1680x1050_60.00

xrandr --output DVI-I-1 --mode 1680x1050_60.00

dakle copy/paste iz gore navedenih komandi. Posle toga jedan restart, i željena rezolucija je postavljena !

I to bi bilo to. Uživajte :playboy:

Na ovaj nacin, sam podesio rezoluciju (1440x900 http://forum.mint-srbija.com/topic/1162-geforce-6200-problem-sa-rezolucijom/), na SolusOS-u, Lubuntu, Mintu (xfce, cinnamon) i Debian Wheezy . Međutim nisam uspeo na ChranchBang Waldorf-u, na njemu ne mogu dalje od 1024x768 :(…

Da li si uspeo da forsiraš rezoluciju na Waldorf-u u sesiji sa komandama ? Ili…gde je zapelo ?

Ako si na Wheezy uspeo, trebalo bi da može i na Crunchbangu, pošto je sistem isti. Mada možda samo ne vidi taj .xprofile, pa probaj da postaviš komandu u openboxov autostart.

Mada ja preferiram editovanje xorg.conf za ovo kada se radi statička konfiguracija jer xorg.conf tome i služi za statičku konfiguraciju, xrandr je dinamička.

Krenem od recimo minimalnog xorg.conf-a pa dodam recimo sve standardne od maksimalne nadole (jer u edidu monitora uvek neke fale), na primer:

ovde recimo vidiš minimalac:
https://wiki.ubuntu.com/X/Config

pa ga prepravim (dodajem Modeline u Monitor sekciji proračunete putem cvt ili gtf, a koje mi fale u Edidu monitora ) bude ovako recimo što se rezolucija tiče:

Section "Device"
Identifier	 "Configured Video Device"
EndSection
Section "Monitor"
Identifier	 "Configured Monitor"
# 1024x600 @ 60.00 Hz (GTF) hsync: 37.32 kHz; pclk: 48.96 MHz
Modeline "1024x600" 48.96 1024 1064 1168 1312 600 601 604 622 -HSync +Vsync
# 1152x864 @ 60.00 Hz (GTF) hsync: 53.70 kHz; pclk: 81.62 MHz
Modeline "1152x864" 81.62 1152 1216 1336 1520 864 865 868 895 -HSync +Vsync
# 1280x720 @ 60.00 Hz (GTF) hsync: 44.76 kHz; pclk: 74.48 MHz
Modeline "1280x720" 74.48 1280 1336 1472 1664 720 721 724 746 -HSync +Vsync
# 1400x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 122.61 MHz
Modeline "1400x1050" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -HSync +Vsync
# 1440x900 @ 60.00 Hz (GTF) hsync: 55.92 kHz; pclk: 106.47 MHz
Modeline "1440x900" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync
# 1280x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 80.14 MHz
Modeline "1280x768" 80.14 1280 1344 1480 1680 768 769 772 795 -HSync +Vsync
# 1280x800 @ 60.00 Hz (GTF) hsync: 49.68 kHz; pclk: 83.46 MHz
Modeline "1280x800" 83.46 1280 1344 1480 1680 800 801 804 828 -HSync +Vsync
# 1280x960 @ 60.00 Hz (GTF) hsync: 59.64 kHz; pclk: 102.10 MHz
Modeline "1280x960" 102.10 1280 1360 1496 1712 960 961 964 994 -HSync +Vsync
# 1360x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 84.72 MHz
Modeline "1360x768" 84.72 1360 1424 1568 1776 768 769 772 795 -HSync +Vsync
# 1368x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 85.86 MHz
Modeline "1366x768" 85.86 1368 1440 1584 1800 768 769 772 795 -HSync +Vsync
# 1600x900 @ 60.00 Hz (GTF) hsync: 55.92 kHz; pclk: 119.00 MHz
Modeline "1600x900" 119.00 1600 1696 1864 2128 900 901 904 932 -HSync +Vsync
EndSection
Section "Screen"
Identifier	 "Default Screen"
Monitor		 "Configured Monitor"
Device		 "Configured Video Device"
EndSection

Info o standardnim rezolucijama imaš i na wikipediji, a naravno možeš da dodaješ i bilo koju tvoju custom ispod maksimalne i iznad minimalne po edidu. Mada se za uobičajeno korišćenje uvek preporučuje nativna, po prirodi modela monitora ::slight_smile: .

Evo i izlaz iz xrandr sa VGA i DVI priključenim, čisto da vidiš razliku kako je u edidu a kako sa ovim:

:~$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 4096 x 4096
VGA-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 510mm x 290mm
1920x1080	 60.0*+
1680x1050	 60.0
1400x1050	 60.0
1600x900	 60.0
1280x1024	 60.0
1440x900	 60.0
1280x960	 60.0
1366x768	 60.0
1360x768	 60.0
1280x800	 60.0
1152x864	 60.0
1280x768	 60.0
1280x720	 60.0
1024x768	 60.0
1024x600	 60.0
800x600	 60.3
640x480	 60.0
DVI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 510mm x 290mm
1920x1080	 60.0*+
1680x1050	 60.0
1280x1024	 60.0
1280x960	 60.0
1152x864	 60.0
1024x768	 60.0
800x600	 60.3
640x480	 60.0

Tek onda svičovanje radi čak i kad neki softver traži rezoluciju van edida, a X ne zna da ona postoji. Ali mi smo pametniji pa smo unapred naveli, jelte :1:

http://www.dodaj.rs/t/34/wm/4HrBYLkm/2012-11-08-1843201920x10.jpg

@[member=‘dvajedan’] pokusavao sam sa autostartom, i ovo sto si mi napisao, ali nije uspelo.
@[member=‘drinx’] posle komande
xrandr --addmode DVI-I-1 1440x900_60.00
izbacuje mi ovu gresku
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 154 (RANDR)
Minor opcode of failed request: 18 (RRAddOutputMode)
Serial number of failed request: 27
Current serial number in output stream: 28
Imam instalirane drajvere sa Nvidija sajta, mislim da je 304.64, mozda, da ih obrisem pa probam bez njih …

Ja sam na opensource radeon drajverima, nvidia je novajlija sa xrand tek od 302 serije (od juna ove godine) su počeli i oni to da koriste, pa verovatno još imaju mušice što se toga tiče.

http://forum.ubuntu-rs.org/Thread-nvidia-stable-302-i-xrandr-support

Otprilike kada koristiš nvidia drajver onda je preporuka da koristiš njihove utilities, tako je sigurnije sa blobovima ::slight_smile: . Mada i fglrx odavno podržava xrandr, dok nvidia češće ima problema sa rezolucijama pošto radi nešto svoje mimo X standarda.

A nouveau je reingovan komplet, tako da ne znam šta tu da kažem puno osim… ako ti radi koristi ga :1: .

@[member=‘Чика Глиша’]

Hmmmm… za sada nisam pametan, pojma nemam. Probaj to što i sam predlažeš, skini taj vlasnički drajver… kod nas ovde na forumu ima baš lepih tutorijala i diskusija pogotovo za Nvidia karte. Aj pa javi kako je prošlo žongliranje ? :wink:

[size=4]Sredjeno… ::slight_smile: sad je i na CranchBang-u 1440x900. Uradio novu instalaciju, jedino sto nisam mogao da uradim preko .xprofile, vec sam po uputstvu http://forums.debian…hp?f=16&t=78330 napravio [font=Lucida Grande’]resolution.sh i postavio ga u autostart…[/font]
Mozda ponovo instaliram Nvidija drajvere i probam sa resolution.sh, dal ce da moze… Ne, ne, dosta je, nemam zivce od plastike[/size]

Ja sam rešavao na isti način, jednostavna skripta u dva reda.