Savet za podesavanja nakon instalacije

Instaliraj prvi. Tj. oznaci ga, pa idi na Apply Changes. Kada zavrsi, udri Restart, pa javi jer se nesto promenilo u vezi Splash-a. :slight_smile:

@Cofi,

Evo tabele misli da ovo moze da guta u grubu za podlogu
http://pierre.baudu.in/other/grub.vga.modes.html

@dragan99
Hmm, nesto mi tu nema logike, kako ako Grub podrzava rezoluciju 1600x1200, pritom ne podrzava barem istu rezoluciju pozadine!? :12: Ja bih probao, al nazalost imam stari CRT monitor, pa ne mogu preko 1280x1024… No istrazicu malo na Google, pa javljam.

UPDATE:
Ne nadjoh konkretan odgovor, ali po svemu sudeci biti ce da je maksimalna rezolucija slike ista kao maksimalna rezolucija samog Grub-a, tj, monitora. U prevodu, ko recimo ima HD monitor, i moze da stavi rezoluciju Gruba na 1920x1080, moce ce i rezoluciju pozadine na 1920x1080 bez problema. :slight_smile: Sto kad se malo bolje razmisli, ima logike. :slight_smile: :drinks:

Sad kako sam promenio vga driver samo trepne splash u nekoj manjoj rezoluciji kolko sam mogao da primetim i odmah login…

Ima li joŇ° neŇ°to da probamo???

Za sad ima napretka, nije ni to bilo u pońćetku‚Ķ :slight_smile:

E to smo cekali. :smiley:
Taj problem prave Nvidia drajveri. A resava se:
Otvoris terminal i cepas jedno po jedno:

sudo -s echo FRAMEBUFFER=y >>/etc/initramfs-tools/conf.d/splash update-initramfs -u
Restart, i trebalo bi da je sve u redu. Sem eventualno rezolucije, ali to cemo lako da resimo ako ne valja. :slight_smile:

ReŇ°eno, radi, samo u manjoj rezoluciji ali radi‚Ķ :slight_smile:

[size=3] :good2:
A za rezoluciju; edituj /etc/default/grub i dodaj vga=867 u liniju GRUB_CMDLINE_LINUX_DEFAULT=‚Äúquiet splash‚ÄĚ[/size]
[size=3]tako da na kraju bude:[/size]

[size=3]GRUB_CMDLINE_LINUX_DEFAULT="vga=867 quiet splash"

Za slucaj da ne upali, ponovi isto, samo ovaj put dodaj ovo vga=867 i u GRUB_CMDLINE_LINUX=. Pa ce nakon toga biti:[/size]

GRUB_CMDLINE_LINUX_DEFAULT="vga=867 quiet splash" GRUB_CMDLINE_LINUX="vga=867"
[size=3] :slight_smile:

‚ÄďAko ti nekad bude trebalo:[/size]
http://en.wikipedia…numbersTu su ti ovi kodovi za ovaj vga=xxx parametar! Primera radi ako hoces da ti bude 1024x768 i 24bit, onda bi bilo vga=792…
:drinks:

@Cofi,

U tim tabelama nigde nema moja rezolucija 1680x1050 to je 16:10, imam utisak da su sve to rezolucije 4:3 ili 16:9, moj monitor je 20" to j e16:10 a 21.5" je pravi 16:9

Hmm, da. Ali koliko ja kontam, ovaj vga=xxx parametar sluzi za odredjivanje rezolucije splash-a, ne pozadine Grub-a. Posto se rezolucija samog Gruba odredjuje kroz GRUB_GFXMODE= parametar. Kod tebe na primer, GRUB_GFXMODE=1600x1050 ne bi trebalo da bude problem. :slight_smile:

Edit 1:
Nesto mi ne stima u ovim vga parametrima.
Kao sto kazes, tvoja rezolucija je 16:10 i nema je. A 1920x1200 postoji i takodje je 16:10, a 1920x1080 koja je 16:9 ne postoji!? WTF? :10:

vga= je za splash plymoutha GRUB_GFXMODE=1600x1050 i to stoji kod mene ali Debian to ne konstatuje, a u drugim linuksima to se sukobljava sa tim vga i ja mogu da stavim samo jednu jedinu vednost za vga, sve ostalo masina poludi, sad je splash playmouth. Ako bilo sta promenim u vga= parmatru dzaba meni GRUB_GFXMODE ekran dobije neku levu rezoluciji a spash Mint i numera stoje levo u cosku. Tako da ne pipam dugmice, sta mu sistemstavi a ja mu zveknem samo [email protected]

Da rezimiramo samo sto se tice slike za pozadinu Grub-a. Zakljucak je da je najveca moguca rezolucija slike jednaka najvecoj mogucoj rezoluciji samog Grub-a, tj Monitora. :slight_smile:

Onda je kod mene drugacije, nema konflikta izmedju ta dva parametra, i moram oba da podesim na 1024x768 da bi i Grub i Splash bili u toj rezoluciji. Ali to vazi samo za Mint 13 i 14. NIsam probao na Debian-u lli bilo kom drugom linuksu.

Dalje, zakljucak je (po dosadasnjim saznanjima!) da moras koristiti neku drugu, pribliznu rezoluciju za vga= parametar, dok se ne pojavi isti za 1600x1050.
1152x720 je 16:10, a vga=872 za 24bit boje.
:slight_smile:

Kod mene radi samo u Mint i Ubuntu ova suluda kombinacija GRUB_CMDLINE_LINUX=‚Äúvga=795‚ÄĚ i GRUB_GFXMODE=‚Äú[email protected]‚ÄĚ, u Debijanu ne zarezuje nista kao da ne postoji.
Sata i sate sam prove isprobavajuci sta mu odgovara, AMD graficka sa vlasnickim drajverima jer bez njih nece ni da radi kako treba

Ako radi tako, onda bolje stavi ovaj vga=872, barem je ratio odgovarajuci, tj. 16:10. :wink: :slight_smile:

Nego, sad se mislim, mozda treba da upalis framebuffer, cini mi se da je to ono sto ova komanda radi, isto sam napisao i Milosu jer resava problem kasnog pojavljivanja splash-a:

sudo -s echo FRAMEBUFFER=y >>/etc/initramfs-tools/conf.d/splash update-initramfs -u
Posto vga=xxx parametar izgleda odredjuje rezoluciju samo ako je framebuffer u upotrebi. Inace framebuffer sluzi valjda za povezivanje X-a sa memorijom graficke, tako nesto, ne kapiram ni sam bas najbolje, nije ni vazno…
Probaj ovo da cepnes, jedno za drugim, pa vidi onda da li ce vga=xxx i GRUB_GFX praviti problem ukoliko su zajedno. :slight_smile:

Imam FRAMEBUFFER=y sve sam to radio, to je ludilo, svojevremeno na jednoj masini Lubuntu, rezolucija u terminalu nevidjena, sitno, ludim, AMD kartica, odradim sve kao da ima Nvidiu i plymouth, rezultat, dobijem normalnu rezoluciju kako treba. Ovo sto sam stavio za vga=795 probavao sam danima , FRAMEBUFFER=y , sve tako odradjeno i ako promenim bilo koju vrednost od te ono poludi.

Uff, vala bas ludilo… :connie_nutzo:
Nisam pametan… A koji Radeon je u pitanju? Mozda da probas da dodas parametar kernel-u, pri boot-u, vga=ask. Tad bi trebalo da te pita koji mod da koristi, pa ces tu videti sta sve podrzava tvoja graficka… Tj. koje rezolucije… Pa kad odaberes neku, videces da li se ispravno prikazuje… A ovo vazi samo za to jedno boot-ovanje, prilikom sledeceg restarta, koristice ili onaj vga=xxx ili GRUB_GFX…

Citam post, stvarno mi nije problem sto nema Splash/Boot (ili koji god) screen, ali me brine nesto drugo:

Kod mene uopste ne postoji ovaj tab… Sta sad?

Verovatno imas Mint 13, ili bilo koji sem 14-ice… U tom slucaju imas program Additional Drivers, nacices ga u Meniju… Dalje sve isto vazi… :slight_smile:

Edit:
Ahahah, cuj mene verovatno, a lepo pise koji sistem imas… LOL… :smiley:
Znaci Additional Drivers…

Opet haos! :slight_smile:
Pise

Downloading package indexes failed, please check your network status. Most drivers will not be available.
[Close]

pa kad kliknem na [Close]

No proprietary drivers are in use on the system.
[Close]

Koristim matori HP Pavilion DV6523ea (za ITA trziste) i grafika (bi trebalo da) je Intel 965GMx86/MMX/SSE2.
Drajvere ne pokazuje, a ne primecujem neko kocenje usled nedostatka istih…

Sad sam iscitao i GRUB

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

[email protected] ~ $

znaci, nema one linije GRUB_BACKGROUND=… zato nema ni splash slicice! :slight_smile:
Jel tu mogu da utrpam bilo koju slicicu ili…? (Naravno, da se uklapa u one boje i rezolucije o kojima ste pricali)

Ne bih ti umeo pomoci oko ovoga. Mada mi deluje na neki problem sa povezivanjem na server gde se drajveri nalaze, ne na problem sa drajverima… Mozda da pokusas ponovo kasnije…!? :slight_smile:
U svakom slucaju mozes probati sve sto sam napisao za @Milos, samo zaobidji deo sa drajverima, mislim da ne bi trebalo da bude problema… Ali ne mogu da garantujem, posto imam iskustvo samo sa Nvidiom i sa unapred instaliranim drajverima… :slight_smile:

@Cofi

Kartica mije HD6700 sa 3d chipom 6790, kartica kad radi sa drajverima jede malu decu :slight_smile:
Gde ti je ta opcija Additional Drivers pod kojim meniem, sad sam u Cinnamonu 14 i to ne nalazim, koliko mi se cini to je valjda jockey a on je ukinut.
Sad AMD isporuci drajvere Canonicalu, oni to srede i nalaze se u synapticu ali moram sam da ih instaliram i obaveznao da napravim xorg.conf sa pozivom
fgltx