Server timeout - SBB router i TP link TL-WR940N

Poz ekipo,

Imam problema sa novim SBB netom u firmi, oni su bili i kalibrisali sve, slabljenja su manja od 1dB, češće manje razlike… i tvrde da je sve ok.
Pored toga imamo konektovan TP link TL-WR940N kao dodatni wifi.

Dešava mi se da mi puca neaktivna sesija iako sam konektovan preko kabla… dakle konektujem se na server i ako ne šaljem upite neko vreme, samo me diskotnektuje. Kroz aktivan rad mi se nije dešavalo za sad.

Verujem da dosta vas ima SBB i da ima nekih koji imaju TP link uređaj. Jedino mi pada na pamet da postoji neko podešavanje koje ima timeout… da li je na ruter nivou ili moram da cimam SBB, ne znam, stoga thred!

Unapred hvala svima

Pa kakve veze ima SBB internet sa serverom? :slight_smile:

Ovo se rešva u ssh_config (na serveru) sa max_timeout sesijom, da na određeni vremenski interval radi ping kako bi konekcija bila live.

Ima, u drugom kancu mi radi normalno sve, ovde ne, isti setup lokalno kod mene. :slight_smile:

Problem je i što kolegi puca na linuxu, dakle SSH sesija, ukoliko je ne koristimo, samo prekine. Sad da li imamo problem sa netom da buca na mili sekund… ali rekao bih da nije slučaj budući da aktivne sesije ne pucaju.

Postavi ovde konfiguraciju “ssh_config” (naravno sakrij IP, imena korisnika i šta sve treba)…

Konfiguracija je poprilično basic, isto nije dirana i radila je svoje… možda je jedino hosting kod koga smo nešto menjao, mada sumnjam da bi korisnicima pravili taj haos.

# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
HostKey /etc/ssh/ssh_host_ed25519_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 1024

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile  %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

Deluje da nisi dobro kopirao fale ti mnoge stvari…

Ajde dodaj na kraju:

ClientAliveInterval 60

Posle ovoga odradi restart sshd kompletno, nakači se ponovo i vidi da li prekida sesiju.

Ja bih zabranio da se TP link koristi u komercijalne svrhe…

Hvala Vlado, izgleda da je bilo to to… cudno je sto mi se nije repliciralo u drugom kancu.

Oho, reci, zasto to mislis? Mikrotik jeste ozbiljniji pristup ali za naše potrebe u trenutnom kancu je ovo bilo taman rešenje.

Različiti računari tj OS-ovi i programi za SSH pristup se različito ponašaju, meni na nekom linuxu raskine vezu nakon par minuta, na nekom 2 dana je nakačen na SSH, na kraju da bi svuda bilo isto uvek sa serverske strane zadaješ vrednost.

Ako si baš freak za bezbednost onda sa serverske strane staviš da se veza isključuje nakon 1-2m neaktivnosti, dok sa klijentske strane stavljaš veću vrednost da bi konekcija bila live stalno. Ovo poslednje ima smisla kada se freak ili ako imaš mnogo stotina različitih konekcija na SSH sa različitih strana pa da se ne diže load bespotrebno dok istekne sesija a korisnik recimo nije na serveru više.

Inače dobro da si našao uzrok gde je kvar bio.

Što se tiče TP Link-a to je u istom rangu kao Mikrotik, Tenda… to što SBB daje one krševe TP Link rutere od 1.000 RSD je druga priča. TP Link je odlična marka.

Gledajuci firme koje imaju iole neku mreznu infrastrukturu, nikad nisam video tp-link kao ruter/switch. Ono sto se izdvaja je Cisco, Mikrotik, HP, Dell i Ubiquiti EdgeSwitch/Router.

A sto se tice Mikrotik-a, dignes RouterOS na virtualizaciju i ne razmisljas o hardware-u :cool: