t umesto ć i đ u pretraživačima na 42.2 na ćirilici

Ćao ljudi,

zna li neko zbog čega mi se u pretraživačima ćirilični ć i đ pokazuju kao t? pre svega na twitteru, pa onda i na drugim sajtovima. Gde da krenem?

Hvala!

Verovatno fale neki fontovi, ne koristim Suse ali znam da ne mare mnogo za font rendering i slične stvari zbog softverskih patenata. Ja bih potražio opensuse web fonts i opensuse font rendering.

Провери прво да ли ти је инсталиран MozillaFirefox-translations-other

zypper info --provides MozillaFirefox-translations-other

Ако није,

zypper install MozillaFirefox translations-other

затим у ФФ

Preferences>Content>Font&Colors>Advanced>Allow pages to choose their own fonts, instead of my selections above (одштиклирај)

Briljantno!

Hvala, majstore!

Izvinjenje, ali ovo pitanje pokrećem ponovo.

Gore navedeno rešenje radi, ali mi borkuje fontove po stranicama, msm, nekako neprirodno izgledaju pošto firefox force-a svoje fontove. Da li postoji još neko moguće rešenje? pokušavao sam i sa promenom encodinga, ali nije radilo. Da li postoji još enka opcija koju bih mogao da pogledam?

HVala!

P.S.: Koliko sam uspeo da primetim, problem je samo na Twitteru i Faceu. Ostale stranice (a la Politika, Pouke itd. pokazuju ćiriličke znakove uredno)

Можеш ли да окачиш неку слику? Нисам сасвим сигуран у чему је проблем, а код мене у виртуали је све у реду па нисам сигуран о чему се ради…

Isto kod mene na vbox nisam primetio nikakav problem, leap 42.2 sve je default osim što sam instalirao software.opensuse.org: i podesio na yast fonts - force hint style na hint slight, i subpixel rendering na RGB. Pomoglo bi ako staviš neke linkove da vidimo koje stranice prave probleme,

Zasad to primećujem samo na Twitteru i Facebooku.

U prilogu skrinšot.

I ja imam taj slight hinting, ali mi je to radilo nevezano na podešavanja fontova. Chromium i Chrome to ne rade, takođe nije radio to FF na Ubuntu. Takođe mi page info pokazuje da je pravilno namešten utf-8 encoding.

[SIZE=2][SIZE=4]Никако не могу да репродукујем грешку. Мењао сам подешавања и у ЈАСТУ и у ФФ и код мене је све у реду. Стрпљења, можда ће неко знати у чему је ствар…[/SIZE][/SIZE]
[SIZE=2]

Screenshot - 03082017 - 02:28:11 PM.png

  • узгред, ако је неког убола у очи она неспретна језичка конструкција двоструког “нисам сигуран” у истој реченици - извињавам се… [/SIZE]

Ja sam našao grešku, ali nisam baš siguran kako sam popravio. Videću da vratim snapshot, popijem kafu pa polako korak po korak.

Probaj u home dir da napraviš fajl .fonts.conf i unesi:

[CODE]<?xml version="1.0"?>

Helvetica Arial [/CODE]

snimi i odradi restart.

Ćao,

Hvala na rešenju, ovo je proradilo. Šta smo tačno učinili ovim configom i u čemu je bio problem?

Hvala ti.

Problem je u Nimbus Sans L fontovima koji dolaze u ghostscript paketu, izgleda da je neka starija verzija sa slabom podrškom za ćirilicu. Config samo menja fontove na arial familiju koja je u suštini identična.

Svaka ti čast, majstore, i jedno veliko hvala. FB i TW rade, a na drugim sajtovima mi nije borkalo fontove.

Samo još jedno pitanje, da ne zeznem nešto. Ja već imam jedan fonts.conf u .config folderu, a ovoga sam stavio direktno u /home. Ne može valjda doći do nekih problema pošto postoje dva?

Hvala

Neće biti problema, što ne znači da je ok rešenje. Trebalo bi to nekako da se podesi preko YAST, jer nije preporučljivo ručno prepravljanje i dodavanje conf fajlova. Možda neko sa dužim stažom može da posavetuje da se podesi kako Suse zapoveda.

[FONT=Arial]Rešenje problema koje primenjujem je sledeće :

Putanja

/etc/fonts/conf.d/30-metric-aliases.conf

uneti

Helvetica DejaVu Sans
   <alias binding="same">
     <family>Times</family>
     <accept>
     <family>DejaVu Serif</family>
     </accept>
   </alias>

   <alias binding="same">
     <family>Courier</family>
     <accept>
     <family>DejaVu Mono</family>
     </accept>
   </alias>

I to bi bilo rešenje. [/FONT]

Suse kaže:

Mea culpa.

Uneti u terminal kao root korisnik

leafpad /etc/fonts/conf.d/30-metric-aliases.conf

ili

kwrite /etc/fonts/conf.d/30-metric-aliases.conf

u zavisnosti od toga koji se tekst editor koristi. Nakon otvaranja editovati fajl i ubaciti tekst

Helvetica DejaVu Sans Times DejaVu Serif Courier DejaVu Mono

sačuvati izmene i izaći iz tekst editora.

Koristio ovaj način za Open SUSE 42.1 i 42.2. princip primenjiv na još poneku distribuciju, ali za ovu temu nevažno.

На Slackware Srbija је било приче о овоме.

@uxbal Za sada najednostavnije rešenje je da obrišeš taj .fonts.conf u home (obrati pažnju, kod mene je napravilo prečicu i premetilo fajl u .config/fontconfig/rendering-options.conf) i odštikliraš Search metric compatible iz yast kao na slici:
yast.png

Zaboravio sam da napišem da ovaj korak Hatorija odrađuje posao. Hvala!