Testing...

Hello, Dragan.

Thanks for the tip to register. Thanks for the English section.
Perhaps I can help with Spanish some day.

I’m currently running antiX-Mepis MX-14 which is Wheezy based
and expected to continue systemd free until end-of-life of Wheezy,
or until it becomes untenable to maintain. That’s the reason I’m
interested in alternatives to “Jessie as planned”.

It’s about 10 PM here in Venezuela. Imagine it’s early morning for you.
Please point me to the link for the new build when you get a chance.
I have a partition ready to install it, although I will install it’s grub
to root of the partition and continue to use MX-14 to boot my system.

Regards and Best wishes for the season.
Richard.

Hello Richard, welcome to our community :slight_smile:

If you plan to install TRIOS on existing partition, please keep in mind to choose manual partitioning/grub install in installer.

Download link was sent to you by PM…happy testing :slight_smile:

Nice setup. Darker than my normal but it looks good.

My installation of Trios:

  1. Changed keyboard to ES.

  2. Prefer no Orage. I use Date-Time, but that is my personal preference

  3. I prefer the Clipman in the tray, via Session/Startup > App-Autostartup,
    since it is smaller than normal icon.

  4. The Manual Partitioning screen isn’t clear that changes
    must be saved before continue. Some text, “Save”,
    would remove the ambiguity, or maybe it’s just me.
    I did figure it out. :slight_smile:

Here is a shot of my preferred layout, or at least, todays:
https://db.tt/kqxtslIq
Should show now that I got the link into Dropbox.

All in all, a very nice piece of work. I was so looking forward to Jessie,
until the systemd fiasco. Thanks for your efforts. Keep me informed.
I plan to add my preferred apps and use this install for a few weeks.

saludos,
Richard.

Many thanks for the effort Richard!

  1. Keyboard layout will be switched back to (default) English.

  2. & 3. We’ll keep that in mind ( the default setup is up for a revision anyway )

  3. I’ll try to add labels on the “Apply/Save” & “Revert” buttons in the toolbar, to make them more visible ( btw, there is a info text in the bottom left corner, informing on the actions needed, but yeah, I agree, it would’t hurt to make the whole thing more clear )

:slight_smile:

EDIT:

Window buttons centered on the panel…cool lookin’! :good:

@Ćofi

[COLOR=rgb(40,40,40)]1. Changed keyboard to ES.
No problem with your keyboard setup, I thought the “rs” was “es”, but couldn’t read it. :slight_smile:

Anything in particular that you’d like me to test? Apps? OpenRC? etc.?

Richard.

…and I really like what you did with the 2nd Xfce panel --really neat presentation
without the overhead of another dock.

Open terminal as user from Thunar gives error:

right click > "Open terminal here" on a folder in thunar,
gives error:

bash: /etc/bash.bashrc: Permission denied
[[email protected]][~/.gconf]$
but then the terminal seems to work as expected.

Opening as root gives no error and seems as expected.
When will there be a 32 bit ISO?
I have a 64bit desktop, but have never bothered to run 64bit;
which helped to keep things compatible with the netbooks.
I use netbooks a lot for work while traveling.
Probably start again in late January.

Well, openrc test is the prime target of this build.
As I’ve explained here we would really like to stick with it, since it’s essentially what systemd is meant to be/should have been ( on the improvement side ofc, over sysvinit ), minus all the crap…
So, to answer your question more precisely, openrc behaviour is what we would like to know about.
On the “apps” side, any report on any one of them is considered a bonus for this build. But if you have time and will, you’re certainly more than welcome to test/report. :slight_smile:

Yes, that’s a “permissions”* related issue ( slipped through the build process ), which besides bash^ prevents lightdm from being themed, Grey theme from showing up in the Appearance settings, gdebi from running and some other less obvious stuff. Anyway, this script should fix that.

@32bit: Well, no guarantees, we’re still considering what to do about it, but should we decide to go for it, it’s likely going be released some time after the “final” a4** 64bit… :slight_smile:

[SIZE=12px]* They got messed up, resulting in only root having RW permissions on some ( mainly conf ) files ( /etc/bash.bashrc, /etc/lightdm-gtk-greeter.conf etc )[/SIZE], [SIZE=12px]everyone else = no access at all…[/SIZE]
[SIZE=12px]** a4 = alpha 4[/SIZE]

Some other niggles:

  1. Could not install Chrome with gdebi, said something about indexes being bad;
    installed with apt-get without problem.

  2. Sound didn’t work. see the fix here: http://www.pclinuxos.com/forum/index.php/topic,129296.msg1089619.html#msg1089619
    a. Removed the Alsa-mixer from App-Autostart.
    b. Installed VolumeIcon-Alsa and added it to App-Autostart.
    c. make sure /home/richard/.config/volumeicon/volumeicon contains:
    [COLOR=rgb(0,0,0)][Alsa]
    [COLOR=rgb(0,0,0)]card=default
    Now sound works and the mute button works as expected.

OK, here is rc-status from my desktop. Been up for a few hours:
[[email protected]][~]$ rc-status
Runlevel: default
rsyslog [ started ]
cron [ started ]
gdomap [ started ]
motd [ started ]
dbus [ started ]
lightdm [ started ]
bootlogs [ started ]
ssh [ started ]
speech-dispatcher [ started ]
avahi-daemon [ started ]
saned [ started ]
hddtemp [ started ]
bluetooth [ started ]
cgmanager [ started ]
cgproxy [ started ]
atd [ started ]
minissdpd [ started ]
anacron [ started ]
cups [ started ]
cups-browsed [ started ]
irqbalance [ started ]
open-vm-tools [ started ]
virtualbox-guest-utils [ started ]
wicd [ started ]
rc.local [ started ]
rmnologin [ started ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed
umountroot [ started ]
umountfs [ started ]
umountnfs.sh [ started ]
Dynamic Runlevel: manual
[[email protected]][~]$

Gdebi is affected by the permissions issue. Just fire up the script :wink:

No sound at all, or only muting refusing to…ammm, unmute? :slight_smile: :smiley:

On the muting problem:

It’s actually caused by the incompatibilty between xfce4-volumed & PulseAudio if I remember corectly ( “everything” except PA gets unmuted ).
Trying to stick with xfce-volume daemon/control, I sort of fixed it a couple of months ago, via custom “asound.rc” config, which allowed KB shortcuts/Mute Key (if existing), and middle-click on the volume icon tu mute/unmute properly.

However, you’re right, it doesn’t work anymore :frowning: Anyway, if it’s fixable, then good, if not, “volume-icon all the way” :smiley:

just playing around.
@Ćofi, your script seems to have things working again.

I had to turn off compositing in order to see the Dropbox icon.
It’s a Dropbox problem…hopefully they will get it fixed soon.

…and another look, without compositing…
https://db.tt/aPeRiD5M

Fixed![/URL] Along with enabling [URL=“https://github.com/trios-linux/trios-installer/commit/e4b74747f18852962d7a648fece7ba310128d1eb”]labels[/URL] on buttons, and some [URL=“https://github.com/trios-linux/trios-installer/commit/ef8b407766d1cc1a879027e02f4435b1b5ca7b09”]color tweaks, so that text remains readable on both dark and light themes. :slight_smile:
[SIZE=12px]( ^Screenshots are in the comments on the bottom )[/SIZE]

Great.
Looking forward to hybrid-4 or maybe Trios-rc1,
so I can start over again.
It is hard to find anything wrong with hybrid-3. :slight_smile:

:good2:

Thank you very much Richard for your enthusiasm and efforts!!! Much aprecciated!

Next build ( likely an “RC” ) will, if everything goes well, be released in a few days following the new year :slight_smile: drinks.gif

An observation, which could be just the difference between 32bit and 64bit but I don’t have experience running 64bit, is that

Trios-hybrid3-64bit based on Jessie uses considerably more Swap than MX-14 based on Wheezy.
About 2 - 5% compared to 40 - 50%.

The main effect of this seems to be perceived response of the system when switching apps.
Probably more an effect of only having 2 GiB in this system. With 32 bits it has never been an issue.

Watching for the new build.

Best wishes for a Happy and Prosperous New Year for all.

The problem with the 32bit systems is their 4GB RAM limitation, though… 32bit will remain for a few more years to support older computers but it’s lifetime has come to an end.

Well, first, Wheezy uses less RAM then Jessie ( it’s the way it goes, newer releases almost always eat more memory ), and second, 64bit(s)…

However you can use zram. It’ll greatly improve responsivness, with the cost of increased CPU usage during swaping.

What it does is create a compressed block device inside RAM and mount it as a swap partition, then, instead of moving data to swap, it just compresses it in the RAM itself.
Now, that puts a burden on the CPU, but, compared to regular swaping which can take a lot of time, while usually completely freezing the system, zram takes very, very little time, and doesn’t cause a freeze/lockup/slowdown.
It’s especially faster when data is read back from swap, since reading it from RAM is hell of a lot faster then reading from hdd…

I’ve been using it on this junker for two years without a hitch ( note “/dev/zram0” @Partition section ). Also, on a CPU that slow, it’s almost unnoticable when it swaps ( unless you stare at CPU/Swap monitor :smiley: )…

Now, you can use the script provided @Debian wiki^ (which may cause a boot to hang, although I haven’t experienced that ), or use this one[/URL], made by our friend Eugeinio, which uses udev to get the block device up and running ( .deb [URL=“http://archive.semplice-linux.org/semplice/archive/pool/main/z/zramcfg/”]here ).
If you go for the second solution, make sure you list “zram” in the /etc/modules so it’s get loaded on boot ( this is needed when there is no systemd )!

Also, check this on 32 vs. 64bit! :wink:

Thanks, Ćofi. That explains what I’m seeing. I’ll try zram;
sounds like an improvement for < 4 GiB RAM.
I’ve just never bothered since with 32 bit it’s not an issue.
Really needwant more RAM. ::slight_smile:
Inertia is my excuse --the box is mounted under and behind
my desk.

@mar1n3r0, you’re right, even though I use a pae kernel,
since it runs cooler on my machine, there’s nothing like more RAM. B)

You’re welcome! :slight_smile:

@zram: Definitely! It basically gives you “free” RAM.
Eugeonio’s soluton by default creates a swap device(s) of 25% size of total RAM amount, divided with number of cores in CPU. For dual-core & 1GB of RAM it would make two 128MB swaps, effectively “increasing” RAM to 1.25GB.

I forgot to mention these previously:

  • It’s best to use between 25-33% RAM for zram ( no more than ~50%, it may cause problems ),
  • It’s setup with priority over hdd swap, meaning that zram block device gets filled up first, and only then, if neccessary, hdd swap is used,
  • And, while it’s still considered experimental/unstable, I’ve never had, nor have read that someone had, any issues with it, but keep that in mind for the first couple of days atleast.

With that said, I’d recommend that you try “loading” it heavily after setting it up, just to make sure everything is ok. Easiest way is with browser, by “sequentally” opening a ton of heavy pages in tabs, while watching swap get filled up @System Monitor. :slight_smile:
If everything is ok, it shouldn’t cause any severe slowdown ( even with 100% on CPU ), until system starts swaping to hdd.

Speaking about RAM I have a very strange problem which appears to be quite widespread those days. BIOS shows about 400MB less RAM available than the physical one reported.

Here are some details from the machine:

check-my-memory.py - version: SJ 2014-03-16
OK, you’re root
ANALYSIS:
Total of physical memory modules found 4096 MB in 1 memory module(s)
BIOS offers 3668 MB as usable
Memory seen by OS 3534 MB
BIOS version 08/02/2013
CPU is PAE enabled
CPU is x86_64 64-bit enabled
OS is x86_64 64-bit

SUMMARY:
Memory difference between DIMM hardware and BIOS offering 428 MB
Memory difference between BIOS offering and memory seen by OS 134 MB
Memory difference between DIMM hardware and memory seen by OS 562 MB

ADVICE:
Your BIOS is not offering all of your physical memory. Try to update your BIOS, and/or enable ‘memory hole remapping / hoisting’ in your BIOS to get more usable memory

Finally: show more detailed memory info from lshw and dmidecode. This can take up to 30 seconds …
description: System Memory
size: 4GiB
description: DIMM [empty]
description: SODIMM DDR3 Synchronous 1600 MHz (0,6 ns)
size: 4GiB
description: BIOS
size: 128KiB
capacity: 4032KiB
BIOS Information
Vendor: LENOVO
Version: H0ET94WW (2.54 )
Release Date: 08/02/2013

System Information
Manufacturer: LENOVO
Product Name: 33664NG
Version: ThinkPad Edge E530c

Maximum Capacity: 16 GB

Finished

[email protected]:~$ dmesg | grep BIOS [ 0.000000] e820: BIOS-provided physical RAM map: [ 0.000000] BIOS-e820: [mem 0x0000000000000000-0x000000000009cfff] usable [ 0.000000] BIOS-e820: [mem 0x000000000009d000-0x000000000009ffff] reserved [ 0.000000] BIOS-e820: [mem 0x00000000000e0000-0x00000000000fffff] reserved [ 0.000000] BIOS-e820: [mem 0x0000000000100000-0x000000001fffffff] usable [ 0.000000] BIOS-e820: [mem 0x0000000020000000-0x00000000201fffff] reserved [ 0.000000] BIOS-e820: [mem 0x0000000020200000-0x0000000040003fff] usable [ 0.000000] BIOS-e820: [mem 0x0000000040004000-0x0000000040004fff] reserved [ 0.000000] BIOS-e820: [mem 0x0000000040005000-0x00000000873c6fff] usable [ 0.000000] BIOS-e820: [mem 0x00000000873c7000-0x000000009ae9efff] reserved [ 0.000000] BIOS-e820: [mem 0x000000009ae9f000-0x000000009af9efff] ACPI NVS [ 0.000000] BIOS-e820: [mem 0x000000009af9f000-0x000000009affefff] ACPI data [ 0.000000] BIOS-e820: [mem 0x000000009afff000-0x000000009f9fffff] reserved [ 0.000000] BIOS-e820: [mem 0x00000000f8000000-0x00000000fbffffff] reserved [ 0.000000] BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved [ 0.000000] BIOS-e820: [mem 0x00000000fed08000-0x00000000fed08fff] reserved [ 0.000000] BIOS-e820: [mem 0x00000000fed10000-0x00000000fed19fff] reserved [ 0.000000] BIOS-e820: [mem 0x00000000fed1c000-0x00000000fed1ffff] reserved [ 0.000000] BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved [ 0.000000] BIOS-e820: [mem 0x00000000ff000000-0x00000000ff000fff] reserved [ 0.000000] BIOS-e820: [mem 0x00000000ffc00000-0x00000000ffffffff] reserved [ 0.000000] BIOS-e820: [mem 0x0000000100000000-0x000000015e5fffff] usable [ 0.000000] SMBIOS 2.7 present. [ 0.000000] DMI: LENOVO 33664NG/33664NG, BIOS H0ET94WW (2.54 ) 08/02/2013 [ 0.000000] Calgary: detecting Calgary via BIOS EBDA area [ 0.100643] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored [ 1.112549] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found [ 19.685894] thinkpad_acpi: ThinkPad BIOS H0ET94WW (2.54 ), EC unknown [ 19.780993] hda_codec: CX20590: BIOS auto-probing.

[email protected]:~$ free -m total used free shared buffers cached Mem: 3534 2872 662 61 90 1367 -/+ buffers/cache: 1414 2120 Swap: 3864 0 3864

lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 635M] (rev a1)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)
03:00.0 Network controller: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter (rev 01)
0c:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)
[email protected]:~$ lspci -v -s 00:02.0
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
Subsystem: Lenovo Device 5001
Flags: bus master, fast devsel, latency 0, IRQ 45
Memory at e1400000 (64-bit, non-prefetchable) [size=4M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 6000 [size=64]
Expansion ROM at  [disabled]
Capabilities: 
Kernel driver in use: i915

After a bit of research my suggestion is BIOS issue related to part of the memory not getting remapped after reserving the necessary. They call it also the memory hole, but I don’t have any option in my BIOS to remap it.

There is a newer version of the BIOS but I can’t see any hot fix for this announced…

Anybody else ever stumbled upon such a scenario, any suggestions ?

P.S. I am booting with Legacy mode. Tried to boot UEFI today for the sake of testing but wouldn’t pass the welcome screen. Not sure if this could be related. As far as I know UEFI concerns only windows users.