TRIOS Gnome3

Konačno je i Gnome3 proradio…TRIOS sada može da se pohvali da je jedini moderan Debian u univerzumu koji ima Gnome3, a nema systemd-infekciju :wink:

Index of /trios/mia/pool/main/g/

Za one koji su voljni da testiraju:

  1. gdm3 mora biti instaliran, ali ostavite lightdm kao aktivan display manager…kod mene gdm3 (još uvek) ne radi kako treba, pa je bolje da ne rizikujete…
  2. gnome-logs nije u funkciji, i ne može da se instalira na TRIOS…u potpunosti se oslanja na libsystemd-journal.
  3. PackageKit još nisam sredio do kraja…kada bude gotov, ubaciću i njega u repo. Za sada, koristite Synaptic ili terminal (apt)
    Ostalo, koliko se meni čini, radi kako treba…testirajte, pa prijavite ovde ako naiđete na neke ozbiljnije probleme.

Uživajte :slight_smile:

Test snimaka…forum nešto zeza…
Screenshot - 04212016 - 11:43:48 PM.png Screenshot - 04222016 - 01:40:30 AM.png

Edit:
Ovo su snimci xfce okruženja, još dok je operacija likvidacije uljeza bila u toku :wink:

Screenshot - 04222016 - 04:56:32 PM.png

ovo je standardni snimač, iz xfce…brljotina na desnoj strani snimka je uobičajena, zbog velike razlike u rezolucijama glavnog i “pomoćnog” ekrana sa desne strane (svega1024 x 768)

Screenshot - 04222016 - 05:08:45 PM.png

Screenshot from 2016-04-22 17:00:51.png

Ne zeza forum, nego snimač ekrana koji dolazi u gnome paketu…ne snalazi se sa dual monitor snimcima celog ekrana. Slika jednog prozora je ok (ova poruka)…istražujemo dalje :slight_smile:

Super vest, ispravite me ako grešim ali ovo je prvi Gnome 3 na svetu koji nije zavisan od systemD i koristi openRC!? :wink:

Nije baš prvi generalno…postavio sam link gore, prvi je Gentoo/Funtoo…ali ako se računa samo Debian bazirani ekosistem, onda jeste prvi :slight_smile:

Neće da se instalira. :slight_smile:

[CODE]apt install gnome
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gnome : Depends: gnome-core (= 1:3.14+3trios1.1) but it is not going to be installed
Depends: gnome-shell-extension-weather but it is not going to be installed
Recommends: gnome-software but it is not installable
E: Unable to correct problems, you have held broken packages.
[/CODE]

# inxi -r
Repos:  Active apt sources in file: /etc/apt/sources.list
  deb http://http.debian.net/debian/ jessie non-free contrib main
  deb-src http://http.debian.net/debian/ jessie main contrib non-free
  deb http://security.debian.org/ jessie/updates main contrib non-free
  deb-src http://security.debian.org/ jessie/updates main contrib non-free
  deb http://http.debian.net/debian/ jessie-updates main contrib non-free
  deb-src http://http.debian.net/debian/ jessie-updates main contrib non-free
  deb http://http.debian.net/debian/ jessie-backports non-free contrib main
  deb-src http://http.debian.net/debian/ jessie-backports main contrib non-free
  Active apt sources in file: /etc/apt/sources.list.d/trios.list
  deb http://mirror.org.rs/trios/mia/ mia main sysdfree zfs eudev
  deb-src http://mirror.org.rs/trios/mia/ mia main sysdfree zfs eudev

Tu su svi paketi

[CODE]# list=“gdm3 gnome-bluetooth gnome-disk-utility gnome-session gnome-settings-daemon gnome-shell gnome-system-monitor”

for pkg in $list; do apt-cache policy $pkg; done

gdm3:
Installed: (none)
Candidate: 3.14.1-7trios1
Version table:
3.14.1-7trios1 0
1001 http://mirror.org.rs/trios/mia/ mia/main amd64 Packages
3.14.1-7 0
500 http://http.debian.net/debian/ jessie/main amd64 Packages
gnome-bluetooth:
Installed: (none)
Candidate: 3.14.0-2trios1
Version table:
3.14.0-2trios1 0
1001 http://mirror.org.rs/trios/mia/ mia/main amd64 Packages
3.14.0-2 0
500 http://http.debian.net/debian/ jessie/main amd64 Packages
gnome-disk-utility:
Installed: (none)
Candidate: 3.12.1-1trios1
Version table:
3.12.1-1+b1 0
500 http://http.debian.net/debian/ jessie/main amd64 Packages
3.12.1-1trios1 0
1001 http://mirror.org.rs/trios/mia/ mia/main amd64 Packages
gnome-session:
Installed: (none)
Candidate: 3.14.0-2trios1
Version table:
3.14.0-2trios1 0
1001 http://mirror.org.rs/trios/mia/ mia/main amd64 Packages
3.14.0-2 0
500 http://http.debian.net/debian/ jessie/main amd64 Packages
gnome-settings-daemon:
Installed: (none)
Candidate: 3.14.2-3~trios1
Version table:
3.14.2-3 0
500 http://http.debian.net/debian/ jessie/main amd64 Packages
3.14.2-3~trios1 0
1001 http://mirror.org.rs/trios/mia/ mia/main amd64 Packages
gnome-shell:
Installed: (none)
Candidate: 3.14.4-1~trios1
Version table:
3.14.4-1~trios1 0
1001 http://mirror.org.rs/trios/mia/ mia/main amd64 Packages
3.14.4-1~deb8u1 0
500 http://http.debian.net/debian/ jessie/main amd64 Packages
gnome-system-monitor:
Installed: (none)
Candidate: 3.14.1-1trios1
Version table:
3.14.1-1trios1 0
1001 http://mirror.org.rs/trios/mia/ mia/main amd64 Packages
3.14.1-1 0
500 http://http.debian.net/debian/ jessie/main amd64 Packages
[/CODE]
Ali

# apt install gdm3 gnome-bluetooth gnome-disk-utility gnome-session gnome-settings-daemon gnome-shell gnome-system-monitor
Reading package lists... Done
Building dependency tree   
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-shell : Depends: gir1.2-mutter-3.0 (>= 3.14.4) but it is not going to be installed
  Depends: libmutter0e (>= 3.14.4) but it is not going to be installed
  Depends: mutter (>= 3.14.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

# apt-cache policy  gir1.2-mutter-3.0 libmutter0e mutter
gir1.2-mutter-3.0:
  Installed: (none)
  Candidate: 3.14.4-1~trios1
  Version table:
  3.14.4-1~trios1 0
  1001 http://mirror.org.rs/trios/mia/ mia/main amd64 Packages
  3.14.4-1~deb8u1 0
  500 http://http.debian.net/debian/ jessie/main amd64 Packages
libmutter0e:
  Installed: (none)
  Candidate: 3.14.4-1~trios1
  Version table:
  3.14.4-1~trios1 0
  1001 http://mirror.org.rs/trios/mia/ mia/main amd64 Packages
  3.14.4-1~deb8u1 0
  500 http://http.debian.net/debian/ jessie/main amd64 Packages
mutter:
  Installed: (none)
  Candidate: 3.14.4-1~trios1
  Version table:
  3.14.4-1~trios1 0
  1001 http://mirror.org.rs/trios/mia/ mia/main amd64 Packages
  3.14.4-1~deb8u1 0
  500 http://http.debian.net/debian/ jessie/main amd64 Packages

# apt install gir1.2-mutter-3.0 libmutter0e mutter
Reading package lists... Done
Building dependency tree   
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libmutter0e : Depends: libgnome-desktop-3-12 (>= 3.17.92) but it is not installable
  Depends: libxkbcommon-x11-0 (>= 0.5.0) but it is not going to be installed
  Depends: libxkbcommon0 (>= 0.5.0) but 0.4.3-2 is to be installed
E: Unable to correct problems, you have held broken packages.

Ovo je sveža instalacija TRIOS-EUDEV

@Misko_2083
Izvinjotka…verovatno sam zaboravio nešto od paketa da ubacim u repo, saćem proverim :slight_smile:

Ovde je (bio) problem…pogrešna verzija mutter-a, bildana na triosu sa uljezom, pa je povlačila i pogrešnu verziju libgnome-desktop…treba libgnome-desktop-3-10, a ne *-3-12
Prepakovao sam i prebacio ispravne verzije u repo, trebalo bi da je sada ok…isprobaj kad stigneš pa javi rezultat :slight_smile:

[[email protected]][/home/dragan/Desktop]# apt install gir1.2-mutter-3.0 libmutter0e mutter Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: autoconf2.13 ca-certificates-java default-jre-headless gir1.2-edataserver-1.2 gir1.2-panelapplet-4.0 gnome-applets gnome-applets-data gnome-control-center-dev gnome-flashback gnome-flashback-common gnome-panel gnome-panel-data java-common libasn1-8-heimdal libasound2-dev libatk-wrapper-java libatk-wrapper-java-jni libcamel1.2-dev libcaribou-dev libcinnamon-desktop-dev libcroco3-dev libecal1.2-dev libedataserver1.2-dev libgck-1-dev libgconf2-4 libgcr-3-dev libgjs-dev libgmp-dev libgmpxx4ldbl libgnome-bluetooth-dev libgnome-menu-3-dev libgnomekbd-dev libgnutls28-dev libgnutlsxx28 libgssapi3-heimdal libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal libical-dev libimobiledevice-dev libkrb5-26-heimdal libmozjs-24-bin libmozjs-24-dev libnm-glib-vpn-dev libnm-gtk-dev libp11-kit-dev libpanel-applet-4-0 libplist-dev libpolkit-agent-1-dev libroken18-heimdal libsctp1 libtasn1-6-dev libtasn1-bin libtasn1-doc libtelepathy-glib-dev libusb-1.0-0-dev libusb-1.0-doc libusbmuxd-dev libwind0-heimdal libxklavier-dev lksctp-tools nettle-dev openjdk-7-jre-headless perlmagick tzdata-java yasm Use 'apt-get autoremove' to remove them. The following extra packages will be installed: libmutter-dev mutter-common The following packages will be upgraded: gir1.2-mutter-3.0 libmutter-dev libmutter0e mutter mutter-common 5 upgraded, 0 newly installed, 0 to remove and 7 not upgraded. Need to get 1,383 kB of archives. After this operation, 574 kB of additional disk space will be used. Do you want to continue? [Y/n] Get:1 http://mirror.org.rs/trios/mia/ mia/main mutter amd64 3.14.4-1~trios2 [90.8 kB] Get:2 http://mirror.org.rs/trios/mia/ mia/main libmutter-dev amd64 3.14.4-1~trios2 [194 kB] Get:3 http://mirror.org.rs/trios/mia/ mia/main gir1.2-mutter-3.0 amd64 3.14.4-1~trios2 [92.0 kB] Get:4 http://mirror.org.rs/trios/mia/ mia/main libmutter0e amd64 3.14.4-1~trios2 [423 kB] Get:5 http://mirror.org.rs/trios/mia/ mia/main mutter-common all 3.14.4-1~trios2 [583 kB] Fetched 1,383 kB in 0s (2,945 kB/s) Reading changelogs... Done (Reading database ... 489767 files and directories currently installed.) Preparing to unpack .../mutter_3.14.4-1~trios2_amd64.deb ... Unpacking mutter (3.14.4-1~trios2) over (3.14.4-1~trios1) ... Preparing to unpack .../libmutter-dev_3.14.4-1~trios2_amd64.deb ... Unpacking libmutter-dev (3.14.4-1~trios2) over (3.14.4-1~trios1) ... Preparing to unpack .../gir1.2-mutter-3.0_3.14.4-1~trios2_amd64.deb ... Unpacking gir1.2-mutter-3.0 (3.14.4-1~trios2) over (3.14.4-1~trios1) ... Preparing to unpack .../libmutter0e_3.14.4-1~trios2_amd64.deb ... Unpacking libmutter0e (3.14.4-1~trios2) over (3.14.4-1~trios1) ... Preparing to unpack .../mutter-common_3.14.4-1~trios2_all.deb ... Unpacking mutter-common (3.14.4-1~trios2) over (3.14.4-1~trios1) ... Processing triggers for bamfdaemon (0.2.118-1) ... Rebuilding /usr/share/applications/bamf.index... Processing triggers for gnome-menus (3.13.3-6) ... Processing triggers for desktop-file-utils (0.22-1) ... Processing triggers for mime-support (3.58) ... Processing triggers for libglib2.0-0:amd64 (2.42.1-1+b1) ... Processing triggers for man-db (2.7.0.2-5) ... Setting up mutter-common (3.14.4-1~trios2) ... Setting up libmutter0e (3.14.4-1~trios2) ... Setting up mutter (3.14.4-1~trios2) ... Setting up gir1.2-mutter-3.0 (3.14.4-1~trios2) ... Setting up libmutter-dev (3.14.4-1~trios2) ... Processing triggers for libc-bin (2.19-18+deb8u4) ... [[email protected]][/home/dragan/Desktop]#

@Dragan Hvala, sada mogu da instaliram. Znao sam da je mutter u pitanju ali nisam znao zašto. :slight_smile:

OK instalira kompletan Gnome 3, što je negde oko 1 GB preko Triosa. Izabrao sam lightdm display menadžer.
… … … … …
Log out and in.

Sve u redu osim ovog vremena, ne može da se podesi.

o_O

R0yHCeC.jpg
Inače lepo izgleda i radi za sada. Ako naiđem na još nešto, postavljam. :slight_smile:

Proveriću da li mogu nešto da popravim…usput, ako te mrzi, probaj čist restart, ili u root terminalu

rc-status

rc-status Runlevel: default rsyslog [ started ] dbus [ started ] avahi-daemon [ started ] gdomap [ started ] zfs-mount [ started ] zfs-zed [ started ] zfs-share [ started ] lightdm [ started ] network-manager [ started ] gdm3 [ started ] speech-dispatcher [ started ] open-vm-tools [ started ] bootlogs [ started ] hddtemp [ started ] smartmontools [ started ] virtualbox-guest-utils [ started ] uuidd [ started ] anacron [ started ] atd [ started ] bluetooth [ started ] cron [ started ] cups [ started ] cups-browsed [ started ] exim4 [ started ] irqbalance [ started ] minissdpd [ started ] motd [ started ] rsync [ started ] saned [ started ] ssh [ started ] rmnologin [ started ] rc.local [ started ] Dynamic Runlevel: hotplugged Dynamic Runlevel: needed umountroot [ started ] umountfs [ started ] umountnfs.sh [ started ]
Vreme može da se sačuva komandom date iz terminala. GUI ne može da sačuva, vezali su ga za systemd. :slight_smile:
EnoR7H3.jpg

Da, dosta toga je uslovljeno uljezom…čudo da i ovoliko radi na TRIOS-u :slight_smile:

@Dragan :up: Nije čudo, već tvoja istrajnost i naporan rad.