update manager - pomoć

Dobar dan
Kad pokrenem update manager izbaci mi

ERROR###ERROR###ERROR###ERROR###ERROR###ERROR###ERROR
E:Type ‘http://ppa.launchpad.net’ is not known on line 1 in source list /etc/apt/sources.list.d/additional-repositories.list

imam mint 16
hvala u napred

Koliko vidim, nije ti ispravan link do LP…

Prenesi ovde kakva je lista za dodatne ppa repoe

cat /etc/apt/sources.list.d/additional-repositories.list

 

Dali ovo treba u terminal ili ne?

Ako ide terminal mi je izbacio ovo http://ppa.launchpad.net

Nisam baš vičan pa vas molim da nezamerite.

Ne zamera niko ništa, bez brige :slight_smile:

Jeste, dobro si uradio, ispis iz terminala je potvrdio

Bilo koji repo/unos u apt source listi mora imati sledeću (generičku) formu

deb http://ppa.launchpad.net/person/ppa/ubuntu karmic main

Odnosno, za mint verovatno ne piše ubuntu nego mint, i naziv izdanja/verzije (petra, olivia ili nešto treće)

Međutim, kod tebe niti ima deb ispred linka, niti se vidi koji ppa želiš da postaviš u sors listu.

Slobodno obriši taj unos iz liste (/etc/apt/sources.list.d/additional-repositories.list), kao sudo korisnik naravno, pa pusti ponovo update manager

Uputstva kako da dodaš željeni ppa u sors listu ima puno…na primer ovde:

https://launchpad.net/+help-soyuz/ppa-sources-list.html

Samo mi reci dali je http://ppa.launchpad.net taj koji ppa koji treba da instaliram

Ne, LP je samo server (http://ppa.launchpad.net/) na kome se nalaze ppa skladišta za dodatne programe…

Moraš malo više da cunjaš i da izabereš šta ti tačno treba od tih dodatnih skladišta…ima ih zilion i praktično je nemoguće sve ih dodati u listu, poklali bi se paketi između sebe sigurno :slight_smile:
Sad vidim da postoji i nekakav ppa manager, da početnicima olakša pretragu i dodavanje ppa u sors liste

http://www.webupd8.org/2013/11/y-ppa-manager-0992-adds-support-for.html

Pokušao sam da instaliram ppa manager međutim neće

zaboravio sam sliku

Ipak hoće :slight_smile:

Na linku koji sam ti dao, imaš doslovce samo 3 linije koje treba da preneseš u terminal i izvršiš…upravo sam probao, (imam Mint 16 u Vboxu), radi bez greške :slight_smile:
http://www.webupd8.org/2013/11/y-ppa-manager-0992-adds-support-for.html

[ATTACH]3228.IPB[/ATTACH][ATTACH]3229.IPB[/ATTACH]
[ATTACH]3230.IPB[/ATTACH][ATTACH]3231.IPB[/ATTACH]

Ne zameri nije mi cilj da vas zadržavam ni tebe ni bilo koga.Prvi red sam ubacio u treminal i njega je odradi zatim kada sam ubacio komandu
sudo apt-get update izbacio je sledeće

[email protected] ~ $ sudo apt-get update
E: Type ‘http://ppa.launchpad.net/ikarosdev’ is not known on line 2 in source list /etc/apt/sources.list.d/ikarosdev-unity-revamped-saucy.list
E: The list of sources could not be read.
kako da ga instaliram?

Ne znam šta se kod tebe dešava, deluje kao da je zbrljan apt…šta imaš u osnovnoj sors listi?

Ukucaj u terminalu, pa prenesi ovde…

cat /etc/apt/sources.list

evo ga

evo i slike

Izvinjavam se, moja greška…sad sam tek video da Mint osnovnu sors listu smešta drugačije nego Debian…

Otvori terminal, ukucaj u terminalu komandu

inxi -r

pa prebaci ovde

Ovako nekako

[ATTACH]3234.IPB[/ATTACH]

evo uradio

Mogao si da razvučeš malo taj terminal da bude preglednije :smiley:

[SIZE=24px]Svejedno…u /etc/apt/sources.list.d/ikarosdev-unity-revamped-saucy.list imaš jednu liniju viška, koja je bez deb prefiksa, i ona ti pravi problem[/SIZE]

[ATTACH]3238.IPB[/ATTACH]

Otvori taj fajl sa

sudo gedit

obriši tu liniju viška, pa sačuvaj fajl, i posle toga odradi standardno

sudo apt-get update

opet neće

Majko mila… :connie_pumpkinsmile:

Koji text editor imaš instaliran kod sebe? ako nemaš gedit, upotrebi onaj koji imaš…ja ne mogu znati šta sve imaš ili nemaš instalirano u tvom Mintu…

imam pluma i evo šta sam dobio kada sam u terminal ukucao sudo pluma lanunchpad.net/

[ATTACH]3242.IPB[/ATTACH]

http://forum.opensource-srbija.org/topic/2472-update-manager-pomoć/?p=43036

sudo pluma /etc/apt/sources.list.d/ikarosdev-unity-revamped-saucy.list 

Drugar hvala na pomoći i na tvom vremenu ali vidim da se nerviraš i da te smaram svojim ne znanjem.Ovde ćemo prekinuti iako je problem polovično rešen.Još jednom hvala i svako dobro.

Da uspelo je ali sam morao da idem u update manager i da u ppa izbrišem sve ppa koje pokazuje kao eror.
Hvala još jednom