update mint-15

problem oko update mint-15

Failed to fetch copy:/var/lib/apt/lists/partial/packages.linuxmint.com_dists_olivia_import_binary-i386_Packages Hash Sum mismatch
Some index files failed to download. They have been ignored, or old ones used instead.

i ovo mi izbacuje :

E: Could not get lock /var/cache/apt/archives/lock - open (11: Resource temporarily unavailable)
E: Unable to lock directory /var/cache/apt/archives/

Probaj ovo
http://linuxg.net/unlock-the-apt-install-manager

hvala ti druze , dugujem pivo

[sredjeno]

isti problem imam. danas sam radio nekoliko puta update. ili mi izbaci ovu gresku, ili se nista ne desi. zakuca [ne komp, nego updater] drndao malo-vamo sa listom i sada sam jos u vecem problemu :frowning:

kada pokrenem synaptic, pojavi se na cas i nestane. kada radim u terminalu:

sudo apt-get update
samo me prebaci na sledecu praznu linuju za kucanje. nista se ne desi, kao da nisam ukucao komandu.

jedno pitanje:

sta vam stoji u:

/etc/apt/source.list

i

/etc/apt/sources.list.d/local-repository.list

Meni ništa.

izgleda da cu morati ponovo da reinstaliram mint.
ne radi mi apt-get i synaptic kada se pokrene - prsne.

================================================================

wow… kako sam se izbedacio…

formatiorao sam hdd krenuo da instaliram mint 15 mate. sve protekne kako treba, ali kada sam krenuo da update-ujem - mosa.

pojavi mi se ista greska kao i forumasu koji je postavio pitanje.

ovu liniju nemam

sudo rm /var/apt/lists/lock
ovu imam, ali nista se nije promenilo, i dalje mi prijavljuje gresku:

sudo rm /var/cache/apt/archives/lock

sudo apt-get update

[CODE]
Err http://packages.linuxmint.com olivia Release

Fetched 17,9 kB in 1min 10s (255 B/s)

Reading package lists… Done

W: A error occurred during the signature verification. The repository is not updated and the previous
index files will be used. GPG error: http://packages.linuxmint.com olivia Release:
The following signatures were invalid: NODATA 2

W: Failed to fetch http://packages.linuxmint.com/dists/olivia/Release

W: Some index files failed to download. They have been ignored, or old ones used instead.[/CODE]
image.jpg

Meni to deluje da je problem sa Mint-ovim serverom. Probaj da promenis na nas, Kragujevacki:
Update Manager -> Edit -> Software Sources -> Download from -> Oznaci link ispod “Serbia”
Apply pa probaj ponovo :slight_smile:

probao sam to medju prvim stvarima, ali i dalje je izbacivalo ovo. evo sta sam na kraju uradio [prilicno sam u konfuziji kako se ovo zapravo desilo sto cu da napisem, tj. sta je bio krajnji ishod]. file koji je nalazi na ovoj putanji:

/etc/apt/source.list.d/official-package-repositories.list
tu se nalazila linija [tacnije, dve linije] koja je pravila problem, i ja sam stavio # ispred tih linija kako bih mogao da uradim kakav-takav update [ostale stvari koje ukljucuju update, a nisu main].

kada sam postavio tarabu ispred linija koje su mi pravile problem, sacuvao sam podesavanja, i udario ponovo update - upgrade. uradio je nesto, tj. uradio je update, ja bih nazvao polovican. zasto kazem polovican… da je sve u redu, one linije koje prave problem bi uradile maksimalan update, tj. sve bih update-ovao na ovom sitemu, ovako mi se cini da je on pokupio update samo u slucaju broja 3. [oh… nadam se da znas o cemu pricam. pojave se u gui update-ru tri ona broja. npr. 1 je zut, 2 je orange, a 3 je green. valjda, nisam siguran oko boje] e, on je uradio samo trojku. 1 i 2 je preskocio verovatno zato sto sam stavio tarabu na one linije.

auuu… ala sam ga sada iskomplikovao… da li ti je nesto barem jasno iz ovoga?

medjutim… ovde mi je konfuzija: kada se update zavrsio, restrat-ovao sam masinu i vratio se da vidim kako izgleda file koji se nalazi na onoj putanji, a tamo sam stavio tarabe [dve]. kada sam ga otvorio, linije gde je ispred trebalo da stoji # - nema ih!!! wtf!

tako da… zasita sam zbunjen.

edit:

iskreno, najsrecniji bih bio kada bih video kod drugih sta im stoji, tj. koje su sve linije ukljucene u tom file-u.

:10: Damn…
'Ajd daj ispis:

cat /etc/apt/source.list.d/official-package-repositories.list

cat: /etc/apt/source.list.d/official-package-repositories.list: No such file or directory
a, ipak se nalazi tamo… tj. taj fajl postoji na toj putanji.

edit:

morao sam rucno da ga otvorim:

[CODE]deb http://mirror.pmf.kg.ac.rs/mint/packages.linuxmint.com/ olivia main upstream import

deb http://mirrors.liquidweb.com/ubuntu/ raring main restricted universe multiverse
deb http://mirrors.liquidweb.com/ubuntu/ raring-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ raring-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ raring partner[/CODE]

:10: x2 :smiley:

Nemam trenutno Mint da proverim, ni slobodno particiju da ga instaliram, a ni mesta za Vbox ( glavni hdd mi na reklamaciji ) :sarcastic:

Nego, jer si probao u “mintsources” da ides na “Restore the default settings”? :slight_smile:

nisam probao. kako to da uradim?

edit:

izvinjavam se. i to sam uradio, sada kada sam pogledao, secam se da sam i to uradio.

Uff, “mintsources” ti je zapravo ono sto je “Software Sources” bio u verzijama pre 15-ice.
Uglavnom bi trebalo da postoji u meniju, ili kao Mint Sources ili kao Software Sources. Ako nema, onda:
Update Manager -> Edit -> Software Sources :slight_smile:

bio sam editovao post u medjuvremenu. nego… razmisljam se da nije do samog iso file-a? razmisljam ponovo da skinem iso i da ga stavim na usb. tj. da ponovo pokrenem instalaciju.

Probaj ovako, napravi backup od /etc/apt/source.list.d/official-package-repositories.list
pa otvori official-package-repositories.list u tekst editor-u
i edituj da izgleda ovako:

deb http://packages.linuxmint.com olivia main upstream import #id:linuxmint_main

deb http://mirrors.liquidweb.com/ubuntu/ raring main restricted universe multiverse
deb http://mirrors.liquidweb.com/ubuntu/ raring-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ raring-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ raring partner
:slight_smile:

EDIT:
Ova linija mi izgleda malo :connie_crazyperson:
"deb http://mirror.pmf.kg.ac.rs/mint/packages.linuxmint.com/ olivia main upstream import "
:smiley:

pa, zanimljivo je ako procitas predhodne postove koje sam pisao, da su mnoge linije bile malo vise :connie_crazyperson: :smiley: btw. nisam nista ubacivao naknadno. kada sam instalirao mint, krenuo sam da update-ujem sa onim gui programom, i tada je krenulo jako fino :smiley:

sa ovom tvojom postavkom je sasvim ok. tj. izmenio sam [COLOR=rgb(40,40,40)]official[COLOR=rgb(40,40,40)]-[COLOR=rgb(40,40,40)]package[COLOR=rgb(40,40,40)]-[COLOR=rgb(40,40,40)]repositories[COLOR=rgb(40,40,40)].[COLOR=rgb(40,40,40)]list sa ovom, tvojom prvom linijom. udario sam update-upgrade prego gui-a i nasao je 1 update. sve je proslo kako treba.

Si si, nego ona je prva koju sam zapravo video celu, pa… :biggrin:
Negde usput se poremetio nekako…
Kako god, bitno da je sad ok. :slight_smile: :drinks:

cekaj, znaci sada imam adekvatnu listu? sav update ce biti uredjen?

i sto mi ne radi ona komanda cat? sada sam ponovo pokusao i dalje mi izbacuje da nema nikakvog fajla tamo :frowning:

Trebalo bi da je to to… Provericu kasnije na drugom kompu, nemam vremena sad da skidam/przim ISO.
@cat
'ebem li ga, probaj nesto drugo, na primer:

cat /etc/fstab

:slight_smile:

nemoj da se mucis. tj. ne moras da probas na drugoj masini. videcu kako ovo sljaka.

cat /etc/fstab

ovo cita