Update sa mint 15 na mint 16

Zdravo svima

Interesuje me na koji nacin bih mogao da najbezbednije nadogradim linux sa verzije 15 na verziju 16. Video sam neka uputstva po netu ali nisam siguran da li su 100% bezbedna. Tacnije nakon nadogradnje bih hteo (ako je moguce) da se zadrzi sve osim verzije linuxa :slight_smile:

Imate li neki predlog ?

EDIT: provalio sam da sam temu otvorio na pogresnom mestu, jer nije problem da se prebaci…

Jel si probao sa komandom:

sudo apt-get dist-upgrade

…to bi trebalo da ti uradi ono što želiš, da apgrejduje sistem a zadrži apsolutno sve na računaru kako je bilo do tada.

Ok probacu sada, hvala na brzom odgovoru :slight_smile:

Nema na čemu :wink:

Ali ne zaboravi prethodno da uradiš

sudo apt-get update

Evo odradio sam, ali izgleda da imam neki problem, bar tako kaze u terminalu.

Err http://ppa.launchpad.net raring/main Sources
404 Not Found
Err http://ppa.launchpad.net raring/main amd64 Packages
404 Not Found
Err http://ppa.launchpad.net raring/main i386 Packages
404 Not Found
Ign http://ppa.launchpad.net raring/main Translation-en_US
Ign http://ppa.launchpad.net raring/main Translation-en
Ign http://ppa.launchpad.net raring/main Translation-en_US
Ign http://ppa.launchpad.net raring/main Translation-en
Err http://ppa.launchpad.net raring/main Sources
404 Not Found
Err http://ppa.launchpad.net raring/main amd64 Packages
404 Not Found
Err http://ppa.launchpad.net raring/main i386 Packages
404 Not Found
W: Failed to fetch http://ppa.launchpad.net/conkyhardcore/ppa/ubuntu/dists/raring/main/source/Sources 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/conkyhardcore/ppa/ubuntu/dists/raring/main/binary-amd64/Packages 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/conkyhardcore/ppa/ubuntu/dists/raring/main/binary-i386/Packages 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/ferramroberto/gimp/ubuntu/dists/raring/main/source/Sources 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/ferramroberto/gimp/ubuntu/dists/raring/main/binary-amd64/Packages 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/ferramroberto/gimp/ubuntu/dists/raring/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
[email protected] ~ $ sudo apt-get dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected] ~ $ ^C
[email protected] ~ $

Ajde baci ovde ispis:

sudo gedit /etc/apt/sources.list

Evo ubacio sam ovako nesto nisam mogao da nakacim onaj obican txt fajl.

Ok nisi dao ispis sources.list nego si okačio komandu apt-get update, ali nema veze video sam i kroz ovo samo na teži način :slight_smile:

Odradi ovo, izvršavaj komadnu jednu za drugom:

sudo sed -i ‘s/raring/saucy/’ /etc/apt/sources.list.d/official-package-repositories.list

sudo sed -i 's/olivia/petra/' /etc/apt/sources.list.d/official-package-repositories.list

Ove ^^ gore komande će ti zameniti sources.list i napraviti sources.list.d odakle ćeš vući Linux Mint 16

Kada si to uradio onda izvrši ovo:

sudo apt-get update && sudo apt-get dist-upgrade

sudo apt-get upgrade

I zadnja komanda za restart računara, da bi po podizanju ušao u Linux Mint 16

sudo shutdown -r now

Ajde pa javi šta si uradio.

Ne brini komande su potpuno bezbedne.

Ok evo sad sam probao.

Kad odkucam prve dve komande sve je ok, kad nastavim dalje sa

sudo apt-get update && sudo apt-get dist-upgrade

onda dobijem sledece

[email protected] ~ $ sudo apt-get update
E: Type ‘[email protected]’ is not known on line 3 in source list /etc/apt/sources.list
E: The list of sources could not be read.
[email protected] ~ $ sudo apt-get dist-upgrade
Reading package lists… Error!
E: Type ‘[email protected]’ is not known on line 3 in source list /etc/apt/sources.list
E: The list of sources could not be read.
E: The package lists or status file could not be parsed or opened.

Obriši sve što se nalazi u /etc/apt/sources.list

Pa probaj ponovo sa update-om…

Odradio sam i to ali opet me nesto zeza. Obrisao sam te liste iz foldera ali nesto zeza. Jer ne treba nekako drugacije da pristupim terminalu ?

Čekaj jel si ti imao Mint 14 pa ga upgredovao na mint 15 i sada hoćeš na 16 ili si instalirao svežu 15-icu i sada hoćeš na 16-icu?

Da ranije sam imao 14, ali sam posle reinstalirao sistem na mint 15. E sad d ane bi to opet radio mislio sam da updejtujem na 16.

Nisi me razumeo, bitno je ovo što te pitam.

Da li si posle uradio svežu instalaciju 15-ice ili ti je to nadograđena 14-ica?

Da da, sveza instalacija je radjena na mint 15

Ok onda… jer se strukture razlikuju u repoima drugačije su putanje, samo mi onda nije jasno kako ti nije htela prva komanda da radi jer mora da radi, ja sam sad proverio u VB-u kod mene na 15-ici.

Mozda sam ja nesto zeznuo od ranije pa sad imam posledice…

Ajde ovako…

sudo gedit /etc/apt/sources.list

Tu upiši ove podatke:

deb http://packages.linuxmint.com/ petra main upstream import
deb http://archive.ubuntu.com/ubuntu/ saucy main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ saucy-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ saucy-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ saucy partner

deb http://archive.getdeb.net/ubuntu saucy-getdeb apps games

Odradi

sudo apt-get update && sudo apt-get dist-upgrade

Javljam se posle instalacije izgeda da sad radi :slight_smile:

Ovo je malo “pogrešan” način da se uradi upgrade ali verovatno je nešto od ranije bilo zbrljano na sistemu a da nebi tražili dlaku u jajetu bitnije je da se “problem” reši.

Ovo “pogrešan” način ne znači da ne valja već samo da bi trebalo da se upgrade uradi na drugi način to je to…