USB problem

Naime, USB mi se srusio. Napravio sam live USB sa elementary OS-om i kada sam ga hteo formatirati poceo je izbacivati gresku kao da ne moze kreirati novi partition table. Pokusao preko Terminala i GParted-a, na Windowsu klasicno i preko Command Promta, skinuo nekoliko aplikacija sa neta za formatiranje i nista, totalno je neupotrebljiv.

Ako je neko imao isti problem ili zna rjesenje neka mi javi. Hvala

Prvo, moraš koristeći dd da obrišeš prvih 1 MB sa fleša, jer se tamo nalaze particione tabele, identifikatori fajl sistema primarnih particija (heksadecimalni brojevi) i ostale kerefeke, koje prave problem gparted-u i fdisk-u ako ih ne ukloniš. Učini sledeće:

  • ubaci flešku u računar i demontiraj sve montirane particije
  • pomoću lsblk-a ili dmesg-a u terminalu vidi koje je tačno ime fleške (pr. /dev/sdb)
  • VAŽNO! PROVERI JOŠ JEDNOM KOJI JE UREĐAJ KAKO NE BI POGREŠIO I PREBRISAO HARD DISK!
  • u terminalu kao root (administrator) sledećom komandom prebrisaćeš prvih megabajt podataka sa uređaja nulama:

dd if=/dev/zero of=/dev/sdX bs=1M count=1

VAŽNO: Zameni X slovom koje predstavlja celu flešku, NE jednu njenu particiju! Znači na primer /dev/sdd, NE /dev/sdd1!
Sačekaj da se prebriše taj prvi megabajt, ukloni je sa USB porta i ponovo ubaci i onda napravi novu particionu tabelu sa Gparted-om ili fdisk-om, kako želiš. Ovo radi uvek nakon što flešku iskoristiš za lajv distribucije, kako se kernel ne bi bunio da je fleška read-only DVD zbog tog prvog megabajta na početku.

@ Dado Meni se to često događa kada napravim liveUSB. Svaki put sam to rešio na sledeći način. Ubacim USB, ali kada ubacim, umesto da se mount-uje jedan usb, meni se pojavi kao da su mount-ovana dva usb-a. Otkačiš sa računara prvo onaj deo fleške koji je manji, otprilike je nekoliko MB, pa onda otkačiš flešku, zatim obrišeš particionu tabelu u Gparted-u celog fleša, i napraviš novu. Format i to je to. Proveri da li ti se pojave dva uređaja kada ubaciš fleš. Ako da, onda ovaj postupak verovatno može da ti sredi to. Ako neće onda uradi ovo što je napisao @bjornoslav

@ubuntuser Ne pojavljuju se 2 USB-a tako da to otpada, hvala u svakom slucaju.

@bjornoslav Ovo sve odradim i kad pokrenem GParted i podesim sve za formatiranje, tokom tog procesa mi opet javi greske:

GParted 0.16.1 --enable-libparted-dmraid
Libparted 2.3

			[B]Delete /dev/sdb1 (fat32, 7.45 GiB) from /dev/sdb[/B]  00:00:18    ( ERROR )
	
			    
		
			
							calibrate /dev/sdb1  00:00:00    ( SUCCESS )
					
							    
						
							
											[I]path: /dev/sdb1

start: 2048
end: 15635408
size: 15633361 (7.45 GiB)[/I]

							delete partition  00:00:18    ( ERROR )
					
							libparted messages    ( INFO )
					
							    
						
							
											[I]Input/output error during write on /dev/sdb[/I]
									
											[I]Error fsyncing/closing /dev/sdb: Input/output error[/I]
									
											[I]Error opening /dev/sdb: No such file or directory[/I]
									
					
	========================================

@ Dado Ma nema potrebe da se zahvaljuješ, samo da mi rešimo taj problem.:slight_smile: A pogledaj da li ti se pojave dva fleša kada probaš u Gpartedu da formatiraš fleš…? Meni nekada odmah se pojave dva fleša, a nekada kada pokušam da formatiram prijavi kao da ima dva fleša…

tj. prati u file manageru šta se dešava sa flešom dok radiš u Gparted-u…

Ovo mi je sumljivo:

Input/output error during write on /dev/sdb
Error fsyncing/closing /dev/sdb: Input/output error
Error opening /dev/sdb: No such file or directory

Ukoliko flešku vezuješ na desktop računar, osiguraj se da to bude na portovima nazad na kućištu, oni dobijaju više struje, i da ukloniš sve nepotrebne uređaje sa USB portova (sem tastature i miša). Proveri da nije oštećen USB konektor na flešci ili da su kontakti unutra prljavi (očisti štapićima za uši ili nekom veoma tankom krpom, izribaj alkoholom i ostavi da se suši).
Moguće je da je čip na flešci otišao pa da se gasi usred rada. Šta kaže “dmesg” u vezi fleške kada je povežeš na sistem i kada dođe do kraha libparted biblioteke prilikom particionisanja?

dmesg kaze sledece:

[ 2.152421] [] do_one_initcall+0xfa/0x1b0
[ 2.152425] [] ? set_memory_nx+0x43/0x50
[ 2.152429] [] load_module+0x12b2/0x1b80
[ 2.152433] [] ? store_uevent+0x40/0x40
[ 2.152437] [] SyS_init_module+0xa2/0xf0
[ 2.152441] [] system_call_fastpath+0x1a/0x1f
[ 2.152443] —[ end trace 2e598cf666f47ede ]—
[ 2.237676] fbcon: inteldrmfb (fb0) is primary device
[ 2.724086] Console: switching to colour frame buffer device 170x48
[ 2.727384] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[ 2.727386] i915 0000:00:02.0: registered panic notifier
[ 2.729964] acpi device:0b: registered as cooling_device2
[ 2.730059] ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)
[ 2.730152] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:01/input/input4
[ 2.730267] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[ 2.912073] [drm:intel_pipe_config_compare] ERROR mismatch in adjusted_mode.flags (expected 2, found 0)
[ 2.912078] ------------[ cut here ]------------
[ 2.912099] WARNING: CPU: 0 PID: 182 at /build/buildd/linux-3.11.0/drivers/gpu/drm/i915/intel_display.c:8292 check_crtc_state+0x58f/0x9c0 i915
[ 2.912100] pipe state doesn’t match!
[ 2.912102] Modules linked in: i915 r8169 i2c_algo_bit drm_kms_helper mii(F) drm video(F)
[ 2.912113] CPU: 0 PID: 182 Comm: plymouthd Tainted: GF W 3.11.0-12-generic #19-Ubuntu
[ 2.912115] Hardware name: TOSHIBA Satellite L500/KSWAA, BIOS V1.10 05/18/2009
[ 2.912117] 0000000000000009 ffff880035c49710 ffffffff816e547a ffff880035c49758
[ 2.912121] ffff880035c49748 ffffffff81061dbd ffff8800b27616d0 0000000000000001
[ 2.912124] ffff880035cc9000 ffff8800b2761000 ffff880035cc9478 ffff880035c497a8
[ 2.912127] Call Trace:
[ 2.912135] [] dump_stack+0x45/0x56
[ 2.912140] [] warn_slowpath_common+0x7d/0xa0
[ 2.912143] [] warn_slowpath_fmt+0x4c/0x50
[ 2.912157] [] check_crtc_state+0x58f/0x9c0 [i915]
[ 2.912173] [] intel_modeset_check_state+0x2c3/0x770 [i915]
[ 2.912187] [] intel_set_mode+0x25/0x30 [i915]
[ 2.912202] [] intel_get_load_detect_pipe+0x253/0x410 [i915]
[ 2.912219] [] intel_tv_detect+0x100/0x490 [i915]
[ 2.912226] [] drm_helper_probe_single_connector_modes+0x1d3/0x380 [drm_kms_helper]
[ 2.912242] [] drm_mode_getconnector+0x3e6/0x440 [drm]
[ 2.912246] [] ? page_add_new_anon_rmap+0x91/0x130
[ 2.912255] [] drm_ioctl+0x532/0x660 [drm]
[ 2.912261] [] ? do_mmap_pgoff+0x305/0x3c0
[ 2.912265] [] do_vfs_ioctl+0x2e5/0x4d0
[ 2.912269] [] SyS_ioctl+0x81/0xa0
[ 2.912272] [] system_call_fastpath+0x1a/0x1f
[ 2.912274] —[ end trace 2e598cf666f47edf ]—
[ 3.036074] [drm:intel_pipe_config_compare] ERROR mismatch in adjusted_mode.flags (expected 2, found 0)
[ 3.036078] ------------[ cut here ]------------
[ 3.036099] WARNING: CPU: 0 PID: 182 at /build/buildd/linux-3.11.0/drivers/gpu/drm/i915/intel_display.c:8292 check_crtc_state+0x58f/0x9c0 i915
[ 3.036101] pipe state doesn’t match!
[ 3.036102] Modules linked in: i915 r8169 i2c_algo_bit drm_kms_helper mii(F) drm video(F)
[ 3.036112] CPU: 0 PID: 182 Comm: plymouthd Tainted: GF W 3.11.0-12-generic #19-Ubuntu
[ 3.036114] Hardware name: TOSHIBA Satellite L500/KSWAA, BIOS V1.10 05/18/2009
[ 3.036116] 0000000000000009 ffff880035c49710 ffffffff816e547a ffff880035c49758
[ 3.036119] ffff880035c49748 ffffffff81061dbd ffff8800b27616d0 0000000000000001
[ 3.036122] ffff880035cc9000 ffff8800b2761000 ffff880035cc9478 ffff880035c497a8
[ 3.036126] Call Trace:
[ 3.036133] [] dump_stack+0x45/0x56
[ 3.036138] [] warn_slowpath_common+0x7d/0xa0
[ 3.036141] [] warn_slowpath_fmt+0x4c/0x50
[ 3.036154] [] check_crtc_state+0x58f/0x9c0 [i915]
[ 3.036170] [] intel_modeset_check_state+0x2c3/0x770 [i915]
[ 3.036185] [] intel_set_mode+0x25/0x30 [i915]
[ 3.036199] [] intel_get_load_detect_pipe+0x253/0x410 [i915]
[ 3.036217] [] intel_tv_detect+0x100/0x490 [i915]
[ 3.036223] [] drm_helper_probe_single_connector_modes+0x1d3/0x380 [drm_kms_helper]
[ 3.036239] [] drm_mode_getconnector+0x3e6/0x440 [drm]
[ 3.036249] [] drm_ioctl+0x532/0x660 [drm]
[ 3.036253] [] ? mntput_no_expire+0x100/0x150
[ 3.036258] [] do_vfs_ioctl+0x2e5/0x4d0
[ 3.036262] [] ? ____fput+0xe/0x10
[ 3.036265] [] ? task_work_run+0xac/0xe0
[ 3.036269] [] SyS_ioctl+0x81/0xa0
[ 3.036273] [] system_call_fastpath+0x1a/0x1f
[ 3.036275] —[ end trace 2e598cf666f47ee0 ]—
[ 3.385751] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[ 16.393715] Adding 2096672k swap on /dev/sda2. Priority:-1 extents:1 across:2096672k FS
[ 16.488181] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 16.554371] systemd-udevd[348]: starting version 204
[ 16.689453] lp: driver loaded but no devices found
[ 16.801445] wmi: Mapper loaded
[ 16.812258] toshiba_acpi: Toshiba Laptop ACPI Extras version 0.19
[ 16.812340] input: Toshiba input device as /devices/virtual/input/input5
[ 16.870638] ACPI Warning: 0x0000000000000428-0x000000000000042f SystemIO conflicts with Region \PMIO 1 (20130517/utaddress-251)
[ 16.870647] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 16.870652] ACPI Warning: 0x00000000000011b0-0x00000000000011bf SystemIO conflicts with Region \GPIO 1 (20130517/utaddress-251)
[ 16.870657] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 16.870659] ACPI Warning: 0x0000000000001180-0x00000000000011af SystemIO conflicts with Region \GPIO 1 (20130517/utaddress-251)
[ 16.870663] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 16.870665] lpc_ich: Resource conflict(s) found affecting gpio_ich
[ 16.885371] cfg80211: Calling CRDA to update world regulatory domain
[ 16.939074] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[ 17.003746] lib80211: common routines for IEEE802.11 drivers
[ 17.003824] lib80211_crypt: registered algorithm ‘NULL’
[ 17.007762] microcode: CPU0 sig=0x1067a, pf=0x80, revision=0xa07
[ 17.014158] rtllib: module is from the staging directory, the quality is unknown, you have been warned.
[ 17.027658] r8192e_pci: module is from the staging directory, the quality is unknown, you have been warned.
[ 17.029200]
[ 17.029200] Linux kernel driver for RTL8192E WLAN cards
[ 17.029206] Copyright © 2007-2008, Realsil Wlan Driver
[ 17.029626] Memory mapped space start: 0xf2200000
[ 17.125203] device-mapper: multipath: version 1.5.1 loaded
[ 17.131727] snd_hda_intel 0000:00:1b.0: irq 46 for MSI/MSI-X
[ 17.152860] SKU: Nid=0x1d sku_cfg=0x40178e2d
[ 17.152864] SKU: port_connectivity=0x1
[ 17.152866] SKU: enable_pcbeep=0x1
[ 17.152867] SKU: check_sum=0x00000007
[ 17.152869] SKU: customization=0x0000008e
[ 17.152871] SKU: external_amp=0x5
[ 17.152872] SKU: platform_type=0x1
[ 17.152874] SKU: swap=0x0
[ 17.152875] SKU: override=0x1
[ 17.153065] autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[ 17.153067] speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 17.153069] hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[ 17.153071] mono: mono_out=0x0
[ 17.153072] inputs:
[ 17.153074] Internal Mic=0x19
[ 17.153076] Mic=0x18
[ 17.153078] realtek: No valid SSID, checking pincfg 0x40178e2d for NID 0x1d
[ 17.153080] realtek: Enabling init ASM_ID=0x8e2d CODEC_ID=10ec0272
[ 17.166634] autoconfig: line_outs=0 (0x0/0x0/0x0/0x0/0x0) type:line
[ 17.166639] speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 17.166641] hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 17.166643] mono: mono_out=0x0
[ 17.166644] inputs:
[ 17.171786] input: HDA Intel Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input6
[ 17.171974] input: HDA Intel Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7
[ 17.179526] Linux video capture interface: v2.00
[ 17.196330] uvcvideo: Found UVC 1.00 device (05ca:1804)
[ 17.206172] input: UVC Camera (05ca:1804) as /devices/pci0000:00/0000:00:1a.7/usb1/1-6/1-6:1.0/input/input8
[ 17.209089] usbcore: registered new interface driver uvcvideo
[ 17.209094] USB Video Class driver (1.1.1)
[ 17.758049] microcode: CPU1 sig=0x1067a, pf=0x80, revision=0xa07
[ 17.783997] microcode: Microcode Update Driver: v2.00 , Peter Oruba
[ 17.881340] cfg80211: World regulatory domain updated:
[ 17.881345] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 17.881348] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 17.881350] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 17.881353] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 17.881355] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 17.881357] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 18.072642] EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null)
[ 19.110591] psmouse serio1: synaptics: Touchpad model: 1, fw: 7.0, id: 0x1c0b1, caps: 0xd04711/0xa00000/0x20000, board id: 3655, fw id: 502560
[ 19.110598] psmouse serio1: synaptics: Toshiba Satellite L500 detected, limiting rate to 40pps.
[ 19.280072] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input9
[ 19.520468] init: failsafe main process (661) killed by TERM signal
[ 20.203533] Bluetooth: Core ver 2.16
[ 20.203606] NET: Registered protocol family 31
[ 20.203609] Bluetooth: HCI device and connection manager initialized
[ 20.204625] Bluetooth: HCI socket layer initialized
[ 20.204632] Bluetooth: L2CAP socket layer initialized
[ 20.204645] Bluetooth: SCO socket layer initialized
[ 20.209958] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 20.209963] Bluetooth: BNEP filters: protocol multicast
[ 20.209974] Bluetooth: BNEP socket layer initialized
[ 20.211225] Bluetooth: RFCOMM TTY layer initialized
[ 20.211248] Bluetooth: RFCOMM socket layer initialized
[ 20.211250] Bluetooth: RFCOMM ver 1.11
[ 20.651197] init: avahi-cups-reload main process (768) terminated with status 1
[ 20.718185] ppdev: user-space parallel port driver
[ 22.509482] r8169 0000:0e:00.0 eth0: link down
[ 22.509530] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 22.509881] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 23.583994] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 23.584388] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 23.587262] init: smbd main process (647) killed by HUP signal
[ 23.587300] init: smbd main process ended, respawning
[ 24.744022] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 25.836149] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 26.461673] vboxdrv: Found 2 processor cores.
[ 26.472082] vboxdrv: fAsync=0 offMin=0x1e0 offMax=0x668
[ 26.472192] vboxdrv: TSC mode is ‘synchronous’, kernel timer mode is ‘normal’.
[ 26.472194] vboxdrv: Successfully loaded version 4.3.10 (interface 0x001a0007).
[ 26.699443] vboxpci: IOMMU not found (not registered)
[ 27.104432] init: plymouth-stop pre-start process (1420) terminated with status 1
[ 28.536093] [drm:intel_pipe_config_compare] ERROR mismatch in adjusted_mode.flags (expected 2, found 0)
[ 28.536100] ------------[ cut here ]------------
[ 28.536141] WARNING: CPU: 0 PID: 1339 at /build/buildd/linux-3.11.0/drivers/gpu/drm/i915/intel_display.c:8292 check_crtc_state+0x58f/0x9c0 i915
[ 28.536143] pipe state doesn’t match!
[ 28.536145] Modules linked in: pci_stub vboxpci(OF) vboxnetadp(OF) vboxnetflt(OF) vboxdrv(OF) parport_pc(F) ppdev(F) rfcomm bnep bluetooth binfmt_misc(F) joydev(F) coretemp uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep(F) snd_pcm(F) dm_multipath(F) scsi_dh(F) snd_page_alloc(F) snd_seq_midi(F) snd_seq_midi_event(F) r8192e_pci© snd_rawmidi(F) rtllib© microcode(F) lib80211 rtl8192se rtl_pci rtlwifi snd_seq(F) psmouse(F) serio_raw(F) snd_seq_device(F) mac80211 snd_timer(F) lpc_ich cfg80211 snd(F) soundcore(F) toshiba_acpi sparse_keymap wmi mac_hid lp(F) parport(F) dm_mirror(F) dm_region_hash(F) dm_log(F) i915 r8169 i2c_algo_bit drm_kms_helper mii(F) drm video(F)
[ 28.536193] CPU: 0 PID: 1339 Comm: Xorg Tainted: GF WC O 3.11.0-12-generic #19-Ubuntu
[ 28.536195] Hardware name: TOSHIBA Satellite L500/KSWAA, BIOS V1.10 05/18/2009
[ 28.536197] 0000000000000009 ffff8800ae095710 ffffffff816e547a ffff8800ae095758
[ 28.536201] ffff8800ae095748 ffffffff81061dbd ffff8800b27616d0 0000000000000001
[ 28.536205] ffff880035cc9000 ffff8800b2761000 ffff880035cc9478 ffff8800ae0957a8
[ 28.536208] Call Trace:
[ 28.536216] [] dump_stack+0x45/0x56
[ 28.536223] [] warn_slowpath_common+0x7d/0xa0
[ 28.536226] [] warn_slowpath_fmt+0x4c/0x50
[ 28.536243] [] check_crtc_state+0x58f/0x9c0 [i915]
[ 28.536261] [] intel_modeset_check_state+0x2c3/0x770 [i915]
[ 28.536277] [] intel_set_mode+0x25/0x30 [i915]
[ 28.536294] [] intel_get_load_detect_pipe+0x253/0x410 [i915]
[ 28.536316] [] intel_tv_detect+0x100/0x490 [i915]
[ 28.536325] [] drm_helper_probe_single_connector_modes+0x1d3/0x380 [drm_kms_helper]
[ 28.536348] [] drm_mode_getconnector+0x3e6/0x440 [drm]
[ 28.536359] [] drm_ioctl+0x532/0x660 [drm]
[ 28.536366] [] do_vfs_ioctl+0x2e5/0x4d0
[ 28.536371] [] ? __sb_end_write+0x31/0x60
[ 28.536374] [] ? vfs_write+0x172/0x1e0
[ 28.536378] [] SyS_ioctl+0x81/0xa0
[ 28.536382] [] system_call_fastpath+0x1a/0x1f
[ 28.536385] —[ end trace 2e598cf666f47ee1 ]—
[ 28.964058] [drm:intel_pipe_config_compare] ERROR mismatch in adjusted_mode.flags (expected 2, found 0)
[ 28.964063] ------------[ cut here ]------------
[ 28.964096] WARNING: CPU: 1 PID: 1569 at /build/buildd/linux-3.11.0/drivers/gpu/drm/i915/intel_display.c:8292 check_crtc_state+0x58f/0x9c0 i915
[ 28.964097] pipe state doesn’t match!
[ 28.964099] Modules linked in: pci_stub vboxpci(OF) vboxnetadp(OF) vboxnetflt(OF) vboxdrv(OF) parport_pc(F) ppdev(F) rfcomm bnep bluetooth binfmt_misc(F) joydev(F) coretemp uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep(F) snd_pcm(F) dm_multipath(F) scsi_dh(F) snd_page_alloc(F) snd_seq_midi(F) snd_seq_midi_event(F) r8192e_pci© snd_rawmidi(F) rtllib© microcode(F) lib80211 rtl8192se rtl_pci rtlwifi snd_seq(F) psmouse(F) serio_raw(F) snd_seq_device(F) mac80211 snd_timer(F) lpc_ich cfg80211 snd(F) soundcore(F) toshiba_acpi sparse_keymap wmi mac_hid lp(F) parport(F) dm_mirror(F) dm_region_hash(F) dm_log(F) i915 r8169 i2c_algo_bit drm_kms_helper mii(F) drm video(F)
[ 28.964147] CPU: 1 PID: 1569 Comm: upowerd Tainted: GF WC O 3.11.0-12-generic #19-Ubuntu
[ 28.964148] Hardware name: TOSHIBA Satellite L500/KSWAA, BIOS V1.10 05/18/2009
[ 28.964150] 0000000000000009 ffff8800ae60b8d0 ffffffff816e547a ffff8800ae60b918
[ 28.964154] ffff8800ae60b908 ffffffff81061dbd ffff8800b27616d0 0000000000000001
[ 28.964158] ffff880035cc9000 ffff8800b2761000 ffff880035cc9478 ffff8800ae60b968
[ 28.964161] Call Trace:
[ 28.964168] [] dump_stack+0x45/0x56
[ 28.964173] [] warn_slowpath_common+0x7d/0xa0
[ 28.964176] [] warn_slowpath_fmt+0x4c/0x50
[ 28.964192] [] check_crtc_state+0x58f/0x9c0 [i915]
[ 28.964210] [] intel_modeset_check_state+0x2c3/0x770 [i915]
[ 28.964226] [] intel_set_mode+0x25/0x30 [i915]
[ 28.964243] [] intel_get_load_detect_pipe+0x253/0x410 [i915]
[ 28.964263] [] intel_tv_detect+0x100/0x490 [i915]
[ 28.964283] [] status_show+0x3b/0x80 [drm]
[ 28.964289] [] dev_attr_show+0x20/0x60
[ 28.964293] [] sysfs_read_file+0x9a/0x1a0
[ 28.964298] [] vfs_read+0x9e/0x170
[ 28.964301] [] SyS_read+0x49/0xa0
[ 28.964305] [] system_call_fastpath+0x1a/0x1f
[ 28.964307] —[ end trace 2e598cf666f47ee2 ]—
[ 30.599010] Linking with Colic,channel:5, qos:1, myHT:1, networkHT:0, mode:6 cur_net.flags:0x40e
[ 30.599023] Linking with Colic,channel:5, qos:1, myHT:1, networkHT:0, mode:6 cur_net.flags:0x40e
[ 30.599125] HTSetConnectBwMode():pHTInfo->bCurBW40MHz:0
[ 30.620983] Associated successfully
[ 30.620987] normal associate
[ 30.620995] Using G rates:108
[ 30.620997] Successfully associated, ht not enabled(0, 0)
[ 30.621147] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 30.622615] RX: IEEE802.1X EAPOL frame!
[ 30.628799] RX: IEEE802.1X EAPOL frame!
[ 30.628955] alg name:R-CCMP
[ 30.631764] rtllib_crypt_ccmp: module is from the staging directory, the quality is unknown, you have been warned.
[ 30.631987] lib80211_crypt: registered algorithm ‘R-CCMP’
[ 30.640359] RX: IEEE802.1X EAPOL frame!
[ 30.644102] [drm:intel_pipe_config_compare] ERROR mismatch in adjusted_mode.flags (expected 2, found 0)
[ 30.644107] ------------[ cut here ]------------
[ 30.644140] WARNING: CPU: 0 PID: 1339 at /build/buildd/linux-3.11.0/drivers/gpu/drm/i915/intel_display.c:8292 check_crtc_state+0x58f/0x9c0 i915
[ 30.644142] pipe state doesn’t match!
[ 30.644144] Modules linked in: rtllib_crypt_ccmp© pci_stub vboxpci(OF) vboxnetadp(OF) vboxnetflt(OF) vboxdrv(OF) parport_pc(F) ppdev(F) rfcomm bnep bluetooth binfmt_misc(F) joydev(F) coretemp uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep(F) snd_pcm(F) dm_multipath(F) scsi_dh(F) snd_page_alloc(F) snd_seq_midi(F) snd_seq_midi_event(F) r8192e_pci© snd_rawmidi(F) rtllib© microcode(F) lib80211 rtl8192se rtl_pci rtlwifi snd_seq(F) psmouse(F) serio_raw(F) snd_seq_device(F) mac80211 snd_timer(F) lpc_ich cfg80211 snd(F) soundcore(F) toshiba_acpi sparse_keymap wmi mac_hid lp(F) parport(F) dm_mirror(F) dm_region_hash(F) dm_log(F) i915 r8169 i2c_algo_bit drm_kms_helper mii(F) drm video(F)
[ 30.644190] CPU: 0 PID: 1339 Comm: Xorg Tainted: GF WC O 3.11.0-12-generic #19-Ubuntu
[ 30.644192] Hardware name: TOSHIBA Satellite L500/KSWAA, BIOS V1.10 05/18/2009
[ 30.644194] 0000000000000009 ffff8800ae095710 ffffffff816e547a ffff8800ae095758
[ 30.644197] ffff8800ae095748 ffffffff81061dbd ffff8800b27616d0 0000000000000001
[ 30.644201] ffff880035cc9000 ffff8800b2761000 ffff880035cc9478 ffff8800ae0957a8
[ 30.644204] Call Trace:
[ 30.644211] [] dump_stack+0x45/0x56
[ 30.644216] [] warn_slowpath_common+0x7d/0xa0
[ 30.644220] [] warn_slowpath_fmt+0x4c/0x50
[ 30.644236] [] check_crtc_state+0x58f/0x9c0 [i915]
[ 30.644253] [] intel_modeset_check_state+0x2c3/0x770 [i915]
[ 30.644269] [] intel_set_mode+0x25/0x30 [i915]
[ 30.644286] [] intel_get_load_detect_pipe+0x253/0x410 [i915]
[ 30.644307] [] intel_tv_detect+0x100/0x490 [i915]
[ 30.644316] [] drm_helper_probe_single_connector_modes+0x1d3/0x380 [drm_kms_helper]
[ 30.644336] [] drm_mode_getconnector+0x3e6/0x440 [drm]
[ 30.644341] [] ? inotify_handle_event+0x130/0x130
[ 30.644352] [] drm_ioctl+0x532/0x660 [drm]
[ 30.644359] [] do_vfs_ioctl+0x2e5/0x4d0
[ 30.644363] [] ? __sb_end_write+0x31/0x60
[ 30.644366] [] ? vfs_write+0x172/0x1e0
[ 30.644370] [] SyS_ioctl+0x81/0xa0
[ 30.644374] [] system_call_fastpath+0x1a/0x1f
[ 30.644376] —[ end trace 2e598cf666f47ee3 ]—
[ 30.645479] alg name:R-TKIP
[ 30.650783] rtllib_crypt_tkip: module is from the staging directory, the quality is unknown, you have been warned.
[ 30.651017] lib80211_crypt: registered algorithm ‘R-TKIP’
[ 31.060037] [drm:intel_pipe_config_compare] ERROR mismatch in adjusted_mode.flags (expected 2, found 0)
[ 31.060043] ------------[ cut here ]------------
[ 31.060075] WARNING: CPU: 0 PID: 1339 at /build/buildd/linux-3.11.0/drivers/gpu/drm/i915/intel_display.c:8292 check_crtc_state+0x58f/0x9c0 i915
[ 31.060078] pipe state doesn’t match!
[ 31.060079] Modules linked in: michael_mic(F) arc4(F) rtllib_crypt_tkip© rtllib_crypt_ccmp© pci_stub vboxpci(OF) vboxnetadp(OF) vboxnetflt(OF) vboxdrv(OF) parport_pc(F) ppdev(F) rfcomm bnep bluetooth binfmt_misc(F) joydev(F) coretemp uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep(F) snd_pcm(F) dm_multipath(F) scsi_dh(F) snd_page_alloc(F) snd_seq_midi(F) snd_seq_midi_event(F) r8192e_pci© snd_rawmidi(F) rtllib© microcode(F) lib80211 rtl8192se rtl_pci rtlwifi snd_seq(F) psmouse(F) serio_raw(F) snd_seq_device(F) mac80211 snd_timer(F) lpc_ich cfg80211 snd(F) soundcore(F) toshiba_acpi sparse_keymap wmi mac_hid lp(F) parport(F) dm_mirror(F) dm_region_hash(F) dm_log(F) i915 r8169 i2c_algo_bit drm_kms_helper mii(F) drm video(F)
[ 31.060128] CPU: 0 PID: 1339 Comm: Xorg Tainted: GF WC O 3.11.0-12-generic #19-Ubuntu
[ 31.060130] Hardware name: TOSHIBA Satellite L500/KSWAA, BIOS V1.10 05/18/2009
[ 31.060132] 0000000000000009 ffff8800ae095710 ffffffff816e547a ffff8800ae095758
[ 31.060136] ffff8800ae095748 ffffffff81061dbd ffff8800b27616d0 0000000000000001
[ 31.060139] ffff880035cc9000 ffff8800b2761000 ffff880035cc9478 ffff8800ae0957a8
[ 31.060143] Call Trace:
[ 31.060150] [] dump_stack+0x45/0x56
[ 31.060156] [] warn_slowpath_common+0x7d/0xa0
[ 31.060159] [] warn_slowpath_fmt+0x4c/0x50
[ 31.060175] [] check_crtc_state+0x58f/0x9c0 [i915]
[ 31.060194] [] intel_modeset_check_state+0x2c3/0x770 [i915]
[ 31.060210] [] intel_set_mode+0x25/0x30 [i915]
[ 31.060226] [] intel_get_load_detect_pipe+0x253/0x410 [i915]
[ 31.060247] [] intel_tv_detect+0x100/0x490 [i915]
[ 31.060256] [] drm_helper_probe_single_connector_modes+0x1d3/0x380 [drm_kms_helper]
[ 31.060275] [] drm_mode_getconnector+0x3e6/0x440 [drm]
[ 31.060286] [] drm_ioctl+0x532/0x660 [drm]
[ 31.060291] [] ? __set_task_blocked+0x32/0x70
[ 31.060297] [] do_vfs_ioctl+0x2e5/0x4d0
[ 31.060300] [] SyS_ioctl+0x81/0xa0
[ 31.060305] [] system_call_fastpath+0x1a/0x1f
[ 31.060307] —[ end trace 2e598cf666f47ee4 ]—
[ 31.844209] dm_check_edca_turbo():iot peer is unknown, bssid: 00:24:8c:53:aa:e6
[ 52.308067] [drm:intel_pipe_config_compare] ERROR mismatch in adjusted_mode.flags (expected 2, found 0)
[ 52.308073] ------------[ cut here ]------------
[ 52.308110] WARNING: CPU: 1 PID: 1339 at /build/buildd/linux-3.11.0/drivers/gpu/drm/i915/intel_display.c:8292 check_crtc_state+0x58f/0x9c0 i915
[ 52.308111] pipe state doesn’t match!
[ 52.308113] Modules linked in: michael_mic(F) arc4(F) rtllib_crypt_tkip© rtllib_crypt_ccmp© pci_stub vboxpci(OF) vboxnetadp(OF) vboxnetflt(OF) vboxdrv(OF) parport_pc(F) ppdev(F) rfcomm bnep bluetooth binfmt_misc(F) joydev(F) coretemp uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep(F) snd_pcm(F) dm_multipath(F) scsi_dh(F) snd_page_alloc(F) snd_seq_midi(F) snd_seq_midi_event(F) r8192e_pci© snd_rawmidi(F) rtllib© microcode(F) lib80211 rtl8192se rtl_pci rtlwifi snd_seq(F) psmouse(F) serio_raw(F) snd_seq_device(F) mac80211 snd_timer(F) lpc_ich cfg80211 snd(F) soundcore(F) toshiba_acpi sparse_keymap wmi mac_hid lp(F) parport(F) dm_mirror(F) dm_region_hash(F) dm_log(F) i915 r8169 i2c_algo_bit drm_kms_helper mii(F) drm video(F)
[ 52.308162] CPU: 1 PID: 1339 Comm: Xorg Tainted: GF WC O 3.11.0-12-generic #19-Ubuntu
[ 52.308164] Hardware name: TOSHIBA Satellite L500/KSWAA, BIOS V1.10 05/18/2009
[ 52.308166] 0000000000000009 ffff8800ae095710 ffffffff816e547a ffff8800ae095758
[ 52.308169] ffff8800ae095748 ffffffff81061dbd ffff8800b27616d0 0000000000000001
[ 52.308173] ffff880035cc9000 ffff8800b2761000 ffff880035cc9478 ffff8800ae0957a8
[ 52.308176] Call Trace:
[ 52.308183] [] dump_stack+0x45/0x56
[ 52.308188] [] warn_slowpath_common+0x7d/0xa0
[ 52.308191] [] warn_slowpath_fmt+0x4c/0x50
[ 52.308208] [] check_crtc_state+0x58f/0x9c0 [i915]
[ 52.308225] [] intel_modeset_check_state+0x2c3/0x770 [i915]
[ 52.308241] [] intel_set_mode+0x25/0x30 [i915]
[ 52.308258] [] intel_get_load_detect_pipe+0x253/0x410 [i915]
[ 52.308279] [] intel_tv_detect+0x100/0x490 [i915]
[ 52.308288] [] drm_helper_probe_single_connector_modes+0x1d3/0x380 [drm_kms_helper]
[ 52.308308] [] drm_mode_getconnector+0x3e6/0x440 [drm]
[ 52.308313] [] ? inotify_handle_event+0x130/0x130
[ 52.308324] [] drm_ioctl+0x532/0x660 [drm]
[ 52.308331] [] do_vfs_ioctl+0x2e5/0x4d0
[ 52.308335] [] ? __sb_end_write+0x31/0x60
[ 52.308339] [] ? vfs_write+0x172/0x1e0
[ 52.308342] [] SyS_ioctl+0x81/0xa0
[ 52.308346] [] system_call_fastpath+0x1a/0x1f
[ 52.308348] —[ end trace 2e598cf666f47ee5 ]—
[ 384.139453] systemd-timedated[3159]: /etc/localtime should be a symbolic link to a timezone data file in /usr/share/zoneinfo/.
[ 533.120381] perf samples too long (2509 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
[ 1315.924102] usb 2-1: new high-speed USB device number 2 using ehci-pci
[ 1316.060234] usb 2-1: New USB device found, idVendor=0951, idProduct=1642
[ 1316.060243] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1316.060247] usb 2-1: Product: DT 101 G2
[ 1316.060252] usb 2-1: Manufacturer: Kingston
[ 1316.060256] usb 2-1: SerialNumber: 001CC0EC345AFBA055EE2379
[ 1316.200835] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 1316.200944] scsi4 : usb-storage 2-1:1.0
[ 1316.201050] usbcore: registered new interface driver usb-storage
[ 1317.222054] scsi 4:0:0:0: Direct-Access Kingston DT 101 G2 1.00 PQ: 0 ANSI: 4
[ 1317.222961] sd 4:0:0:0: Attached scsi generic sg2 type 0
[ 1317.225104] sd 4:0:0:0: [sdb] 15638480 512-byte logical blocks: (8.00 GB/7.45 GiB)
[ 1317.225751] sd 4:0:0:0: [sdb] Write Protect is off
[ 1317.225760] sd 4:0:0:0: [sdb] Mode Sense: 45 00 00 00
[ 1317.226385] sd 4:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn’t support DPO or FUA
[ 1317.234155] sdb: sdb1
[ 1317.237414] sd 4:0:0:0: [sdb] Attached SCSI removable disk
[ 1317.589881] FAT-fs (sdb1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[ 1523.447786] JFS: nTxBlock = 8192, nTxLock = 65536
[ 1523.572731] SGI XFS with ACLs, security attributes, realtime, large block/inode numbers, no debug enabled

Provjeravao sam, dva se ne pojavljuju…to sa dva mi se desavalo kod openSUSE-a ali sam lako rijesavao…ne znam ima li veze ali kod mene nije u pitanju 1MB nego 1,5MB!

[ 1317.589881] FAT-fs (sdb1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

Kao sto kaze^, probaj da mu raspalis fsck:

fsck.vfat -r /dev/sdXY

:slight_smile:

Hehe…a kako??? :biggrin2: :biggrin2: :biggrin2:

Otvoris terminal i odkucas:

fsck.vfat -r /dev/sdXY

Naravno “/dev/sdXY” kucas shodno tome kako je flesh obelezen.
Izlistaj diskove sa “sudo blkid” pa ga nadji ( u ispisima gore je bio /dev/sdb1 ali se to menja, ne mora da znaci da je i dalje isto, zato obavezno proveri prvo )

Ne ide, to odradim i dobijem sledece:

dosfsck 3.0.16, 01 Mar 2013, FAT32, LFN
0x41: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.

  1. Remove dirty bit
  2. No action
    ? 1
    Perform changes ? (y/n) y
    /dev/sdb1: 18 files, 452142/1950356 clusters

USB se kao i ranije zasvijetli i ne gasi se, sta god od ovog sto su mi rekli ranije uradim ne ide…

'Ajd probaj sad:

sudo mkfs.vfat -F 32 /dev/sdXY

pa javi rezultate.

mkfs.vfat 3.0.16 (01 Mar 2013)
mkfs.vfat: /dev/sdb1 contains a mounted file system.

Moras prvo da ga otkacis sa:

sudo umount /dev/sdb1

Naravno pre toga jos jednom proveri da li je i dalje “sdb1”, pa onda ponovi:

sudo mkfs.vfat -F 32 /dev/sdXY

To sam radio i ranije medjutim svaki put mi izbaci ovu poruku:

mkfs.vfat 3.0.16 (01 Mar 2013)
/dev/sdb1: No such file or directory

Jednostavno sta god od ovih komandi da pokrenem sto ste mi ti i predhodnici napisali svaki put se desi isto, samo ga izbaci (unmount) i nista sa njim poslije ne mogu uraditi…
Nesto se skroz cudno desava sa njim, a skoro sam ga uzeo pa mi se ne kupuje novi…

'Ajd da probamo sa ext3 prvo…

Znaci, turis flesku, proveris opet da li je sdb1, pa redom:

sudo umount /dev/sdb1
sudo mkfs.ext3 /dev/sdb1
sudo mkfs.vfat -F 32 /dev/sdb1

Zdravo

@ Dado

Ako ti sve ovo ne pomogne
probaj iz repoa da instaliraš gpart ako ti nije instaliran pa probaj opet sa Gparted da odradiš ne format VEĆ brisanje fleša

GParted 0.16.1 --enable-libparted-dmraid
Libparted 2.3
Delete /dev/sdb1 (fat32, 7.45 GiB) from /dev/sdb 00:00:18 ( ERROR ) calibrate /dev/sdb1 00:00:00 ( SUCCESS ) path: /dev/sdb1
start: 2048
end: 15635408
size: 15633361 (7.45 GiB)
delete partition 00:00:18 ( ERROR ) libparted messages ( INFO ) Input/output error during write on /dev/sdb Error fsyncing/closing /dev/sdb: Input/output error Error opening /dev/sdb: No such file or directory

Gparted od ove verzije je podeljen na 2 dela Gparted i gpart koji se posebno instaliraju
meni je ovakvu grešku izbacilo baš na ovoj verziji kada sam hteo da uradim prost format fleša

Ubacicu par slika i pokusacu objasniti sta se sve desava:

  1. Ovo se nalazi na USB-u:

screenshot-from-2014-04-.jpg

  1. Sad se poceli pojavljivati dva drivea:

screenshot-from-2014-04-.jpg

  1. Ovaj drive desno se ne moze mount-ovati

screenshot-from-2014-04-.jpg

  1. U GPartedu se pokazuje sledece:

screenshot-from-2014-04-.jpg

  1. Svaki pokusaj brisanja ili bilo kakve druge “akcije” dovede do ovoga:

screenshot-from-2014-04-.jpg

  1. @Cofi kad odradim drugu komandu odradi svoje i odmah izbaci USB (opet zasvijetli i cuje se onaj zvuk kao kad ides na eject) i sve po starom:

screenshot-from-2014-04-.jpg

7: A kada izvadim i ponovo ubacim USB odradim trecu komandu i dobijem sledece:

screenshot-from-2014-04-.jpg

Na kraju je epilog opet sve kao i ranije, ima na njemu neki kao “bad sector” koji ne dozvoljava bilo kakvu radnju na USB-u, LIBGPARTED BUG FOUND-Could not stat device /dev/sdc - No such file or directory.
Ako bude bilo potrebno jos nesto javite…i hvala i na ovolikom trudu do sada…
@ MIKULINO Ne ide ovo…

@ Dado kada ti izbaci onu grešku u Gparted-u kao na slici 5, ništa ne diraj u Gparted-u, ostavi tako, idi tamo kao na slici 2 i otkači onaj deo fleške koji je počeo da se pojavljuje, desni klik i “eject”, pa zatim izbaci flešku istim postupkom, zatim se vrati u Gparted, klikni na “close” na onaj dijalog prozor o grešci, i formatiraj fleš. Ovoga puta bi trebalo da hoće…:slight_smile:

Nece da odradi eject, pokusavao sam te kombinacije i svaki put javi sledece Unable to eject location-Unable to find block device for drive. Jednostavno bilo sta da uradim automatski mi sam izbaci usb (unmount) i tako je sa svakim korakom koji preduzmem.

A sa druge strane uvijek pored primarnog dijela pokazuje na usb-u i 1,5MB unlocated dio. Kada zadam komandu brisanja u GPartedu, onda ih pokaze kao jedan medjutim poslije apply prekine brisanje i javi gresku:

GParted 0.16.1 --enable-libparted-dmraid
Libparted 2.3

			[B]Delete /dev/sdb1 (fat32, 7.45 GiB) from /dev/sdb[/B]  00:00:13    ( ERROR )
	
			    
		
			
							calibrate /dev/sdb1  00:00:00    ( SUCCESS )
					
							    
						
							
											[I]path: /dev/sdb1

start: 2048
end: 15635408
size: 15633361 (7.45 GiB)[/I]

							delete partition  00:00:13    ( ERROR )
					
							libparted messages    ( INFO )
					
							    
						
							
											[I]Input/output error during write on /dev/sdb[/I]
									
											[I]Error fsyncing/closing /dev/sdb: Input/output error[/I]
									
											[I]Error opening /dev/sdb: No such file or directory[/I]

U terminalu ista stvar, sta god od komandi pokrenem automatski odradi unmount i onda ponovo moram ubacivati usb da bih nastavio medjutim opet sve isto bude na kraju…

Koliko bi teamviewer pomogao ako je neko voljan!?