VPN podesavanje

Vec sam pitao na drugoj temi o zastiti privatnosti na internetu pa da tamo ne zatrpavam temu otvaram ovu. Pokusao sam da instaliram VPN Free VPN • 100% Free PPTP and OpenVPN Service i prema njihovom uputstvu za ubuntu sam radio i javlja mi problem kad dodjem do 4 koraka.

GuestGost mi je tamo napisao uputstvo kako da probam na drugi nacin ali kada uradim tako internet mi uopste ne radi dok ne restartujem kompjuter.
Moze li da bude problem sto idem na net preko modema i rutera, ili negdje drugo grijesim?

Moras da pratis njihov sajt, cesto menjaju password.
A kazi mi sta mislis pod “korak 4”, instalacija openvpn ili pokretanje!?

Edit: sad sam video da mislis na pokretanje openvpn-a, u uputstvu su izostavilli “sudo” pre naredbe “openvpn --config”

Evo kako kod mene glasi:
“sudo openvpn --config vpnbook-euro1-tcp80.ovpn”
Trazi ti prvo tvoj pass, pa username sa VPNBook sajta pa pass sa istog sajta

sad sam uradio sa ovom komandom koju si mi napisao i sve je proslo kako treba (moj pass, njihos username i pass) ali me ne pusta na net uopste i tek nakon restarta sam mogao ponovo ici na net.
ne pomaze mi da samo izadjem iz terminala ili da se ponovo konektujem, samo restart pomaze.

Uh, aj polako, ne hvatam :slight_smile:
Kada se konektujes, ne treba da gasis terminal tj ni ne smes da ga gasis ako hoces preko vpn da surfujes.
Kada hoces da prekines vpn dok si u terminalu pritisnes ctrl+c i posle mozda 10 sekundi ides preko svoje konekcije.
Tako je barem kod mene.

kad mi je otvoren terminal i sve u njemu uradjeno ne pusta me na net, a ni kad ga zatvorim ne radi mi net dok ne restartujem komp.

E onda stvarno ne znam.
Evo mene upravo preko istog tog, sve okej.

Sad sam pokusavao i da se spojim bez rutera samo preko modema i opet nece nesto, ne znam zasto.
Hvala ti u svakom slucaju. Ako hoces mogu ti poslati ispis iz terminala sta dobijem kad uradim sve ili da ga ovdje okacim.

Takođe potvrđujem da sve radi baš kako treba kada se povežem preko vpnbook-a. U pitanju je Linux Mint 17.2 Mate.

onda sam vjerovatno ja negdje pogrijesio. kojom naredbom bih mogao da deinstaliram pa da pokusam ponovo da instaliram?

Mislim da nista neces dobiti ako deinstaliras pa opet instaliras, jer u sustini samo je instaliran jedan paket “openvpn”.
Ne znam, ajd da vidimo sta ti pise u terminalu pa mozda dodjemo do nekog resenja.

Ovo je ispis o juce kada sam pokusavao da se tako konektujem

Wed Oct 28 22:19:51 2015 OpenVPN 2.3.2 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [eurephia] [MH] [IPv6] built on Dec 1 2014

Enter Auth Username:vpnbook

Enter Auth Password:

Wed Oct 28 22:20:57 2015 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.

Wed Oct 28 22:20:57 2015 NOTE: --fast-io is disabled since we are not using UDP

Wed Oct 28 22:20:57 2015 Socket Buffers: R=[87380->131072] S=[16384->131072]

Wed Oct 28 22:20:57 2015 Attempting to establish TCP connection with [AF_INET]176.126.237.217:80 [nonblock]

Wed Oct 28 22:20:58 2015 TCP connection established with [AF_INET]176.126.237.217:80

Wed Oct 28 22:20:58 2015 TCPv4_CLIENT link local: [undef]

Wed Oct 28 22:20:58 2015 TCPv4_CLIENT link remote: [AF_INET]176.126.237.217:80

Wed Oct 28 22:20:58 2015 TLS: Initial packet from [AF_INET]176.126.237.217:80, sid=27ff7575 11748d45

Wed Oct 28 22:20:58 2015 WARNING: this configuration may cache passwords in memory – use the auth-nocache option to prevent this

Wed Oct 28 22:20:59 2015 VERIFY OK: depth=1, C=CH, ST=Zurich, L=Zurich, O=vpnbook.com, OU=IT, CN=vpnbook.com, name=vpnbook.com, [email protected]

Wed Oct 28 22:20:59 2015 VERIFY OK: depth=0, C=CH, ST=Zurich, L=Zurich, O=vpnbook.com, OU=IT, CN=vpnbook.com, name=vpnbook.com, [email protected]

Wed Oct 28 22:21:00 2015 Data Channel Encrypt: Cipher ‘AES-128-CBC’ initialized with 128 bit key

Wed Oct 28 22:21:00 2015 Data Channel Encrypt: Using 160 bit message hash ‘SHA1’ for HMAC authentication

Wed Oct 28 22:21:00 2015 Data Channel Decrypt: Cipher ‘AES-128-CBC’ initialized with 128 bit key

Wed Oct 28 22:21:00 2015 Data Channel Decrypt: Using 160 bit message hash ‘SHA1’ for HMAC authentication

Wed Oct 28 22:21:00 2015 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA

Wed Oct 28 22:21:00 2015 [vpnbook.com] Peer Connection Initiated with [AF_INET]176.126.237.217:80

Wed Oct 28 22:21:03 2015 SENT CONTROL [vpnbook.com]: ‘PUSH_REQUEST’ (status=1)

Wed Oct 28 22:21:03 2015 PUSH: Received control message: ‘PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 89.233.43.71,dhcp-option DNS 91.239.100.100,route 10.12.0.1,topology net30,ping 5,ping-restart 30,ifconfig 10.12.0.58 10.12.0.57’

Wed Oct 28 22:21:03 2015 OPTIONS IMPORT: timers and/or timeouts modified

Wed Oct 28 22:21:03 2015 OPTIONS IMPORT: --ifconfig/up options modified

Wed Oct 28 22:21:03 2015 OPTIONS IMPORT: route options modified

Wed Oct 28 22:21:03 2015 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified

Wed Oct 28 22:21:03 2015 ROUTE_GATEWAY 76.239.66.1/255.255.254.0 IFACE=eth0 HWADDR=0e:2e:7c:cc:66:e7

Wed Oct 28 22:21:03 2015 TUN/TAP device tun3 opened

Wed Oct 28 22:21:03 2015 TUN/TAP TX queue length set to 100

Wed Oct 28 22:21:03 2015 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0

Wed Oct 28 22:21:03 2015 /sbin/ip link set dev tun3 up mtu 1500

Wed Oct 28 22:21:03 2015 /sbin/ip addr add dev tun3 local 10.12.0.58 peer 10.12.0.57

Wed Oct 28 22:21:05 2015 /sbin/ip route add 176.126.237.217/32 via 76.239.66.1

Wed Oct 28 22:21:05 2015 /sbin/ip route add 0.0.0.0/1 via 10.12.0.57

Wed Oct 28 22:21:05 2015 /sbin/ip route add 128.0.0.0/1 via 10.12.0.57

Wed Oct 28 22:21:05 2015 /sbin/ip route add 10.12.0.1/32 via 10.12.0.57

Wed Oct 28 22:21:05 2015 Initialization Sequence Completed

Ne znam da li je povezano(da li je ovde klijent ili server u pitanju) uglavnom ja sam imao problem do skoro da nisam mogao da se nakačim na VPN firme od kuće. A onda sam rešio u temi na Ubuntu forumu: [Rešeno] VPN pristup problem
Ukratko treba da promeniš opseg na ruteru. To je bio moj problem. Opseg VPN-a i mog rutera su bili isti i zato mi nije dao da se nakačim. Kad sam promenio to na ruteru sve mi je radilo.

Ne znam do cega je i da li bi ovo kod mene pomoglo. Juce sam pokusao da se konektujem i bez rutera, ni tada nije radilo.

Danas sam opet pokusao da se spojim, bez rutera samo sa modemom, i nikako ne ide kod mene po uputstvima po kojim se drugi spoje bez problema. Bez problema me vrati sa crtl+c na moju konekciju, do sada sam morao da restartujem komjuter da bih mogao da se ponovo konetkujem (nisam znao za ovu narednu).
Jedino jos sto bih mozda mogao da probam je to da sve deinstaliram i da ponovo instaliram od pocetka. Ako moze neko ko zna da napise naredbe kojim bih mogao da to uradim.