Wireless problem

Pozdrav,
Instalirao sam Mint 14 KDE na laptop. Internet radi normalno preko kabla ali wireless nece nikako. Pise connected, ali ne mogu da otvorim nijedan sajt, cak i ping rutera ne ide. Imam Atheros AR9285 karticu. Probao sam neka resenja koje sam izguglao ali bez uspeha. Cak sam pokusao i sa Mageiom, ali ista prica, mislim da ionako nema veze sa tim koja je distribucija jer sam izmedju ostalog i kompajlirao kod ath9k drivera, pa opet nista. A u Win7 radi normalno. Malo mi je glupo i nezgodno da koristim zicu za internet na laptopu. Zaista bi mi znacilo ako neko zna kako da osposobim wireless.

[email protected] ~ $ uname -a
Linux fb 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:32:08 UTC 2012 i686 i686 i686 GNU/Linux
[email protected] ~ $ ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
^C
— 192.168.0.1 ping statistics —
8 packets transmitted, 0 received, 100% packet loss, time 7056ms

[email protected] ~ $ sudo lshw -class network
*-network
description: Wireless interface
product: AR9285 Wireless Network Adapter (PCI-Express)
vendor: Atheros Communications Inc.
physical id: 0
bus info: [email protected]:03:00.0
logical name: wlan0
version: 01
serial: 5c:ac:4c:14:6b:37
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ath9k driverversion=3.5.0-17-generic firmware=N/A ip=192.168.0.103 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
resources: irq:17 memory:f0500000-f050ffff
*-network
description: Ethernet interface
product: RTL8111/8168B PCI Express Gigabit Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: [email protected]:07:00.0
logical name: eth0
version: 06
serial: 00:23:26:91:d2:59
size: 100Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8168e-2.fw latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
resources: irq:42 ioport:5000(size=256) memory:f0a04000-f0a04fff memory:f0a00000-f0a03fff

Kada si preko žice nakačen jel si upgradeovao sistem i odradio sva ažuriranja?

Pogledaj ovo mozda pomogne
http://askubuntu.com…ss-adapter-work
ili
http://ubuntuforums.org/showthread.php?t=1836867&page=2

jel se povezujes preko pppoe na wirelles, imao sam sličan problem da nece net preko wirellesa, ja sam se povezivao pppoe preko terminala, pa sam instalirao graphic pppoe program i net radi normalno…

@[member=‘msjankovich’] jel si uradio nešto da središ wifi?

Odmah po instalaciji sam uradio apt-get update; apt-get upgrade. Imam kablovski net, ne koristim PPPoE, podešen je automatic DHCP, dobije lokalnu IP adresu, gateway, ali ping ne vraća ništa.
Dragane, već sam dosta tražio i na askubuntu i na ubuntuforums, iz nekog razloga rešenja tamo priložena kod mene ne uspevaju, više ne znam šta dalje… Probaću još jednom sa compat-wireless modulima, možda sam prošli put promašio verziju ili nešto zabrljao u kompajliranju. Ako ne, mogu uvek da probam sa ndiswrapperom i windows drajverom, valjda će bar to da radi.

Kompajlirao si drajver za wifi?

Jesam ovaj:
compat-wireless-3.6.8-1-snp.tar.bz2

To je sa http://linuxwireless.org/en/users/Download/stable/

Ne mogu da se setim ali mislim da sam jednom davno skidao odatle drajver da ga kompajliram na netbook-u (isto imam atheros) i da nije radio a skinuo sam odgovarajući. E sada da li je problem što ja ne znam da ga iskompajliram ili jednostavno se kolje sa kernelom i ne prihvata ga ne znam.

Meni je pomoglo to što sam se nakačio na lan i povukao neke upgrade-e i povukao je medju tim atheros drajver i WiFi je proradio.

Koji laptop je u pitanju?

Fujitsu Lifebook AH530

Konačno sam sredio wireless, sve radi :slight_smile:

Nadam se da će ovo biti od koristi još nekom “nesrećnom korisniku atherosa”:
1 Instalirao sam gore pomenuti backport drajver;
2 Dodao sam liniju “options ath9k nohwcrypt=1” u fajl /etc/modprobe.d/ath9k.conf;
3 Promenio sam WAP/WAP2 protokol sa AUTO(AES/TKIP) u TKIP.
Izgleda da drajver ima problem sa AES-om, čim sam prebacio u TKIP, sve radi normalno, brzina je ok takodje…

Hvala Vladi i ostalima na trudu i pomoći.

Bitno da je rešeno :slight_smile: