xsreensaver ide preko svega

Pitanje jednostavno :

Kako, ali zaboga KAKO, naučiti xscreensaver da se ne pokreće kada je ekran X zauzet. Da li je to moguće nekim editovanjem nekog .conf fajla za xscreensaver. Podesim da se startuje na 1 min., i šta god radio, gledao film i ostale radnje, uvek se startuje screensaver. Third party aplikacije kao što je Caffeine[/url] ne rade više. I sa podešenim caffeine opet screensaver ide preko svega. [url=“https://raw.github.com/hotice/lightsOn/master/lightsOn.sh”]Lights on skripta i ostalo žongliranje preskačem, neću to da radim. Hoću da udarim direktno u srce podešavanja xscreensaver -a i da podesim da se ne aktivira kada je X ekran zauzet. Ako je to moguće !?

Pa isključi ga :connie_crazyperson:. Ja i ne koristim screensavere, samo dpms - a to je već setovano u X, na Debianu je default na 10 minuta (provera sa xset q) I onda da ne reaguje uopšte za neku aplikaciju dok je aktivna može da se stavi u sendvič, recimo:

xset -dpms && iceweasel && xset +dpms

Sad sam video xset ima i s opciju i parametre za screensavere (xset s off, itd) pa bi onda moglo i sa tim kod tebe:

xset s off && firefox && xset s on

i ostalo… pročitaj:

man xset

I držim screensaver isključen, izbacio sam na desktop prečicu za isti, pa onda pre nego se " odaljim " od kompa otvorim pa omogućim screensaver, i tako se igram, sam sebi smešan sa tim radnjama :connie_crazyperson:

man xset je slično kao Caffeine koji trenutno ne radi, po principu kada je aplikacija aktivna, ne aktiviraj screensaver, jel da ? To bi morao posle svakog novog logovanja da kucam. Uglavnom se svodi na to da definišem ime programa ili procesa koji kada je aktivan, screensaver da ćuti.

A jel može da se negde podesi bez konkretne naznake imena procesa, samo da je displej zauzet, i screensaver da se ne pokrene ?
Kao u starom dobrom Gnome 2, sa gnome screensaver -om, gde ništa nije moralo da se čačka.

Ako ti je xscreesaver isključen onda ne bi trebalo da se pali… Moguće je da tebe zeza samo dpms on je setovan na 10 minuta, ako ti se samo ekran zacrni?

Da xset je dinamički tool setovanja ostaju dok ne restaruješ X, možeš dodati tu komandu u autostart ili isključiti preko xorg.conf, ček da nađem… Evo ovako nešto za xorg.conf:

http://www.randombug…rg-xserver.html

Mada mala mu slova, nisam proveravao :connie_crazyperson:, ako češ da gasiš dpms suština je ta.

Mplayer recimo emulira klikove pa se ne gasi ekran, firefox naravno nema pa mora nešto oko toga i flasha ;).

Display je uvek zauzet, i screensaveri i dpms reaguju na inpute, tj. restartuju timer na klikove miša, kucanje po tastaturi…

Ne zeza me dpms, a xscreensaver držim isključen, pa ga ja uključim kada želim. Lakše bi bilo da ga podesim na 10, 15,…20 min, ali da ćuti kada gledam film ili slajdšou sa slikama ili nešto deseto. Kao sav normalan svet koji ima sceensaver ( na winu :connie_crazyperson: ).

Naravno to tako i treba da radi, kod mene i radi mplayer ne gasi se… koji player je u pitanju? Kod mene u config fajlu za mplayer imam linije:

heartbeat-cmd="xscreensaver-command -deactivate &"
stop-xscreensaver="yes"

Šta ? Kod tebe se ne aktivira xscreensaver kada gledaš video sadržaj preko mplayer -a ?

Ja koristim isključivo Smplayer, ali i VLC, puštam slajdšou preko Gwenview, Gthumb, Picasa… ma uvek me screensaver iznenadi, kada je uključen naravno. On jednostavno ne vidi da je X zauzet, da se nešto dešava po ekranu.

Da znam za taj dodatak. Ali poenta je zaobići te pisanije, i podesiti xscreensaver mozak, da se ne pokreće kada se nešto događa po ekranu, najprostije rečeno.

Ne kod mene je sve u redu ;). Pročitaj tačku 21:

http://www.jwz.org/x…nsaver/faq.html

Sve aplikacije od reda moraju da implementiraju to, ako neće da im se pali xsceensaver. Da to ili da emuliraju fake klikove :connie_crazyperson:.

Da ponovim screensaveri i nisu dizajnirani tako da se gase na dešavanje na ekranu, nego da se pale ako kao što rekoh samo reaguju na inpute, pa resetuju interni tajmer.

Auu koje bunarenje… Zašto ? Šta to sa xscreensaver -om nije uredu. On nije dorađen ili šta ? Zašto u Gnome 2 i gnome screensaverom nije moralo ništa da se dira i upisuje ?

Ma jok, sve je u redu za xcreensaverom :connie_crazyperson:. Gnome-screensaver je podešen za Gnome, aplikacije koje koristiš možda prepoznaju samo njega, a ne i xcreensaver ili nešto nije u redu by default sa tim power managmentom u lubuntu.

Evo resimo smplayer ima tu opciju i radi na isti fazon kao kod svih, jel ti čekirano to?

http://www.dodaj.rs/t/H/YW/2TgBwG3x/2012-08-17-002503715x451.jpg

Iliti config ~/.config/smplayer/smplayer.ini

disable_screensaver=true

Jest čekirano je ali ne vredi, ide screensaver preko Smplayera. Izgleda da aplikacije moraju da jure xscreesaver. Tačka 21 koju si predložio da pročitam.

That’s kind of lame, I know. You should ask the author of the movie-playing software you are using to add explicit support for xscreensaver to their program.[list]
When you want to watch a movie, fire up xscreensaver-demo and select Mode: Disable Screen Saver from the option menu, which means not to blank the screen at all. When you’re done watching the movie, re-select your previous mode.
[/list]
If you are the author of movie-playing software:

if (playing && !paused) {
system (“xscreensaver-command -deactivate >&- 2>&- &”);
}
[font=Arial][size=4]Though it would be better to code this using fork() and execvp() instead of system().[/size][/font]

The way you prevent xscreensaver from blanking the screen while a movie is playing is something like this:

Znači kod tebe je Disable Screen Saver izabrano u xcreensaver, ali kao da nije izabrano? Jel ti pali screensaver ili samo zamrači sliku?

Možda screensaver daemon zaboravi podešavanja posle log out log in, možda se pali na dva mesta u login/autostart i slični mogući bugovi u pakovanju… Koje je verzija lubuntu?

Hmmm… da rezimiram fabulu radnje :connie_crazyperson:

Kada je xcreensaver na disable, sve je ok, monitor se ne gasi i naravno ne pokreće se screensaver jer je isključen.

Kada je xscreensaver na enable, podešen na određenu minutažu, startuje se preko filma, youtube -a. tvtime… bilo šta.

Screensaver ili dpms (samo se zacrni ekran)? Mora da razdvojimo ta dva :wink: OK ako je prvo kad je upaljen tamo u opcijama i ukucaš:

xset s off

pa posle toga gledaš film jel se pali onda? To pomaže ili ne?

Inače preko youtube i flasha mora da se pokreće :connie_crazyperson:.

Kada je xscreensaver na enable…

Nema enable ovde, ima Only One Sceen Saver, Blank Sceen Only, Random Screen Saver i Disable Screen Saver.

http://www.dodaj.rs/t/1D/gj/zbEpmY5/2012-08-17-012200716x418.jpg
http://www.dodaj.rs/t/1H/Bb/1TmdOgi/2012-08-17-012029716x418.jpg

Jel upaljen dpms u njemu - ovo sa druge sličice?

Da, Only One Screen Saver = enable, u kontekstu, ali nije bitno…

Pokreće se uvek, u svakom slučaju preko filma

[ATTACH]505.IPB[/ATTACH]

[ATTACH]506.IPB[/ATTACH]

OK koja je verzija xscreensavera, vidim puno sličnih bugova ima oko toga ali šta li je uzrok… :).

http://bugs.debian.o…cgi?bug=678279
http://bugs.debian.o…cgi?bug=684478

Super uspeo sam da ponovim i kod mene :slight_smile: Samo događa se jedino sa smplayerom i gnome-mplayerom.

Sledeći su OK: vlc je ok sa uključenom opcijom i mplayer (bez gui) što koristim ja sa onom gore opcijama u configu, kao i xine - on recimo ima interval za resetovanje od 10 sec by default.

Aha :slight_smile: eksplicitno xset s off uopšte ne funkcioniše, samo resetovanje kao što xine ima xset s reset na svakih 10 sekundi. OK onda znamo šta da tražimo:

http://forum.xfce.or…pic.php?id=7279

Simpatično sad prorade OK u svim programima :), samo sam stavio u openbox autostart komandu za xsreensaver i log out / log in :connie_crazyperson:. Biće da je do toga kako se loaduje u lxde? Pošto može da ide i lokalno i sistemski i u .Xdefaults i sa openboxom i sa lxde sesijom i još toga :slight_smile: . Zato pomenuh duplikate uvek postoji ta problematika sa tim openbox baziranim lxde-om . Ali ponovo na neke inpute kao reaguje, a neke ne, hmm.

Ha, ha, gledam sada source i :slight_smile: nisam znao da imaju screensavere za odrasle, debian ih disejbluje sa 22_hacks_barcode.patch ima 10 tak interesantnih ko voli :wink: može da rebilda ;).

Auuu Tormod Volden maintainer i u Debianu , pa to ide dfsg source skripta da se skloni iz originala. nedaje smiles više… ovako će
svaki pornosaverfil učiti da rebulda debove :connie_crazyperson:

You have posted a message with more emoticons than this community allows. Please reduce the number of emoticons you've added to the message

Koliko je dozvoljeno vlajko 00 Biče da je 10 po poruci

U stvari nije porno samo je Molecule struktura za tako neke droge, preparate za onemoćale, itd .

Ovo je stvarno misterija, kada ide film preko VLC -a xscreensaver se ne pokreće, a pre nedelju dana se pokretao i preko VLC -a, između ostalog, preko svih plejera i browsera. Znači sada je kod mene OK kada gledam preko VLC, kao kod tebe, a ništa nisam radio po tom pitanju. Nije mi za utehu, ja koristim SMplayer, a voleo bih da se screensaver ne pokreće i kada se gleda youtube preko firefoxa, G chroma…

Koju si komandu za xscreensaver ubacio u autostart ?

Ista komanda koja ide i u .desktop file:

xscreensaver -no-splash &

Znači posle je proradilo u svim plejerima, ali i dalje ne reagije na druge stvari - recimo u terminalu ako kucam nešto resetuje tek kada se screensaver pojavi. Firefox je OK kad se mrda miš nego sad sam ga uninstalirao, mora još nešto da probam…

Izgleda da je ovo rupa bez dna. Ne postoji način da xscreensaver nadzire da li je ekran aktivan ?, te shodno tome ostane isključen ( neaktivan ). Nezavisno koja aplikacija koristi displej ( ekran ili kako god ).

NE, to ne. On samo detektuje inpute (pomeranje miša, kucanje na tastaturi, klikove miša) i resetuje tajmer, ništa drugo.

Evo sad sam probao rade svi plejeri, pa i SMPlayer… nego bitnije nešto drugo što sam probao - nakačih PS/2 adapter na žičanu USB tastaturu i sad reaguje na kucanje u terminalu :connie_crazyperson: dok kad je USB detektuje tek kad se screensaver pojavi. Izgleda je tačna tačka 11:

http://www.jwz.org/xscreensaver/faq.html#mouse-idle

Obično koristim tu žičanu tastaturu na USB i bežični RF USB miš. Da testiram malo sad i sa žičanim USB mišom…